Sandboxed dictionaries are displayed even when not logged in

RESOLVED DUPLICATE of bug 375622

Status

RESOLVED DUPLICATE of bug 375622
11 years ago
3 years ago

People

(Reporter: thedarthjysky, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: 2.0.0.9 (20071031)

While trying to install finnish dictionary (https://addons.mozilla.org/en-US/thunderbird/downloads/file/22786/suomen_kielen_oikoluku-0.9.8-fx+tb.xpi) to thunderbird all I get is "Thunderbird could not install the file at *url where xpi file is located on my hard disk* because: Not a valid install package -207"
I've tried this on windows, linux and mac and same result on every platform

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
Install finnish dictionary nicelly and ask for restart

Comment 1

11 years ago
What does `unzip -t path/to/file.xpi` say about that file?  (mac or linux should have that util installed)

What's the checksum?  `sha1sum path/to/file.xpi` on linux
Component: Installer → General
OS: Windows XP → All
QA Contact: installer → general
Hardware: PC → All
Whiteboard: CLOSEME 02/20
Version: unspecified → 2.0
(Reporter)

Comment 2

11 years ago
unzip -t suomen_kielen_oikoluku-0.9.8-fx+tb.xpi
Archive:  suomen_kielen_oikoluku-0.9.8-fx+tb.xpi
  End-of-central-directory signature not found.  Either this file is not a zipfile, or it constitutes one disk of a multi-part archive. In the latter case the central directory and zipfile comment will be found on the last disk(s) of this archive. unzip:  cannot find zipfile directory in one of suomen_kielen_oikoluku-0.9.8-fx+tb.xpi or suomen_kielen_oikoluku-0.9.8-fx+tb.xpi.zip, and cannot find suomen_kielen_oikoluku-0.9.8-fx+tb.xpi.ZIP, period.

sha1sum for suomen_kielen_oikoluku-0.9.8-fx+tb.xpi is f1ed464bc57b9dda7d703d7ede51bc13154147f7
Installed just fine into firefox for me. Though, that's in the sandbox so one need log in to get the file. If you just wget that url or something, you just got the html page for signing in.
(Reporter)

Comment 4

11 years ago
Well I tried install the one from https://addons.mozilla.org/en-US/firefox/downloads/file/22786/suomen_kielen_oikoluku-0.9.8-fx+tb.xpi

And it apears to same file for ff and tb only in different url
https://addons.mozilla.org/en-US/thunderbird/downloads/file/22786/suomen_kielen_oikoluku-0.9.8-fx+tb.xpi

If there is another version somewhere that might be nice, but the one in question is somehow broken. Or am I really onlyone who can't get that one work, even I tried on windows, linux and mac
Tried it once more, and unzip -t  --- worked just fine.
No errors detected in compressed data of suomen_kielen_oikoluku-0.9.8-fx+tb.xpi.

Are you able to install other dictionaries? Other .xpis at all? Maybe you have some overanxious firewall/antivirus program that does bad things. Or then you have some trojan/virus/hacked access point or something.

$ sha1sum suomen_kielen_oikoluku-0.9.8-fx+tb.xpi
be44c00830485d07c12963c37dd8021df78beb04

 == not the same as yours, in comment 2.
The problem seems not to be the package, or that it's sandboxed, so much as that https://addons.mozilla.org/en-US/thunderbird/browse/type:3 lists it even when you aren't logged in, and then passes off the "you must log in" HTML to xpinstall (directly, for Fx, via what you save-as for Tb).
Status: UNCONFIRMED → NEW
Component: General → Dictionaries
Ever confirmed: true
Product: Thunderbird → addons.mozilla.org
QA Contact: general → dictionaries
Summary: Finnish dictionary won't install → Sandboxed dictionaries are displayed even when not logged in
Whiteboard: CLOSEME 02/20
Version: 2.0 → unspecified
Adding myself to CC list. Confirming Phil's assessment. If one is not (registered and) logged on to AMO, the user is served the html logon page as an XPI when the dictionary is pending review (possibly because an earlier version was public). 

Sorry everyone this is really my screw-up (wrt the specific extension as its maintainer).. though I can't fix it myself anymore afaik (extension is pending review).

For a quick fix Jyri, check out mozilla.fi forum page: http://preview.tinyurl.com/34ah98
Indeed. Closing as duplicate.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 375622
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.