dictionary page doesn't honor file status

RESOLVED FIXED in 3.2

Status

--
major
RESOLVED FIXED
12 years ago
3 years ago

People

(Reporter: sancus, Assigned: wenzel)

Tracking

Bug Flags:
blocking-firefox3 -

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
The dictionary page currently displays the most recent version of a dictionary, regardless of the file status of files in that version. It shouldn't use the most recent version if the file is incomplete, disabled, etc.
Severity: major → minor
Target Milestone: --- → 3.x (triaged)

Comment 1

11 years ago
This actually means that while a newer dictionary version is in the review queue, nobody can install the dictionary in question (not even an older version) if they're not logged in. I think that's a pretty major problem - can I suggest updating the severity? (I'd do it myself but I'm not an owner/peer, so you can all figure that out yourself).
Duplicate of this bug: 413334
Duplicate of this bug: 414328

Updated

11 years ago
Duplicate of this bug: 414437
This is very bad for the user experience. Requesting blocking-firefox3
Flags: blocking-firefox3?
Requesting that this be included in an upcoming AMO milestone (3.3 probably - likely too late for 3.2) would be more appropriate; this shouldn't block any release of Firefox, imo.

Updated

11 years ago
Severity: minor → major
Component: Public Pages → Dictionaries
QA Contact: web-ui → dictionaries
Duplicate of this bug: 415774
This does not block the final release of Firefox 3.
Flags: blocking-firefox3? → blocking-firefox3-
(Assignee)

Updated

11 years ago
Duplicate of this bug: 406628
(Assignee)

Updated

11 years ago
Depends on: 414884
Duplicate of this bug: 416533
(Assignee)

Comment 11

11 years ago
The new (=reskin) dictionary page only displays public dictionaries/files.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Duplicate of this bug: 416686

Comment 13

11 years ago
This should be reopened. The Danish dictionary got this issue at the moment.
(Assignee)

Comment 14

11 years ago
(In reply to comment #13)
> This should be reopened. The Danish dictionary got this issue at the moment.

I cannot reproduce this: In the development branch (https://preview.addons.mozilla.org/en-US/firefox/browse/type:3), the Danish dictionary version shown is the last public one, not the one pending review at the moment.

Comment 15

11 years ago
(In reply to comment #14)
> I cannot reproduce this: In the development branch

You're right. Just saw the Version 3.0 and then Resolved Fixed. AMO is passed 3.0 (right?), so I thought it was an error.

Do you have any timeplan for the next version (which looks really cool!), since I can't find any in the wiki?

Comment 16

11 years ago
This bug should be reopened as german de-de, swedish and finnish dictionsaries download alright, but installation does dot succeed at this time. 
(Assignee)

Comment 17

11 years ago
REOPENing because it seems to be big enough a problem on trunk that a solution can't wait until the 3.2 redesign is published.

I will port the fix to trunk.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 18

11 years ago
Created attachment 304199 [details] [diff] [review]
only fetch files with the right status on dictionaries page (AMO trunk only)

This patch fixes it for the trunk: Note that because it is fixed on the reskin branch already, it should not be merged there.

Please review, fligtar so that we can get this out with the next push. Thanks!
Assignee: nobody → fwenzel
Status: REOPENED → ASSIGNED
Attachment #304199 - Flags: review?(fligtar)
Comment on attachment 304199 [details] [diff] [review]
only fetch files with the right status on dictionaries page (AMO trunk only)

r=fligtar

Remember that as of yesterday, this isn't trunk anymore and needs to go into 3.1 branch.
Attachment #304199 - Flags: review?(fligtar) → review+
(Assignee)

Comment 20

11 years ago
Thanks fligtar, also for the 3.1 branch heads-up. This is in SVN, r10626. Marking fixed and push-needed.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago11 years ago
Keywords: push-needed
Resolution: --- → FIXED
Target Milestone: 3.x (triaged) → 3.2

Updated

11 years ago
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.