Lightning forces Thunderbird to English due to shipping sunbird-only files

VERIFIED FIXED in 0.8

Status

Calendar
Build Config
--
major
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: ssitter, Assigned: Fallen)

Tracking

({regression})

unspecified
regression
Dependency tree / graph
Bug Flags:
blocking-calendar0.8 +

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
In the German forum it was reported that after installing Lightning nightly build into a German Thunderbird most other extensions switched from German to English too.

This is caused by Lightning shipping the en-US version of sunbird-l10n.js in <lightning.xpi\defaults\preferences\sunbird-l10n.js>.

Because this file contains the preference
   pref("general.useragent.locale", "en-US");
it overwrites Thunderbirds default value (e.g. "de")

This will also break the import of local specific categories names in Lightning from categories.properties because sunbird-l10n.js already contains the en-US categories.

Other preferences in sunbird-l10n.js are also available from lightning.js file.

Other sunbird-only files in the lightning.xpi are e.g. README.txt and updater.ini and maybe more. They should be removed to reduce download size.

Expected Results:
Lightning doesn't break Thunderbird by shipping sunbird-l10n.js.

The first build that shows the issue is Lightning 0.8pre (2008-01-16-04).
Flags: blocking-calendar0.8?

Updated

10 years ago
Flags: blocking-calendar0.8? → blocking-calendar0.8+
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071031 Lightning/0.8pre Thunderbird/2.0.0.9 (2008012320) ID:2007103104

I can confirm it and let me say: this is really annoying.
(Reporter)

Comment 2

10 years ago
This is most probably a regression from the makefile changes in Bug 352546.
Blocks: 352546
(Assignee)

Comment 3

10 years ago
The problem from a technical side is that the prefs file is also added for lightning, while it is sunbird specific. Here is my proposed solution:


We should create a calendar/sunbird/locales/Makefile.in
  - contains sunbird specific PREF_JS_EXPORTS
  - contains any other sunbird specific stuff from the current 
    calendar/locales/Makefile.in


ause, does this look like a good idea?

Comment 4

10 years ago
yes, moving sunbird specific processing into a sunbird specific directory sounds good.
(Assignee)

Comment 5

10 years ago
Taking care. Lightning seems to work with, I need some fine tuning for Sunbird though.
Assignee: nobody → philipp
(Assignee)

Comment 6

10 years ago
Created attachment 301570 [details] [diff] [review]
The "small" solution

After some coding around ause and I have encountered some problems with the solution as noted earlier.

* LocaleProduct must be adjusted in tinder-config.pl
* calendar/installer could be moved to calendar/sunbird/installer
* calendar/locales/generic possibly needs a move to calendar/sunbird/locales

Also in some initial versions there were some missing variables. We think its better to make a "small" version of this patch to initially fix the bug, then after 0.8 is released, move the remaining sunbird specific locale stuff into sunbird/locales

This patch takes care of this and some other build system problems we have been having. I tested the following, and it works

* Lightning XPI in a en-US thunderbird
* Lightning XPI in a de thunderbird
* Localized Sunbird de
* Non-Localized Sunbird en

I have not tested langpacks, I'm not sure we support them though?
Attachment #301570 - Flags: review?(ause)
(Assignee)

Comment 7

10 years ago
Created attachment 303999 [details] [diff] [review]
The "small" solution - v4

After lots of work and testing this seems to do it.
Attachment #301570 - Attachment is obsolete: true
Attachment #303999 - Flags: review?(ause)
Attachment #301570 - Flags: review?(ause)
Status: NEW → ASSIGNED

Comment 8

10 years ago
Comment on attachment 303999 [details] [diff] [review]
The "small" solution - v4

given a clean build and some tweaks to the german localization, this is the first step in separating core/lightning/sunbird resources...
Attachment #303999 - Flags: review?(ause) → review+
(Assignee)

Comment 9

10 years ago
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.8
(Reporter)

Comment 10

10 years ago
All l10n tinderboxen are busted since the "Bustage fix for bug 413868" checkin at 2008-02-19 02:22; e.g. <http://tinderbox.mozilla.org/Mozilla1.8-l10n-ca/>

make[3]: *** No rule to make target `libs'.  Stop.
make[2]: *** [libs-ca] Error 2
make[1]: *** [langpack-ca] Error 2
make: *** [installers-ca] Error 2

Comment 11

10 years ago
first bustage fix revealed next bustage:
a missing entry in allmakefiles.sh causes l10n builds to miss a makefile in sunbird/locales. fix is on its way
Ause, please note that we need to split the necessary change between branch and trunk. On trunk this needs to go into mozilla/calendar/makefiles.sh

On the branch into mozilla/allmakefiles.sh
(Assignee)

Comment 13

10 years ago
Created attachment 304210 [details] [diff] [review]
[checked in] allmakefiles (branch)
Attachment #304210 - Flags: review?
(Assignee)

Comment 14

10 years ago
Created attachment 304211 [details] [diff] [review]
[checked in] allmakefiles (trunk)

Additional allmakefiles are required.
Attachment #304211 - Flags: review?(ause)

Updated

10 years ago
Attachment #304210 - Flags: review? → review+

Updated

10 years ago
Attachment #304211 - Flags: review?(ause) → review+
Comment on attachment 304210 [details] [diff] [review]
[checked in] allmakefiles (branch)

r=me on build config change
Attachment #304210 - Flags: review+
(Assignee)

Updated

10 years ago
Attachment #304210 - Attachment description: allmakefiles (branch) → [checked in] allmakefiles (branch)
(Assignee)

Updated

10 years ago
Attachment #304211 - Attachment description: allmakefiles (trunk) → [checked in] allmakefiles (trunk)
(Assignee)

Comment 16

10 years ago
Both additional fixes checked in
Blocks: 418585
Reopening, see Bug 418585 comment#1.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

10 years ago
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

10 years ago
Verified using Lightning 0.8pre (2008022001) + Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.9) Gecko/2007103104 Thunderbird/2.0.0.9.

The lightning.xpi still contains the updater.ini file from Sunbird but this doesn't cause any trouble. I'll file a follow bug for this.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

10 years ago
Depends on: 418792
You need to log in before you can comment on or make changes to this bug.