Closed Bug 413961 Opened 14 years ago Closed 14 years ago

chrome://global/skin/arrow/* icons don't show up in high contrast mode

Categories

(Toolkit :: Themes, defect, P2)

1.8 Branch
x86
Windows XP
defect

Tracking

()

RESOLVED FIXED
mozilla1.9beta3

People

(Reporter: dao, Assigned: masa141421356)

References

()

Details

(Keywords: access)

Attachments

(25 files, 13 obsolete files)

56 bytes, image/gif
faaborg
: ui-review+
Details
59 bytes, image/gif
faaborg
: ui-review+
Details
57 bytes, image/gif
faaborg
: ui-review+
Details
57 bytes, image/gif
faaborg
: ui-review+
Details
59 bytes, image/gif
faaborg
: ui-review+
Details
59 bytes, image/gif
faaborg
: ui-review+
Details
57 bytes, image/gif
faaborg
: ui-review+
Details
60 bytes, image/gif
faaborg
: ui-review+
Details
60 bytes, image/gif
faaborg
: ui-review+
Details
54 bytes, image/gif
faaborg
: ui-review+
Details
54 bytes, image/gif
faaborg
: ui-review+
Details
64 bytes, image/gif
faaborg
: ui-review+
Details
57 bytes, image/gif
faaborg
: ui-review+
Details
58 bytes, image/gif
faaborg
: ui-review+
Details
57 bytes, image/gif
faaborg
: ui-review+
Details
53 bytes, image/gif
faaborg
: ui-review+
Details
54 bytes, image/gif
faaborg
: ui-review+
Details
54 bytes, image/gif
faaborg
: ui-review+
Details
54 bytes, image/gif
faaborg
: ui-review+
Details
53 bytes, image/gif
faaborg
: ui-review+
Details
54 bytes, image/gif
faaborg
: ui-review+
Details
54 bytes, image/gif
faaborg
: ui-review+
Details
54 bytes, image/gif
faaborg
: ui-review+
Details
64 bytes, image/gif
faaborg
: ui-review+
Details
54 bytes, image/gif
faaborg
: ui-review+
Details
spin-off from bug 352477, where arrow-dn.gif has been fixed:

(bug 352477 comment 0)
> chrome://global/skin/arrow/arrow-dn.gif does not show up in high conrtrast mode
> 
> I'm running into this with the alltabs button, and from a search in bugzilla,
> it's also being reported in a number of other places.

(bug 352477 comment 9)
> We have a lot of arrows, do we need to update all of them?
> 
> http://mxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/global/arrow/
Summary: chrome://global/skin/arrow/* don't show up in high contrast mode → chrome://global/skin/arrow/* icons don't show up in high contrast mode
Attached image arrow-lft.gif (obsolete) —
Attached image arrow-rit.gif (obsolete) —
Attached image arrow-up.gif (obsolete) —
Smaller than attachement 299137
Attachment #299137 - Attachment is obsolete: true
Attachment #299135 - Attachment is obsolete: true
Attachment #299136 - Attachment is obsolete: true
Attached image /layout/style/arrow.gif
Attached image arrow-dn-sharp.gif
Attached image chevron.gif
I think chevron.gif (">>" mark displayed when many tabs are open) is also needed to fix.
Note that arrow-down.png should be removed. It's used by venkman only, which should switch to arrow-dn.gif.
Assignee: nobody → masa141421356
Attached image arrowd.gif
Attached image arrow-up-sharp.gif
Attached image menulist-arrow.gif (obsolete) —
Is it needed to cahnge menulist-arrow-act.gif and menulist-arrow-dis.gif of pinstripe ?
Status: NEW → ASSIGNED
Comment on attachment 299156 [details]
menulist-arrow.gif

this is pinstripe
Attachment #299156 - Attachment is obsolete: true
(In reply to comment #15)
> Is it needed to cahnge menulist-arrow-act.gif and menulist-arrow-dis.gif of
> pinstripe ?

No.
Attached image chevron-rtl.gif
I changed color of left side of lines.
But it may be better to change color of right side.
(It is impossible to change color of both side , because width of line is only 2px)
Comment on attachment 299138 [details]
arrow-up.gif 5x3 (winstripe/global/arrow)

arrow-up.gif of winstrip
Attachment #299138 - Attachment description: arrow-up.gif rv.2.0 → arrow-up.gif of winstrip
Attachment #299140 - Attachment description: arrwo-lft.gif rv.2.0 → arrwo-lft.gif 11x11 (pinstripe/global/arrow)
Attachment #299138 - Attachment description: arrow-up.gif of winstrip → arrow-up.gif 5x3 (winstripe/global/arrow)
Attachment #299141 - Attachment description: arrow-rit.gif rv.2.0 → arrow-rit.gif 11x11 (pinstripe/global/arrow)
Attachment #299163 - Attachment description: pmstripe/global/arrow/arrow-dn.gif → arrow-dn.gif 8x13 (pmstripe/global/arrow)
Attachment #299164 - Attachment description: pmstripe/global/arrow/arrow-up.gif → arrow-up.gif 8x13 (pmstripe/global/arrow/)
Attachment #299160 - Attachment description: arrow-lft-sharp.gif → arrow-lft-sharp.gif 5x9 (winstripe & pinstripe)
Attachment #299161 - Attachment description: arrow-rit-sharp.gif → arrow-rit-sharp.gif 5x9 (winstripe & pinstripe)
Masahiro, please keep this bug limited to winstripe.
Attachment #299140 - Attachment is obsolete: true
(In reply to comment #28)
> Masahiro, please keep this bug limited to winstripe.
> 

OK. I'll change them to obsolete.

And I have a question.
Is it needed to cahnge arrow-*-dis.gif and arrow-*-hov.gif ?
Attachment #299141 - Attachment is obsolete: true
Attachment #299163 - Attachment is obsolete: true
Attachment #299164 - Attachment is obsolete: true
(In reply to comment #32)
> Is it needed to cahnge arrow-*-dis.gif and arrow-*-hov.gif ?

Not as badly as the others, but using a dark gray theme they can disappear as well, so that's not ideal either.
Attachment #299169 - Attachment is obsolete: true
Attachment #299173 - Attachment is obsolete: true
Attachment #299174 - Attachment is obsolete: true
Attached image arrow-dn-hov.gif
Attached image arrow-lft-hov.gif
Attached image arrow-rit-hov.gif
Attached image arrow-up-hov.gif
Attached image arrow-dn-dis.gif
This image uses color #bfbfbf for edge of arrow.
(Color of arrow is #7f7f7f)
Is there better color for it ?
Attached image arrow-lft-hov.gif
Attached image arrow-rit-dis.gif
Attached image arrow-up-dis.gif
Are there other arrows ?
Attachment #299138 - Flags: ui-review?(faaborg)
Attachment #299146 - Flags: ui-review?(faaborg)
Attachment #299147 - Flags: ui-review?(faaborg)
Attachment #299149 - Flags: ui-review?(faaborg)
Attachment #299152 - Flags: ui-review?(faaborg)
Attachment #299154 - Flags: ui-review?(faaborg)
Attachment #299159 - Flags: ui-review?(faaborg)
Attachment #299160 - Flags: ui-review?(faaborg)
Attachment #299161 - Flags: ui-review?(faaborg)
Attachment #299166 - Flags: ui-review?(faaborg)
Attachment #299172 - Flags: ui-review?(faaborg)
Attachment #299175 - Flags: ui-review?(faaborg)
Attachment #299176 - Flags: ui-review?(faaborg)
Attachment #299177 - Flags: ui-review?(faaborg)
Attachment #299178 - Flags: ui-review?(faaborg)
Attachment #299179 - Flags: ui-review?(faaborg)
Attachment #299180 - Flags: ui-review?(faaborg)
Attachment #299181 - Flags: ui-review?(faaborg)
Attachment #299182 - Flags: ui-review?(faaborg)
Attachment #299183 - Flags: ui-review?(faaborg)
Attachment #299184 - Flags: ui-review?(faaborg)
Attachment #299185 - Flags: ui-review?(faaborg)
Attachment #299168 - Flags: ui-review?(faaborg)
I forgot index optimization at attachment 299167 [details] .
Attachment #299167 - Attachment is obsolete: true
Attachment #299357 - Flags: ui-review?(faaborg)
Attachment #299146 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299147 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299149 - Flags: ui-review?(faaborg) → ui-review+
Comment on attachment 299138 [details]
arrow-up.gif 5x3 (winstripe/global/arrow)

let's use (153,153,153) for the highlight like you have on the other arrows since it stands out more when on a black background.
Comment on attachment 299138 [details]
arrow-up.gif 5x3 (winstripe/global/arrow)

forgot to minus, switch highlight to 153,153,153
Attachment #299138 - Flags: ui-review?(faaborg) → ui-review-
Attachment #299152 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299154 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299159 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299160 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299161 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299166 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299168 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299172 - Flags: ui-review?(faaborg) → ui-review+
Requesting blocking since this is an accessibility issue and low risk (just some image replacements)
Flags: blocking1.9?
Attachment #299175 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299176 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299177 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299178 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299179 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299180 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299181 - Flags: ui-review?(faaborg) → ui-review+
Comment on attachment 299182 [details]
arrow-dn-dis.gif

In high contrast mode on black this is going to get lighter which will make it easier to see.  Kind of counter intuitive, but I don't see an obvious way around the problem.
Attachment #299182 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299183 - Flags: ui-review?(faaborg) → ui-review+
Comment on attachment 299184 [details]
arrow-rit-dis.gif

same problem as the other disabled arrow.  At least the shape is changing so people will be able to eventually infer that this is the disabled state.
Attachment #299184 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299185 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299357 - Flags: ui-review?(faaborg) → ui-review+
Masahiro: thanks for working on this
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
It may be needed to fix chrome://global/skin/tree/columnpicker.gif (See bug 414243).
Attachment #299138 - Attachment is obsolete: true
Attachment #299707 - Flags: ui-review?(faaborg)
Attachment #299707 - Flags: ui-review?(faaborg) → ui-review+
Attachment #299155 - Flags: ui-review?(faaborg)
Attachment #299155 - Flags: ui-review?(faaborg) → ui-review+
a=beltzner for checking in the image replacements for beta 3
Checking in editor/composer/src/res/table-add-column-after-active.gif;
/cvsroot/mozilla/editor/composer/src/res/table-add-column-after-active.gif,v  <--  table-add-column-after-active.gif
new revision: 1.4; previous revision: 1.3
done
Checking in editor/composer/src/res/table-add-column-before-active.gif;
/cvsroot/mozilla/editor/composer/src/res/table-add-column-before-active.gif,v  <--  table-add-column-before-active.gif
new revision: 1.5; previous revision: 1.4
done
Checking in editor/composer/src/res/table-add-row-after-active.gif;
/cvsroot/mozilla/editor/composer/src/res/table-add-row-after-active.gif,v  <--  table-add-row-after-active.gif
new revision: 1.4; previous revision: 1.3
done
Checking in editor/composer/src/res/table-add-row-before-active.gif;
/cvsroot/mozilla/editor/composer/src/res/table-add-row-before-active.gif,v  <--  table-add-row-before-active.gif
new revision: 1.4; previous revision: 1.3
done
Checking in layout/style/arrow.gif;
/cvsroot/mozilla/layout/style/arrow.gif,v  <--  arrow.gif
new revision: 1.4; previous revision: 1.3
done
Checking in layout/style/arrowd.gif;
/cvsroot/mozilla/layout/style/arrowd.gif,v  <--  arrowd.gif
new revision: 3.4; previous revision: 3.3
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-dn-dis.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-dn-dis.gif,v  <--  arrow-dn-dis.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-dn-hov.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-dn-hov.gif,v  <--  arrow-dn-hov.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-dn-sharp.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-dn-sharp.gif,v  <--  arrow-dn-sharp.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-lft-hov.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-lft-hov.gif,v  <--  arrow-lft-hov.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-lft-sharp-end.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-lft-sharp-end.gif,v  <--  arrow-lft-sharp-end.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-lft-sharp.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-lft-sharp.gif,v  <--  arrow-lft-sharp.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-lft.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-lft.gif,v  <--  arrow-lft.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-rit-dis.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-rit-dis.gif,v  <--  arrow-rit-dis.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-rit-hov.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-rit-hov.gif,v  <--  arrow-rit-hov.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-rit-sharp-end.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-rit-sharp-end.gif,v  <--  arrow-rit-sharp-end.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-rit-sharp.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-rit-sharp.gif,v  <--  arrow-rit-sharp.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-rit.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-rit.gif,v  <--  arrow-rit.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-up-dis.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-up-dis.gif,v  <--  arrow-up-dis.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-up-hov.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-up-hov.gif,v  <--  arrow-up-hov.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-up-sharp.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-up-sharp.gif,v  <--  arrow-up-sharp.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/arrow/arrow-up.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/arrow/arrow-up.gif,v  <--  arrow-up.gif
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/global/toolbar/chevron-rtl.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/toolbar/chevron-rtl.gif,v  <--  chevron-rtl.gif
new revision: 1.2; previous revision: 1.1
done
Checking in toolkit/themes/winstripe/global/toolbar/chevron.gif;
/cvsroot/mozilla/toolkit/themes/winstripe/global/toolbar/chevron.gif,v  <--  chevron.gif
new revision: 1.3; previous revision: 1.2
done
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9beta3
Still missing replacements for the following:
* Most of editor/composer/src/res/
* toolkit/themes/winstripe/global/arrow/arrow-down.png
* toolkit/themes/winstripe/global/arrow/arrow-lft-dis.gif
* Some of toolkit/themes/winstripe/global/toolbar/

Of course, need the pinstripe ones (new bug, please!).
Component: XUL Widgets → Themes
QA Contact: xul.widgets → themes
Duplicate of this bug: 352288
You need to log in before you can comment on or make changes to this bug.