Displayed number of new usenet messages is inconsistent

RESOLVED DUPLICATE of bug 79130

Status

MailNews Core
Networking: NNTP
P3
normal
RESOLVED DUPLICATE of bug 79130
17 years ago
9 years ago

People

(Reporter: Henrik Gemal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If you subscribe to:
comp.graphics.apps.paint-shop-pro
and select the newsgroup the "Download header" is shown.
Here you select to download 500 new message and mark the rest read.
Now after the headers are downloaded the newsgroup name have the number of new 
messages shown in () after the newsgroup name.
But it's 1 off!!

It says:
comp.graphics.apps.paint-shop-pro (499)
where it should say:
comp.graphics.apps.paint-shop-pro (500)

Updated

17 years ago
Summary: Number is 1 off → Displayed number of new usenet messages is 1 off

Comment 1

17 years ago
We used to have problems with being 1 off.  I'll see if I can locate that bug.
QA Contact: lchiang → huang

Comment 2

17 years ago
This is the bug I was thinking about, but it appears to have been fixed a while
back.  http://bugzilla.mozilla.org/show_bug.cgi?id=18514
this bug seems to be for # of "new" messages, while that other one is for
"total".

accepting bug.  off by one is not beta2 stopper. moving to m18.
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Reporter)

Comment 4

17 years ago
If you go to any newsgroup with alot of postings and select it you'll get the 
Download Headers dialog.

Here it says:
"There are 806 new message headers.
Download 500 headers and mark the rest read."

After the download I'm getting (468) as the number after the newsgroup!

Are there any messages that are deleted, ignore or anything?
Summary: Displayed number of new usenet messages is 1 off → Displayed number of new usenet messages is wrong
(Reporter)

Comment 5

17 years ago
Seth, where/how do you get the different numbers you display? Like the number in 
the () after the newsgroupname, and the number diaplayed in the Download Headers 
dialog.
Summary: Displayed number of new usenet messages is wrong → Displayed number of new usenet messages is inconsistent

Comment 6

17 years ago
Seth is out of the office for a while.  You may want to post your question to 
the mail-news newsgroup, Henrik. 
Mass moving all NEWS bugs from esther to myself.
QA Contact: huang → stephend
clearing milestone, m17 and m18 are meaningless now.  these need to be triages
along with the rest.
Target Milestone: M18 → ---
*** Bug 70297 has been marked as a duplicate of this bug. ***
Blocks: 71728
*** Bug 111954 has been marked as a duplicate of this bug. ***
OS: Windows 2000 → All
Hardware: PC → All
*** Bug 115465 has been marked as a duplicate of this bug. ***

Comment 12

13 years ago
I have a behaviour that may be related to this bug.
If it isn't I may open a new one.

Sometimes, after several days/weeks, a newsgroup gets a phantom message.
The see it :
-expand the newgroup list of a server ;
-mark a newsgroup read ;
-hide the newsgroup list ;
-expand it anew.

there is a "new message" count of 1, although there is NO new message.

Then, click on the newsgroup : the "1" disappears.

As soon as this behaviour begins with a newsgroup, it is reproducible.
You may close and restart the application : the problem is still there.
I have no way to reproduce the bug from a fresh install.

To fix the problem, you have to delete the msf file associated with the
newsgroup.

As this bug is about a message that is not correctly counted as new, maybe
there has been a patch one day (the bug is 4 years old) that fixed
the problem and hence my bug is related to this one.

Comment 13

13 years ago
(In reply to comment #12)
> To fix the problem, you have to delete the msf file associated with the
> newsgroup.
I was a bit optimitic : the behaviour is correct only the first time you
run mozilla after deleting the file (strange).

Deleting .dat and messages files, unsubscribing to the group and marking the
resubscribed group as read fixed the problem.
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Status: ASSIGNED → NEW
Duplicate of this bug: 322361
Filter on "Nobody_NScomTLD_20080620"
QA Contact: stephend → networking.news
As far as I can tell, the original problem as described was fixed. Henrik's second problem is clearly bug 79130. The third problem may or may not be, but unless anything changes, I'm making this a dupe of 79130.

If this turns out to not be the case, reopen this and block bug 71728.
No longer blocks: 71728
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 79130
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.