Duplicate bookmarks don't show up (hidden, invisible), even in bookmark manager

RESOLVED DUPLICATE of bug 51683

Status

SeaMonkey
Bookmarks & History
P2
normal
RESOLVED DUPLICATE of bug 51683
18 years ago
13 years ago

People

(Reporter: jeffw, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m16) Gecko/20000604
BuildID:    2000060408

Duplicate bookmarks don't show up in either the dropdown bookmark menu or the
bookmark manager.

Reproducible: Always
Steps to Reproduce:
1. Open Mozilla.
2. Load any page that's not already bookmarked.
3. Bookmark the page twice.

Actual Results:  The page appears only once in the bookmarks menu and the
bookmark manager, even though it appears twice in the bookmarks.html file.

Expected Results:  The bookmark should show up twice in the bookmarks menu and
bookmark manager.

I'm not sure what the intended behavior is here. Here's a few methods I can
think of for dealing with duplicate bookmarks:

1. Display bookmarks whether or not they're duplicates. This makes the most
sense to me.
2. Don't allow duplicate bookmarks in the same folder. This seems like a bad
idea, since it could create problems when people moved bookmarks between folders.
3. Don't display duplicate bookmarks in the dropdown menus, but display them in
the bookmark manager. This seems kinda pointless.

But the current behavior allows users to create bookmarks that can't be removed
within the application, and I don't think that's wise.
(Reporter)

Comment 1

18 years ago
I'm uploading a testcase for this bug. Replace your bookmarks.html with the
attachment. It should show 10 consecutive bookmarks to mozilla.org, followed by
one to bugzilla, followed by 10 to mozilla.org. Instead, it just shows one to
mozilla.org and one to bugzilla.
(Reporter)

Comment 2

18 years ago
Created attachment 9597 [details]
bookmark file with duplicate entries

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
Also a bug on Mac OS 8.6/2000061411.  Therefore, I set Platfom to ALL and OS to 

ALL.  Duplicates are stored in the file, and therefore if you delete one in the 

Bookmark Manager, another will appear.  Maybe we should mark as MAJOR or 

CRITICAL as it could lead to a major loss of hard drive space which would be 

hard to recover.

OS: Windows 98 → All
Hardware: PC → All

Comment 4

18 years ago
m18
Target Milestone: --- → M18

Comment 5

18 years ago
*** Bug 43752 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
*** Bug 55175 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 10197

Comment 7

18 years ago
Reassigning 79 Bookmarks bugs to Ben.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → ben
(Reporter)

Comment 8

17 years ago
adding cc
Netscape Nav triage team: this is a Netscape beta stopper.
Keywords: nsbeta1
Priority: P3 → P2

Updated

17 years ago
Target Milestone: M18 → ---

Comment 10

17 years ago
.9, depends on bug 51683?
Depends on: 51683
Target Milestone: --- → mozilla0.9
pushing back
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9 → mozilla1.0
*** Bug 52199 has been marked as a duplicate of this bug. ***
Dup'ed 52199, cleared old nsbeta1 keyword
Keywords: nsbeta1 → mozilla1.0

Comment 14

17 years ago
This is a big pain because they are easy to create just by drag/droping in the
bookmarks manager (not sure why this happens).

Comment 15

17 years ago
And, if there's a shortcut assigned to more than one bookmark, the shortcut 
fails (based on errors with %s).
Target Milestone: mozilla1.0 → mozilla1.1
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 17

16 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Comment 18

16 years ago
Wow, bookmark handling seems to be the only component to actually get worse.

Currently (build 2001122108) it still hides duplicate bookmarks, only the first
instance can be seen. However, there are some new twists:
Duplicate bookmarks in the same folder are now eliminated when loading the
bookmark file. That was NOT a good idea ! It is merely pretending that this bug
is a feature. Try this: create a duplicate, then move the first instance
somewhere else. Close and open the folder. What do you see ?

On top of that, the first instance uses a later instance's name for some reason.
So if you rename the first bookmark, then bookmark the same page, you'll see the
bookmark under the old name again. Combined with the duplicate elimination this
makes for some interesting behaviour.
*** Bug 119706 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
adding a couple of obvious keywords to Summary to help improve search results
and cut down on dupes (like my bug 119706)

also 4xp to Keywords line
Keywords: 4xp
Summary: Duplicate bookmarks don't show up, even in bookmark manager → Duplicate bookmarks don't show up (hidden, invisible), even in bookmark manager
Status: NEW → ASSIGNED
Target Milestone: mozilla1.1 → Future

Comment 21

16 years ago
Update: more fun with duplicates (now at Linux build 2002041711).

1. Bookmark a site (slashdot.org for example) and change the title of the
bookmark  (to just "Slashdot")
2. Move it to a folder on your personal toolbar
3. Bookmark the site again
4. Open the folder on your personal toolbar, the bookmark changed its name back !
5. Open the bookmark manager, notice how both bookmarks have the title YOU
entered, as opposed to the title the personal toolbar is showing

Is it time to open a new bug for this ? I feel like it's still related to
duplicates, but the bookmark manager has become this unholy Cthulhu-like entity,
so I'm not sure...

Comment 22

16 years ago
This is the same bug as bug 51683. It's not a dependency. That one has more
activity. Resolving this one as a dupe of bug 51683. If this is not a dupe, reopen.

*** This bug has been marked as a duplicate of 51683 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
No longer depends on: 51683
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.