Cannot bookmark FTP directories, creates folder instead.

VERIFIED FIXED in mozilla1.0.1

Status

SeaMonkey
Bookmarks & History
P3
major
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Henrik Gemal, Assigned: janv)

Tracking

Trunk
mozilla1.0.1
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

(Reporter)

Description

18 years ago
To reproduce:
- Click Manage Bookmarks
- Open Personal Toolbar Folder
- Rightclick on a bookmark in the Personal Toolbar Folder and select Add 
bookmark
- enter "ftp://ftp.gemal.dk/" in the URL and "test" in the name.

Now the bookmark in shown in the bookmarks as a FOLDER!

Build 2000060420

Comment 1

18 years ago
I think it's a feature. See bug #36224.

Comment 2

18 years ago
I think that's how this is intended to function.  FTP sites are kind of like 
directories, or folders.  marking wontfix, will wait for claudius or slamm 
verify
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 3

18 years ago
VERIFIED. this is how it works
Status: RESOLVED → VERIFIED

Comment 4

17 years ago
*** Bug 69779 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
*** Bug 106329 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
Well, I was going to reopen this, but I can't reproduce it, which I think is a
good thing. When I create a bookmark, I should get a bookmark, not a folder.  If
I want a folder, I'll create a folder.
(Reporter)

Comment 7

17 years ago
some month ago when you create a ftp bookmark it became some sort of psedo
folder. So when you selected it, it made the ftp connection to the ftp site and
displayed the results "inline". This has now been turned off. Thank god!

Comment 8

17 years ago
This still happens when I bookmark a local directory, such as c:\.

Comment 9

17 years ago
I can repro that too.  that's not ftp, but it should work the same way. 
updating summary, reopening
Status: VERIFIED → REOPENED
Resolution: WONTFIX → ---
Summary: ftp bookmarks not created correctly. Created like folder. → Cannot bookmark directories, creates folder instead.

Comment 10

17 years ago
->pchen
Assignee: slamm → pchen
Status: REOPENED → NEW

Comment 11

17 years ago
moving to mozilla1.0.1
Target Milestone: --- → mozilla1.0.1

Comment 12

17 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Comment 13

16 years ago
*** Bug 157175 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
This still happens in Mozilla 1.1, Linux on local directories.  For example I
want a bookmark to file:///opt/gtk2.0/share/gtk-doc/html/, but what I get is a
cascading menu entry going down in the directory tree.  Further more, one can't
select any directory in this cascading menus, only files.

One could have something in the property-dialog for the bookmark that cn be set
so one can choose between the cascading menu style and link-to-directory-only style.
-> Jan for buffy. 
Assignee: ben → varga

Updated

16 years ago
Keywords: nsbeta1

Comment 16

16 years ago
Nav triage team: nsbeta1+/adt2
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt2]
(Assignee)

Comment 17

16 years ago
Okey, I know how to fix it, but this looks much more like a feature.
I need a confirmation that we want to fix it this way.
Basically, fix is easy. Just remove rdf:files from all" datasources" attributes
in bookmarks.xml and navigator.xul
So it means that a directory bookmark won't expand into subdirectories etc,
it will be opened in broser window instead.
Jan, just realized that ftp directories are not caused by rdf:files, they're
rdf:httpindex. this bug may actually be fixed already. No bookmarks UI should
have rdf:httpindex on its datasources list. 
(Assignee)

Comment 19

16 years ago
So, I'm going to close this one.
Please reopen if you think there is still an issue.
Status: NEW → RESOLVED
Last Resolved: 18 years ago16 years ago
Resolution: --- → FIXED

Comment 20

16 years ago
*** Bug 177213 has been marked as a duplicate of this bug. ***
I opened bug 41539, which has been closed as DUP of this bug, and I was
recomennded to add comment to this bug.
But I am not authorized for re-open.
Could someoen re-open this bug?

Problem has bee resolved for FTP site directory case.
But problem still occurs on bookmark of local directory in MS Windows environment.
I could not open bookmark of local directory from (1) Menu/Bookmarks, (2)
Personal Toolbar/Bookmarks.
URI becomes file:///D:/dir-1/dir-2/ or file:///D|/dir-1/dir-2/ usually in
Windows world.

Note:
I could open it through context menu when Personal Toolbar item, Sidebar
bookmark and BookmarkManager.
 ( "Open in new tab" is NOT available in context menu of Sidebar/Bookmarks )
 ( and BookmarkManager. But this is a different problem.)

I guess such treatment of a bookmark of local directory as a bookmark folder is
mainly for IE Favarites.
Expansion of user created normal bookmarks should be deactivated.

If many users believes that a bookmark of local directory will be expaned as a
bookmark folder, user option of a bookmark, normal bookmark mode or IE Favarite
mode, may be a good solution.
DUP bug I opened was bug 177213. Sorry for my mistake.

Comment 23

16 years ago
Either this is NOT resolved, or you have to allow us to create new bugs without
marking them as a duplicate of this one!

I too opened a SEPARATE bug (which will do as a dupe of the one the previous
poster (comment21) mentions), which again had nothing to do with FTP, on the
topic of being unable to bookmark local folders which use the file:// URL.

I am having this problem on Mozilla 1.0 and 1.1.

Since you won't reopen this bug, I'm going to try and de-dupe the bug mentioned
in comment 22. If that fails, I shall just have to log a new bug with the
explanation "this is NOT a dupe of 41539" in it.

Comment 24

16 years ago
This bug (can't bookmark ftp directories) WFM.  I reopened bug 177213 for the
inability to bookmark local folders.  Some of the dups of this bug are actually
dups of 177213.
Status: RESOLVED → VERIFIED
Summary: Cannot bookmark directories, creates folder instead. → Cannot bookmark FTP directories, creates folder instead.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.