Last Comment Bug 415446 - zooming out twice on acid2 and then setting normal zoom screws up rendering
: zooming out twice on acid2 and then setting normal zoom screws up rendering
Status: RESOLVED DUPLICATE of bug 398763
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows 2000
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.webstandards.org/files/aci...
: 417833 (view as bug list)
Depends on:
Blocks: acid2
  Show dependency treegraph
 
Reported: 2008-02-03 08:33 PST by martin
Modified: 2011-09-20 09:07 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
page messed up after zoom+unzoom (5.38 KB, image/png)
2008-02-03 08:35 PST, martin
no flags Details

Description martin 2008-02-03 08:33:17 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

1. open url:
http://www.webstandards.org/files/acid2/test.html#top

2. press CTRL-minus twice to zoom out two levels
3. press CTRL-plus twice to zoom back into normal view/size

Actual results:
Page doesn't look same as when first visited (i.e. zoom+unzoom change the page).

Expected results:
Page should look the same after user has done zoom+unzoom.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 martin 2008-02-03 08:35:38 PST
Created attachment 301130 [details]
page messed up after zoom+unzoom
Comment 2 martin 2008-02-03 08:43:42 PST
As pointed out by someone on IRC, this bug is only reproducible if you run your webbrowser in maximized mode.
Comment 3 Mardeg 2008-02-03 08:51:44 PST
I see this as invalid, since it's the same as pressing Page Down, then Page Up, which causes the same scrolling behaviour, and "default" pass includes not scrolling the test. When the browser is the full height of the screen, this causes the document to scroll, when the browser height is half the screen size, both zoom in/out and page down/up don't mess up acid2.
Comment 4 martin 2008-02-03 08:54:50 PST
As an end user, I find it unintuitive that elements within the page changes their *relative* position when I scroll up and down a page? I'm not familiar with the technical details of how this test is constructed though.
Comment 5 Hixie (not reading bugmail) 2008-02-03 14:35:21 PST
This is likely not a bug. The two bits you see are fixed positioned, and the rest isn't, so if you scroll the page you'll see those bits stay in place while the others move. If you zoom out and then zoom back in you are likely changing your scroll position.
Comment 6 Jesse Ruderman 2008-02-03 17:05:55 PST
>As an end user, I find it unintuitive that elements within the page changes
>their *relative* position when I scroll up and down a page?

That's what position:fixed means :)
Comment 7 Matthias Versen [:Matti] 2008-02-15 17:16:00 PST
*** Bug 417833 has been marked as a duplicate of this bug. ***
Comment 8 Robert Longson 2008-02-18 06:03:18 PST
*** Bug 418235 has been marked as a duplicate of this bug. ***
Comment 9 Damian Shaw [Quan] 2008-02-18 06:14:52 PST
Erm basically in my bug ( Bug 418235 ) I'm asking for the Acid2 test to work on all zoom levels. My argument is not to pass the Acid2 test but so people who need zooming to work should have it work correctly on even awkward web pages. Here's what I wrote:

"Here's what the acid2 guys have to say on zooming in Opera 9:
http://www.webstandards.org/2006/07/20/acid2-and-opera-9-clarifications/

The basic gist of which, is that while zooming should keep a nice smiley face
it's not a prerequisite of the test.

But that's not really the point here, people who 'NEED' zooming to use the
browser should have it work well even on incredibly awkward pages."

I'm fairly sure this bug can be moved to Core::Layout and moved to Trunk.
Comment 10 Jesse Ruderman 2008-02-18 11:50:35 PST
I reopened bug 418235 to cover issues other than scrolling.  The only one I noticed was the background behind the eyes being a pattern of yellow/orange/red rather than solid yellow.
Comment 11 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-09-20 09:07:45 PDT

*** This bug has been marked as a duplicate of bug 398763 ***

Note You need to log in before you can comment on or make changes to this bug.