Closed Bug 418235 Opened 12 years ago Closed 7 years ago

When zoomed, Acid2 eye-background is not yellow

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: zurtex, Unassigned)

References

Details

(Whiteboard: [see also bug 415446/398763 for other issues when zooming])

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b4pre) Gecko/2008021704 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b4pre) Gecko/2008021704 Minefield/3.0b4pre

Though not a prerequisite of passing the Acid2 test it does seem to indicate that zooming doesn't work well enough.

Reproducible: Always

Steps to Reproduce:
1. Take the acid2 test
2. Zoom in or or out
Actual Results:  
Smiley face goes wrong, not too much for zooming in bit by bit, but more when zooming out. Results are amplified when zooming out then zooming in.

Expected Results:  
Should continuously see a nice smiley face.
Here's what the acid2 guys have to say on zooming in Opera 9: http://www.webstandards.org/2006/07/20/acid2-and-opera-9-clarifications/

The basic gist of which, is that while zooming should keep a nice smiley face it's not a prerequisite of the test.

But that's not really the point here, people who 'NEED' zooming to use the browser should have it work well even on incredibly awkward pages.
Component: Disability Access → Layout
Product: Firefox → Core
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 415446
Glad to see someone else has spotted this, but I'm basically asking Acid2 to work at all zooms to provide accessibility for people who need zooms, not just zooming out then back in.

Not to pass the Acid2 test, but to make sure zoom works properly. I don't know how 'close' a bug needs to be, but I am asking something different... Should I make comments on that bug for its remit to be widened? 
I would think that you really ought to find real world web sites that break with zooming if you want to have a wider remit bug.
Thanks, I've come across a few, I'll leave this bug dead and start making a list of websites and make a new bug :-).

Like I say, it's not really a matter of Acid2 test, just awkward web pages in general.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008021801 Minefield/3.0b4pre

As long as I shift-reload after zooming (to fix the scroll position), the only problem I see with the acid 2 face is that the background color behind the eyes is a pattern of yellow/orange/red instead of solid yellow.
/* the two images are identical: 2-by-2 squares with the top left
      and bottom right pixels set to yellow and the other two set to
      transparent. Since they are offset by one pixel from each other,
      the second one paints exactly over the transparent parts of the
      first one, thus creating a solid yellow block. */

Crazy stuff; I'm not surprised that zooming breaks it.
Opera 9.5 does much the same thing.  Hixie claims that this is a bug:

"The eyes go orange if you view the test zoomed in or zoomed out: This is a bug."

http://www.webstandards.org/2006/07/20/acid2-and-opera-9-clarifications/
Reopening: let's make this be about viewing the test zoomed, not about zooming an already-loaded test (which is what bug 415446 seems to be about).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
That test seems to be claiming that any kind of image scaling that uses interpolation is not allowed.
OS: Windows Server 2003 → All
Hardware: PC → All
Summary: Acid2 fails when zooming → Acid2 fails when zoomed
That looks like it's just the scrolling issue (you need to shift+reload), which isn't a bug.
shift+reload doesn't fix it
QA Contact: disability.access → layout
Status: UNCONFIRMED → NEW
Ever confirmed: true
A problem is that when you zoom out too much, and then reset the size (without reloading), the page now does not pass the Acid2 test (you have to reload it to pass)...
I observed this problem in 3.0.6build1 while going through a BFT. As other people mention, when you shift reload the page, the image is rendered correctly. My expectation, however, is that if you zoom in the reference image, and you do the same in the test image, I expect both to look the same.
To me, it still breaks in 3.5.
Flags: wanted1.9.2?
Summary: Acid2 fails when zoomed → When zoomed, Acid2 eye-background is not yellow
Any reason you've decided to change the title? That isn't the only problem with zooming...
If there are multiple problems, there need to be multiple bugs...
Flags: wanted1.9.2?
Flags: wanted1.9.2-
Flags: blocking1.9.2-
And this still breaks in 3.6b2 nightly build as well.
Blocks: 620809
Duplicate of this bug: 687291
No longer depends on: 43114
Whiteboard: [see also bug 415446/398763 for other issues when zooming]
See Also: → 415446, 398763
Blocks: 830731
Duplicate of this bug: 830731
Invalid case, test was created to trip browsers up in normal zoom who didn't implement CSS spec correctly. Anyone who wrote an actual web page like that and expected zoom to work would be told to write cleaner webpages.
Status: NEW → RESOLVED
Closed: 12 years ago7 years ago
Resolution: --- → INVALID
Duplicate of this bug: 869731
Duplicate of this bug: 890445
You need to log in before you can comment on or make changes to this bug.