Moz Can't import from 4.7 Personal Address Book

VERIFIED DUPLICATE of bug 35509

Status

defect
P3
major
VERIFIED DUPLICATE of bug 35509
19 years ago
15 years ago

People

(Reporter: akkzilla, Assigned: sspitzer)

Tracking

({relnote})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: relnote-user)

(Reporter)

Description

19 years ago
I want my PAB on mozilla to be the same as the one I use on 4.7.  So, in 4.7, I
did Export... in the address book and saved to a file, then in mozilla I did
Import... and read the file in. In mozilla's import phase, it asks me which
format I want to use, but only offers one: Text.

If I name the exported 4.7 file abook.nab, then mozilla seems to see it, and
says it imported it, and now the addrbook window has three entries, for PAB,
Collected (even though I have that feature preffed off), and a new one, "abook"
(which was the name of the file).  That wasn't what I wanted -- I wanted the new
entries merged into my PAB -- but it doesn't matter because all three of these
are empty (at least, if I click on them, nothing shows up in the right pane).

If I name the exported 4.7 file abook.ldif, then mozilla gives a warning that no
address books were found, and a new abook line doesn't appear in the left pane
of the abook window.

Is there something I'm doing wrong?  And can I just take that 4.x file and copy
it somewhere into my mozilla hierarchy and have it work as the PAB?

Comment 1

19 years ago
esther - can you help here?  We do have another bug about how the product will
create a new address book rather than put the addresses into Personal Address Book.
QA Contact: lchiang → esther

Comment 2

19 years ago
reassigning to chuang.
Assignee: putterman → chuang
Target Milestone: --- → M17

Comment 3

19 years ago
Export your pab as ldif file, choose text on Mozilla import.  It should import 
to a new address book with the file name.  If you want it to be your pab, 
there are 2 ways for now.
1. It's better you have only one imported address book. Find the "impab.mab" ( 
or "impab-n.mab") file in your profile directory and rename it to "abook.mab". 
2. Select all entries in the imported address book, drag over to your personal 
address book.  This won't work for mailing list though.
Status: NEW → ASSIGNED
(Reporter)

Comment 4

19 years ago
Thanks for the workaround -- now I can use the cool new autocomplete from my PAB!

Comment 5

19 years ago
moving to future.
Target Milestone: M17 → Future
(Reporter)

Comment 6

19 years ago
Future?  You mean, in order to use their old personal addressbooks in 6.0,
people will have to figure out how to rename files by hand?
(Reporter)

Comment 7

19 years ago
Adding relnote keyword: non developer geeks don't have a chance of finding this
bug or figuring this out on their own, and I'd like to have something to point
my friends to when they ask me, which will also tell them how to find their
profile directory on whatever platform they're on.
Keywords: relnote

Updated

19 years ago
Keywords: relnoterelnote2

Updated

19 years ago
Keywords: relnote3
Whiteboard: relnote-user

Comment 8

19 years ago
Changing qa assign to myself.
QA Contact: esther → pmock

Comment 9

18 years ago
Assign it to myself..
QA Contact: pmock → fenella

Comment 10

18 years ago
Linux (2001-05-22-05 trunk)
Win32 (2001-05-22-06 trunk)
Mac (2001-05-21-15 trunk)
I am going to mark this bug worksforme because we can import from 4.7 Personal
Address Book now.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 11

18 years ago
.
Status: RESOLVED → VERIFIED

Comment 12

18 years ago
i'm going to reopen because i have no idea what you're talking about.

First, we in the mozilla bug system is mozilla, which can not import from nc4 (that's some bug that i touched repeatedly today). Second it's generally in poor style for one person to both resolve and verify a bug. Third when resolving worksforme it's appropriate to indicate the steps you took to show that it worked. Ideally in this stage it would have been clear to the average bugzilla.mozilla.org reader that you were using a commercial build and that they should have complained.

For reference, someone filed bug 111159 today which proves akkana's assertion in comment 7.  Reopening puts this bug back on the relnote radar, however i expect that it will be duped against one of the other open bugs.
Status: VERIFIED → REOPENED
Keywords: relnote
Resolution: WORKSFORME → ---

Comment 13

18 years ago
Note: timeless is correct the mozilla builds don't support direct importing of
4.7 address books (in the .na2 format).  As stated above, they still have to
export a book while in 4.7 to a .ldif file and then import into a mozilla build
address book, selecting Text (which give a description that it will import a
.ldif file as well as other text files).   This process works so this bug as
orginally written is worksforme in both commercial and mozilla builds.  A new
bug for mozilla only should be logged or this summary should change to Importing
of a 4.7 address book should be easier for the user to do.  Also note, when
importing we don't import into exisiting address books we import the book as a
separate book.  

Comment 14

18 years ago
*** Bug 114624 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
jatin/endico: please resurrect this relnote for 097 and beyond until the bug as 
currently summarized is fixed.

Comment 16

18 years ago
item readded to release notes

Comment 17

17 years ago
Changing summary from "Can't import from 4.7 Personal Address Book" to
"Moz Can't import from 4.7 Personal Address Book".
QA Contact: fenella → nbaca
Summary: Can't import from 4.7 Personal Address Book → Moz Can't import from 4.7 Personal Address Book
note, mozilla can't import .na2 files like the netscape version can, because 
the libneo code (from 4.x) is 3rd party proprietary.

note, you can export from 4.x to ldif, and then import the ldif.
Assignee: chuang → sspitzer
Status: REOPENED → NEW

Comment 19

17 years ago
*** Bug 153113 has been marked as a duplicate of this bug. ***

Comment 20

17 years ago
If one exports a personal address book from Netscape 4.79, it will be called
Bookmarks.ldif.  This can be renamed, e.g. 'My address book.ldif', so as to
differentiate it from the existing personal address book in Mozilla, and can
then be imported into Mozilla.

Note, though, that if entries in the NS 4 address book did not have 'Prefers to
receive HTML' checked, the resulting entries in Mozilla will be marked 'plain
text' instead of 'unknown'.

Comment 21

17 years ago
dup of bug 35509?

Comment 22

17 years ago

*** This bug has been marked as a duplicate of 35509 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE
vrfy
Status: RESOLVED → VERIFIED

Comment 24

17 years ago
I want my PAB on mozilla to be the same as the one I use on 4.7. I tried to use
the "Import tool", as described in the helps, ad to import "Address Book", bt
the programs shown in the appearing window are only Eudora, Outlook and .TXT (or
others strange formats).
What can I do?
Thenks

Comment 25

17 years ago
The success of the workarounds included here depend on the quality of your 
Netscape address book.  Mine is a mix of addresses enetered manually or 
imported from our Netscape LDAP directory using a variety of UI techniques.  

I can't sucessfully export an LDIF file.  I can export a CSV file, but the data 
is not consistantly organized, so the import into Mozilla is full of cruft. 

This issue is probably the cause of many of the similar bug reports 

Comment 26

17 years ago
Followup:
Using the simple method of creating an address book entry where each field is 
filled with the field name, I determined that exporting the NS4 address book to 
a tab delimited file was the most successful method.  Even then, 
the "Department" field was created in the export file, but not populated.

All personal mailing lists are lost.  Dunno if they're saved in an LDIF export -
 as I said, my PAB wouldn't export to that format (NS hangs).

I could import the tab delimited file into Mozilla, but couldn't get it to be 
the main address book using the file renaming method described above.  I went 
as far as to install NS7, which can directly import PABs from NS4, but the NS7 
importer also hung, perhaps for the same reason that the LDIF exporter hung.

Comment 27

16 years ago
I use Netscape 4.X which works under eCS.
I can't import the addressbook. 
I have read the suggestions and I tried to to what the wrote
It won't work.

How do I go on ?

Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.