Closed Bug 417108 Opened 14 years ago Closed 14 years ago

Copy/paste via Cmd-C/Cmd-V in auth dialogs does nothing

Categories

(Core :: Widget: Cocoa, defect, P2)

x86
macOS
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: kinetik, Assigned: jaas)

References

()

Details

(Keywords: regression)

S.T.R.
1. Visit site with auth dialog
2. Paste into username or password field with Cmd-V

E.R.
Clipboard contents pasted into textbox

A.R.
Clipboard contents do not appear


I just noticed this today, but it looks like it has been broken since late January.  I think this is Mac only (so filed as a Cocoa widget bug), since a Linux build from after this broke does not exhibit the problem.  Pasting via keyboard shortcuts into the location or search bar, textboxes in web pages, or anywhere else I thought to try still works.

Regression range: 2008-01-28 nightly works, 2008-01-29 14:42 hourly is broken.  Looking at the checkins for this range, I suspected the patch for bug #376077.  Backing this out locally on a recently trunk build (fixing up some rejects manually) fixes the problem, so this is definitely a regression caused by that patch.
Keywords: regression
Blocks: 376077
For me this occurs on any window.prompt dialog as well.
I also see this in other "sheets" on Mac, for example, the new string dialog in about:config and the "make link" dialog in the new post page in Movable Type.

I suspect this is generalized to all sheets with text fields.
Duplicate of this bug: 417410
Duplicate of this bug: 417426
Flags: blocking1.9?
Duplicate of this bug: 418258
Duplicate of this bug: 418265
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
Duplicate of this bug: 419011
Duplicate of this bug: 417909
Duplicate of this bug: 420194
fixed by patch on bug 358379
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Duplicate of this bug: 420249
(In reply to comment #10)
> fixed by patch on bug 358379
> 

Shortcuts still don't work in file name text field in Browse For File dialogs.
That is bug 372571.
This bug persists in beta 4.
I don't see it in beta 4, please give specific repro steps if you do.
Specific steps to reproduce in beta 4 for Mac:

1. Copy text into clipboard.
2. Go to http://fedex.com/us/
3. Place cursor in box where you enter a tracking number.
4. Press Cmd-V. Nothing happens.
5. Go to Edit menu - Paste is grayed out
6. Right click in text box - context menu comes up and it does permit pasting contents of clipboard.
I don't know what is going on with that, but this bug is about pasting into auth dialogs (prompts). Perhaps file another bug on what you're seeing.
I file this as a separate bug for beta 3 and it was merged into this one. Should I refile? I'm not sure how to find my original report. I have deleted its number.
No, you shouldn't refile - it's right up the page here, bug 418265, reopened.
Another place I can't shortcut paste is the editor for Blogger posts.
It works in beta4, cmd+V in auth dialog box works
You need to log in before you can comment on or make changes to this bug.