Add an email pref to get notifications for newly created bugs

RESOLVED FIXED in Bugzilla 3.4

Status

()

--
enhancement
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: LpSolit, Assigned: LpSolit)

Tracking

3.1.3
Bugzilla 3.4
Bug Flags:
approval +
testcase +

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Assignee)

Description

11 years ago
I'm currently watching the default QA contact for the Bugzilla product to get email notifications for all bugs being closed and reopened. To do this, I turned on the "The bug is resolved or reopened" email pref when my role is "QA contact". This is working great except this email pref is unable to notify me when a bug is filed, which is as important to me as being notified when the bug is resolved.

There is currently no way to get notifications about new bugs (I don't want subsequent notifications, only when the bug is created, so I don't want to be a global watcher) and I don't think we need another row in the email prefs table. What we should do is to extend the email pref above to also include new bugs.

I would love to have it for 3.2, but it's unfortunately too late for this RFE.
(Assignee)

Comment 1

11 years ago
Created attachment 303073 [details] [diff] [review]
patch, v1
Assignee: email-notifications → LpSolit
Status: NEW → ASSIGNED
Attachment #303073 - Flags: review?(bugzilla-mozilla)
(Assignee)

Comment 2

11 years ago
Created attachment 303076 [details] [diff] [review]
patch, v1.1

I'm updating the description of the email pref, to make sure the user understands what it's doing.
Attachment #303073 - Attachment is obsolete: true
Attachment #303076 - Flags: review?(bugzilla-mozilla)
Attachment #303073 - Flags: review?(bugzilla-mozilla)
(Assignee)

Updated

11 years ago
Duplicate of this bug: 420531
(Assignee)

Comment 4

11 years ago
Per our discussion on IRC and in the developers@ mailing-list, we are going to implement this as a separate email pref to not bother QA people only interested in bugs being resolved.
Summary: The "The bug is resolved or reopened" email pref should also include newly created bugs → Add an email pref to get notifications for newly created bugs
(Assignee)

Updated

11 years ago
Attachment #303076 - Flags: review?(bugzilla-mozilla)
(Assignee)

Comment 5

10 years ago
Created attachment 334279 [details] [diff] [review]
patch, v2

Now implement the new email pref separately.
Attachment #303076 - Attachment is obsolete: true
Attachment #334279 - Flags: review?(mkanat)
(Assignee)

Updated

10 years ago
Target Milestone: Bugzilla 4.0 → Bugzilla 3.4
What would be ideal, actually, is getting notified when a bug lands in a component, whether because it was created there or because it was moved there...
(Assignee)

Comment 7

10 years ago
(In reply to comment #6)
> What would be ideal, actually, is getting notified when a bug lands in a
> component, whether because it was created there or because it was moved
> there...

Wouldn't be difficult to implement. But in my case, I don't care about components very much. I only care about products (which my patch currently doesn't implement; I will update it). I fear tracking moves between components generates too much noise. What do you think? On one hand, as soon as a bug enters your favorite product, you can already track it. On the other hand, I understand that in big products such as Core or Firefox, you don't want to track all new bugs in these products, but only those being in components you are focusing on.

More feedback from other users would be interesting.
My use case is that I want to be notified whenever a bug is added to a component I'm module owner or peer for.   As you noted, watching all of Core is a non-starter.
Note that I _already_ get notified on the moves into components, since I watch their default QA contact.  I just want to get _less_ mail, by not watching the QA contact and instead getting mail only when bugs come in, not every time some doofus adds another pointless comment on a spam-fest.
(Assignee)

Comment 10

10 years ago
Created attachment 337319 [details] [diff] [review]
patch, v3

The email pref now triggers bugmail on both bug creation and bug move into another product/component.
Attachment #334279 - Attachment is obsolete: true
Attachment #337319 - Flags: review?(mkanat)
Attachment #334279 - Flags: review?(mkanat)

Comment 11

10 years ago
No, it should only trigger on New bugs. We can have a separate email preference for moving between products and components. Just because combining those prefs might make sense for bmo, doesn't mean that it makes sense anywhere else.
(Assignee)

Updated

10 years ago
Attachment #334279 - Attachment is obsolete: false
Attachment #334279 - Flags: review?(mkanat)
(Assignee)

Comment 12

10 years ago
Comment on attachment 334279 [details] [diff] [review]
patch, v2

I really don't mind if we have one or two email pref for that. Review the one you want.

Updated

10 years ago
Attachment #337319 - Flags: review?(mkanat)

Comment 13

10 years ago
Comment on attachment 334279 [details] [diff] [review]
patch, v2

Wow, that's really all it takes? Our email prefs architecture isn't so bad, then, I guess. :-)

Okay, this looks great to me.
Attachment #334279 - Flags: review?(mkanat) → review+

Updated

10 years ago
Flags: approval+
(Assignee)

Updated

10 years ago
Attachment #337319 - Attachment is obsolete: true
(Assignee)

Comment 14

10 years ago
Checking in Bugzilla/Constants.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Constants.pm,v  <--  Constants.pm
new revision: 1.97; previous revision: 1.96
done
Checking in Bugzilla/User.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/User.pm,v  <--  User.pm
new revision: 1.174; previous revision: 1.173
done
Checking in template/en/default/account/prefs/email.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/account/prefs/email.html.tmpl,v  <--  email.html.tmpl
new revision: 1.31; previous revision: 1.30
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: relnote
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Flags: testcase?(wicked)
Flags: testcase?(wicked) → testcase+

Comment 15

9 years ago
Added to the release notes for Bugzilla 3.4 in bug 494037.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.