unresponsive script warning dialog has reversed icons

VERIFIED FIXED in mozilla1.9.3a1

Status

()

Core
DOM
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: Matěj Cepl, Assigned: Sylvain Pasche)

Tracking

Trunk
mozilla1.9.3a1
x86
Linux
Points:
---

Firefox Tracking Flags

(status1.9.2 .7-fixed)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; cs; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; cs; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3

Originally from the Red Hat Bugzilla:

In the "Unresponsive script" dialog, "continue" should be labelled as the "arrow" and "stop script" be the "x" (currently, "stop script" is labelled with arrow, and "continue" has nothing).


Reproducible: Always

Steps to Reproduce:
1. see above
2.
3.
Actual Results:  
see the image attached to this bug

Expected Results:  
Continue should be labelled with arrow, and Stop script with Cross or something.
(Reporter)

Comment 1

10 years ago
Created attachment 305534 [details]
FF2 screenshot of the dialog
(Assignee)

Comment 2

10 years ago
Firefox 3 screenshot: see attachment 323426 [details]
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
(Assignee)

Updated

10 years ago
Duplicate of this bug: 436910
Component: General → Theme
QA Contact: general → theme
Duplicate of this bug: 463178

Updated

9 years ago
Component: Theme → DOM
Product: Firefox → Core
QA Contact: theme → general

Updated

9 years ago
Summary: firefox script warning dialog has icons reversed → unresponsive script warning dialog has reversed icons
Duplicate of this bug: 491042

Comment 6

9 years ago
Ubuntu Bug:
https://bugs.launchpad.net/bugs/127960

Still a problem in Firefox 3.5 and 3.7 (trunk)
Component: DOM → Themes
Product: Core → Toolkit
QA Contact: general → themes
(Assignee)

Updated

9 years ago
Component: Themes → DOM
Product: Toolkit → Core
QA Contact: themes → general
(Assignee)

Comment 7

9 years ago
Created attachment 395217 [details] [diff] [review]
patch

nsIPrompt assumes that the button at position 0 has an ok/yes icon and the one at position 1 cancel/no. That's only meaningful for Linux as other OSes don't show icons there.
Assignee: nobody → sylvain.pasche
Status: NEW → ASSIGNED
Attachment #395217 - Flags: review?(jst)

Updated

8 years ago
Attachment #395217 - Flags: superreview+
Attachment #395217 - Flags: review?(jst)
Attachment #395217 - Flags: review+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/ba9cb47432a6
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
(Assignee)

Comment 9

8 years ago
Verified fixed on trunk with build Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091026 Minefield/3.7a1pre on Linux Ubuntu 9.04 32bit.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Attachment #395217 - Flags: approval1.9.2.2?
Attachment #395217 - Flags: approval1.9.2.2? → approval1.9.2.3?

Updated

8 years ago

Comment 10

8 years ago
Comment on attachment 395217 [details] [diff] [review]
patch

a=LegNeato for 1.9.2.5. Please ONLY land this on mozilla-1.9.2 default, as we
are still working on 1.9.2.4 on the relbranch
Attachment #395217 - Flags: approval1.9.2.4? → approval1.9.2.5+
(Assignee)

Comment 11

8 years ago
If someone could land it on branch for me, that would be terrific.
Keywords: checkin-needed
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/5fa8c4f2c1dc
status1.9.2: --- → .6-fixed
Keywords: checkin-needed
Attachment #395217 - Flags: approval1.9.2.5+ → approval1.9.2.6+
You need to log in before you can comment on or make changes to this bug.