Last Comment Bug 419490 - NS_ERROR_OUT_OF_MEMORY exception when creating certain monthly repeating events
: NS_ERROR_OUT_OF_MEMORY exception when creating certain monthly repeating events
Status: RESOLVED FIXED
: dataloss
Product: Calendar
Classification: Client Software
Component: Internal Components (show other bugs)
: Sunbird 0.9
: All All
-- critical with 3 votes (vote)
: 4.0.0.1
Assigned To: Decathlon
:
:
Mentors:
: 466520 514946 619037 957870 1147356 (view as bug list)
Depends on:
Blocks: 466520
  Show dependency treegraph
 
Reported: 2008-02-25 10:44 PST by Stefan Sitter
Modified: 2015-03-25 13:37 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Stefan Sitter 2008-02-25 10:44:13 PST
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13pre) Gecko/2008022505 Calendar/0.8pre

Steps to Reproduce
1. Create new event that repeats monthly
2. Open the Edit Recurrence dialog and select a 'every Xth weekday' rule that specifies a day that is not part of the month the events starts in. For example if the events starts in February 2008 select 'every 5th Monday'.
3. Check recurrence preview. Save event and check the view.

Actual Results:
Preview doesn't update after selecting the rule from above. 
The view doesn't show the event. 
Error Console shows many NS_ERROR_OUT_OF_MEMORY exceptions from views / minimonth / composite calendar containing:

Error: uncaught exception: [Exception... "Component returned failure code: 0x8007000e (NS_ERROR_OUT_OF_MEMORY) [calIRecurrenceItem.getOccurrences]"  nsresult: "0x8007000e (NS_ERROR_OUT_OF_MEMORY)"  location: "JS frame :: file:///E:/sunbird/js/calRecurrenceInfo.js :: anonymous :: line 409"  data: no]
Comment 1 User image Pete Riley 2008-02-28 07:16:27 PST
Seems like this causes dataloss (except for users who know how to find the event in the unifinder).  --> Severity: Major or Critical?
Comment 2 User image Stefan Sitter 2008-12-19 07:46:44 PST
*** Bug 466520 has been marked as a duplicate of this bug. ***
Comment 3 User image Philipp Kewisch [:Fallen] 2010-03-07 08:31:02 PST
*** Bug 514946 has been marked as a duplicate of this bug. ***
Comment 4 User image Paul Schulze 2010-12-15 00:45:01 PST
*** Bug 619037 has been marked as a duplicate of this bug. ***
Comment 5 User image Philipp Kewisch [:Fallen] 2011-12-13 08:29:50 PST
This bug could likely be solved by updating to the latest libical. I remember seeing a patch that at some point stopped calculation if it had too many iterations.
Comment 6 User image Stefan Sitter 2011-12-13 08:54:01 PST
Still exists in Lightning 1.3a1 + Mozilla/5.0 (Windows NT 6.1; rv:11.0a1) Gecko/20111213 Thunderbird/11.0a1. I get the error message shown below followed by different call stacks:

Error: uncaught exception: [Exception... "Component returned failure code: 0x8007000e (NS_ERROR_OUT_OF_MEMORY) [calIRecurrenceItem.getOccurrences]"  nsresult: "0x8007000e (NS_ERROR_OUT_OF_MEMORY)"  location: "JS frame :: [...]/calendar-js/calRecurrenceInfo.js :: cRI_calculateDates :: line 537"  data: no]
Comment 7 User image Paul Schulze 2012-04-12 11:53:46 PDT
Still existing. For me the engine of a calendar should be very trustworthy. Adding events like "The fifth wednesday every month" seems to be a rare thing of course, but the engine should be able to handle it stable! Disappearance of ALL events after adding things like this, makes me really feel ugly about the safety of my important appointments.
Comment 8 User image Wayne Mery (:wsmwk, NI for questions) 2013-09-30 03:58:02 PDT
(In reply to Pete Riley from comment #1)
> Seems like this causes dataloss (except for users who know how to find the
> event in the unifinder).  --> Severity: Major or Critical?

Does event really go "missing" to the user?
Comment 9 User image Philipp Kewisch [:Fallen] 2014-03-02 10:44:24 PST
*** Bug 957870 has been marked as a duplicate of this bug. ***
Comment 10 User image Decathlon 2015-02-22 01:33:08 PST
This bug has been corrected with the patch for bug 958974.
Since the unit test now has a specific test that creates a monthly event on a fifth weekday of February, I set the bug to fixed. I'd be glad if someone else could verify.
Comment 11 User image Stefan Sitter 2015-03-25 13:37:25 PDT
*** Bug 1147356 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.