Link in Thunderbird mail doesn't open web site

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
11 years ago
10 years ago

People

(Reporter: rolandmiller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30)
Build Identifier: Internet Explorer version 7.05730.11

When I click on a link in  Thunderbird mail, my Internet Explorer browser opens, but the web site doesn't open.  The same happens if I click on Release Notes or Mozilla Thunderbird help.  If I copy the link and paste it in the Internet Explorer browser, the web site does open, but this requires an two extra steps.  How can I get the link to load in the Internet Explorer browser when it opens.  

Reproducible: Always

Steps to Reproduce:
1.  Cl;ick on link in email message
2.
3.
You probably have to reset the default browser. (Set some other browser in between, then the preferred one again.)

Comment 2

11 years ago
could be duplicate bug 393927 ..
Not so likely (I doubt this bug was for trunk).
Roland: did you try comment 1? Still a problem?
Duplicate of this bug: 478971
Roland did resetting you default browser work ?
Whiteboard: closeme 2009-03-12
RESO INCO due to lack of response to last question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Whiteboard: closeme 2009-03-12
Created attachment 367215 [details]
A message containing a link that does not open

I've just experienced this bug with the attached email. Might be a configuration Error. I experienced it on Mac/Shredder beta3pre.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #7)
> Created an attachment (id=367215) [details]
> A message containing a link that does not open
> 
> I've just experienced this bug with the attached email. Might be a
> configuration Error. I experienced it on Mac/Shredder beta3pre.

That email looks like its been modified/generated wrong. When I decode the source I see:

<A 
title=blocked::http://sciences.blogs.liberation.fr/home/2009/02/un-astronome-la.html 
href="blocked::http://sciences.blogs.liberation.fr/home/2009/02/un-astronome-la.html">http://sciences.blogs.liberation.fr/home/2009/02/un-astronome-la.html</A>

I think what we're doing there is assuming the protocol scheme is "blocked" and not "http".
(In reply to comment #8)
> I think what we're doing there is assuming the protocol scheme is "blocked" and
> not "http".

That's the visual feedback I get when hoovering over the link.
According to the google, Outlook has a "security" "feature" which will put up a "Opening Other Programs Is Scary And Bad" warning when you click links in email, which it does by rewriting the URLs to blocked::http::.

Sure, anyone who gave it two minutes thought would realize that people will copy-paste those blocked::http:: links into mail that they then send to other people, but if those other people aren't also using Outlook and thus don't just get the "Scary And Bad" dialog, screw 'em.

However, that's absolutely and unquestionably _not this bug_, since comment 0 talks about the relnote menuitem as well as links.
Status: NEW → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.