Closed Bug 420669 Opened 12 years ago Closed 2 years ago

[10.5] Command+Delete does not delete to the line beginning (deletes all text instead)

Categories

(Core :: Widget: Cocoa, defect, P3)

All
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
thunderbird_esr52 --- wontfix
thunderbird_esr60 --- wontfix
firefox-esr52 --- wontfix
firefox-esr60 --- wontfix
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- fixed

People

(Reporter: louise6380, Assigned: mstange)

References

Details

(Whiteboard: tpi:+)

Attachments

(2 obsolete files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008030204 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008030204 Minefield/3.0b4pre

Command+Delete should delete from the cursor to the beginning of the line.

Reproducible: Always

Steps to Reproduce:
1.write anything in text area, search box, location bar
2.hit Command+delete
3.
Actual Results:  
nothing happens

Expected Results:  
characters between the cursor and the beginning of the line should be deleted.
Version: unspecified → Trunk
Component: OS Integration → Widget: Cocoa
Product: Firefox → Core
Confirming; this is a feature of the NSText*, at least on Mac OS X 10.5 (try Safari, Stickies, TextEdit).  I'm not sure if it was added in 10.4 or 10.5, but we may as well support it.

I thought this was just a missing binding in platformHTMLBindings.xml, but after adding the appropriate binding (next to the binding for opt-delete, wherever the latter occurs; see bug 285529 for that fix), I still didn't have this working :-(

Something else must be interfering here.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Smokey, this was definitely added in 10.5. I'm not able to get this shortcut working under 10.4 in each of the Apple applications. It only works for the Finder where it deletes the selected file(s). Updating summary accordingly.
Hardware: Macintosh → All
Summary: [Mac] Command+Delete does not delete to the line beginning → [10.5] Command+Delete does not delete to the line beginning
Severity: normal → minor
Assignee: nobody → joshmoz
QA Contact: os.integration → cocoa
Assignee: joshmoz → nobody
Duplicate of this bug: 565144
This is still an issue in 17.0.6 on 10.8.3.
Ignore the comment above...  That's the last time I test editing commands in a bug comment box.  The dependency change is correct at least!
In 2015-01-05 Nightly, command-delete now empties the whole field, regardless of where the caret is. For example, if you type this into the search box, with the caret positioned as indicated...

    hello there| world

...and hit command-delete, all 3 words go away. Only "hello there" should.
To clarify: when bug 282097 was fixed in Firefox 25 (sometime in 2013), the Command+Delete shortcut got mapped to |cmd_deleteToBeginningOfLine|: http://hg.mozilla.org/mozilla-central/rev/4bb128a0bcef#l3.69

Before this change it had no effect, after the change it started clearing the whole text field, as cmd_deleteToBeginningOfLine had this bug for a long time (bug 426246). Fixing the binding to delete to the beginning of the line instead of clearing the whole textbox must happen in bug 426246.

Changing the summary to reflect the current status.
Summary: [10.5] Command+Delete does not delete to the line beginning → [10.5] Command+Delete does not delete to the line beginning (deletes all text instead)
Attachment #506050 - Attachment is obsolete: true
Duplicate of this bug: 1215973
Duplicate of this bug: 1248167
Severity: minor → normal
Priority: -- → P2
Whiteboard: tpi:+
Priority: P2 → P3
Duplicate of this bug: 1417369
Is there a workaround? Some extension or something?

I can understand why people don't see this as a priority. If you have been working with this bug present (for ten years now) then I am sure you don't depend on the usage of `command + delete`, however, as a Chrome user that tries to switch, this is highly annoying and one of the reasons I keep going back to Chrome.
I've attached a fix to bug 426246, which, as far as I can tell, is the only part of this bug that remains.
Here's a try build with that fix included: https://taskcluster-artifacts.net/SRA-ZO3QTyO9DXirZlGjEQ/0/public/build/target.dmg

Can you test that build and report whether it works the way you expect?
Flags: needinfo?(basnijholt)
Wow, this is what I love about open-source!

I write on a 10-year-old issue that kept bugging me for years, 8 hours later it's fixed!

I can confirm that it works the way I expect. 

Thanks a lot for the quick fix 
Flags: needinfo?(basnijholt)
Bug 426246 has landed, so this should be fixed on Nightly now.
Assignee: nobody → mstange
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Thank you!!!
QA Whiteboard: [good first verify]

I just saw the notification email about this, so I tried it. Not sure if it's in scope, but I see two ways it still doesn't act quite the same as other Mac text areas:

  • After undo, Firefox leaves the cursor at the end of the re-added text. Other Mac applications leave the re-added text selected.

  • Command-delete on an empty line in Firefox does nothing. In other Mac applications, it deletes the previous (newline) character.

You need to log in before you can comment on or make changes to this bug.