All users were logged out of Bugzilla on October 13th, 2018

Gmail chat and navigation is broken

VERIFIED FIXED

Status

()

P1
critical
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: Peter6, Unassigned)

Tracking

({dogfood, regression})

Trunk
dogfood, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030613 Minefield/3.0b5pre ID:2008030613

repro:
open Gmail
click on [Chat] , [Labels] or [Invite a friend] (left column)

result:
those menus won't expand

now click on [Send mail]

result:
nothing happens, you can't access anything but your inbox

regressionwindow:
works in 20080306_1109_firefox-3.0b5pre.en-US.win32
fails in 20080306_1241_firefox-3.0b5pre.en-US.win32
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&filetype=match&whotype=match&sortby=Date&hours=2&date=explicit&mindate=1204830540&maxdate=1204836059&cvsroot=%2Fcvsroot

Updated

11 years ago
Flags: blocking1.9?
Version: unspecified → Trunk
All sorts of stuff in that range that could conceivably cause this sort of effect in gmail depending on how evil it's being: bug 420700, bug 420966, bug 420647, bug 420642, bug 420585.

Are there any errors in the error console?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030708 Minefield/3.0b5pre ID:2008030708

Whilst clicking the Chat link in the gmail sidebar, I get

Error: this.Qoa is undefined
Source file: https://mail.google.com/mail/?ui=2&view=js&name=js&ids=1fw6vr42tnziw
Line: 1093

I don't see any of the other links that are now no longer working throwing anything.
(Reporter)

Comment 3

11 years ago
Nothing in the Errorconsole (2) at all Boris.
+'ing this w/ P2.  

Boris, under which component does this bug fit?  Any idea?

Also, seems to work OK in OS X.
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
Not off the top of my head, sorry...
(Reporter)

Comment 6

11 years ago
What I have also seen is that I can't submit a post on moz forums.
The submit seems to happen (throbber spinning) but the post never makes it.
With a pre regression build it works fine right a way.
I can't properly reproduce the above though, but it happened even after several FF restarts.
On Linux, I can narrow this down to
works in 20080306_1116_firefox-3.0b5pre.en-US.linux-i686.tar.bz2 
fails in 20080306_1208_firefox-3.0b5pre.en-US.linux-i686.tar.bz2
Bonsai:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1204830960&maxdate=1204834079

My test was whether the chat sidebar was populated with contacts or not. 

I get this single error in the console (and the usual squillion css warnings)
Error: aT is not a constructor
Source File: https://mail.google.com/mail/?ui=2&view=js&name=js&ids=1dgpb0bm4mmnf
Line: 1096

So bug 420966 or bug 420840 ? CC'ing mrbkap

Updated

11 years ago
Keywords: dogfood

Comment 8

11 years ago
(In reply to comment #6)
> What I have also seen is that I can't submit a post on moz forums.
> The submit seems to happen (throbber spinning) but the post never makes it.
> With a pre regression build it works fine right a way.
> I can't properly reproduce the above though, but it happened even after several
> FF restarts.
>
On OS X, I can submit a forum post, but can't edit it (the edit never gets submitted, dropping me back in 'preview'). No errors in the error console.

On Gmail, as long as I don't touch the 'chat' link, it seems to work well.

OS: Windows XP → All
Hardware: PC → All
(Reporter)

Updated

11 years ago
Duplicate of this bug: 421642
Anyone willing to go through the hook, trying builds with each patch added in turn to an initially pre-hook build?

/be
Boldly raising to P1 -- we can't really ship beta5 with this broken.  (Trying to think of another outstanding bug that would trump "big chunks of gmail broken" and failing so far, too. :) )
Priority: P2 → P1

Updated

11 years ago
Duplicate of this bug: 421696
(Reporter)

Updated

11 years ago
Summary: Gmail navigation is broken → Gmail chat and navigation is broken

Comment 13

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030806 Minefield/3.0b5pre
Contacts is broken too
(Reporter)

Comment 14

11 years ago
(In reply to comment #13)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030806
> Minefield/3.0b5pre
> Contacts is broken too
> 
Contacts has been broken for month, a bug was filed but marked WONTFIX because it is a Google mistake/error/problem.
(Reporter)

Comment 15

11 years ago
my last comment refers to Bug 415252
I went through the regression range in comment 7, starting with a pull-by-date of 2008-03-06 11:16 PST, where I confirmed that I did not see the bug.

1) added the patch for bug 420480, and rebuilt js/src. No bug.
2) added the patch for bug 420585, and rebuilt in js/src/xpconnect. No bug.
3) added the patch for bug 420642, and rebuilt in js/src/xpconnect. Reproduced the bug.
4) removed the patch for bug 420642, and rebuilt in js/src/xpconnect. No bug.

This implicates the patch for bug 420642.
Blocks: 420642

Comment 17

11 years ago
Am I the only one who can't open emails in gmail either?

Comment 18

11 years ago
Nope I can't open emails in gmail either, but only since the latest minefield (20080309). Worked fine with 20080308.
(In reply to comment #17)
> Am I the only one who can't open emails in gmail either?

See bug 421802 for this issue

Comment 20

11 years ago
421802 is definitely dependent on this bug being fixed. It only occurs after the chat sidebar has been clicked. The bug does NOT occur if either of the "Invite a friend" or "Labels" sidebars are clicked. I'm going to put a dependency on this bug being fixed.

Updated

11 years ago
Blocks: 421802
Yeah, expanding the Chat sidebar triggers it for me.

Comment 22

11 years ago
(In reply to comment #21)
> Yeah, expanding the Chat sidebar triggers it for me.
> 

Hey Mike should I mark 421802 as a dup for this bug. Brendan Eich originally asked me to write a seperate bug, but it's become more apparent to me now that it has a heavy dependency on this issue, and should probably be considered a duplicate?
(I see tons of warnings about undefined properties in the console, but they're warnings, so you have to filter out the CSS ones by eye, alas.)

David: yeah, in light of the STR discoveries, I think you should DUP it.  Thanks!

Updated

11 years ago
Duplicate of this bug: 421802
(In reply to comment #16)
> This implicates the patch for bug 420642.

I'm not going to be able to do anything about this until tomorrow. Somebody should feel free to back out bug 420642 to fix this bug (and, as brendan would say, restore the trunk's honor).
(In reply to comment #25)
> I'm not going to be able to do anything about this until tomorrow. Somebody
> should feel free to back out bug 420642 to fix this bug (and, as brendan would
> say, restore the trunk's honor).

Done. Going to mark this FIXED (should be in the next hourlies, and today's nightly in ~5hours).
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 27

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031004 Minefield/3.0b5pre

Chat is fixed. But navigation is still broken

Comment 28

11 years ago
(In reply to comment #27)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031004
> Minefield/3.0b5pre
> 
> Chat is fixed. But navigation is still broken
> 
Hey Pascale, I just downloaded the new nightly you appear to be saying has broken navigation. I'm not sure exactly what you mean by navigation?
The regressions that caused the char menu to screw everything up have been backed out, so it works fine for me.

Comment 29

11 years ago
At first: My name isn't Pascale. I'm Pascal.

The url is e.g. http://mail.google.com/mail/#settings

That means Gmail shows you the settings. Every mail has got a different number in the url and so you can navigate using the browser's buttons.

It only works in Gmail 2.0

http://gmailblog.blogspot.com/2007/10/code-changes-to-prepare-gmail-for.html

Comment 30

11 years ago
Apologies for spelling your name incorrectly Pascal. I've tried to reproduce the navigation issue you mention, but the back and forward buttons work for me in the browser.
The steps I use are as follows:
1. Open GMail.
2. Click on a mail to open it.
3. Click the back button in Firefox to return to the inbox
4. Once returned to the Inbox, I click the firefox forward button to go back to the mail.

All of the above steps produce the expected behaviour for me. Is there something else I'm not testing?
(Reporter)

Comment 31

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031002 Minefield/3.0b5pre ID:2008031002

VERIFIED/FIXED
Status: RESOLVED → VERIFIED

Comment 32

11 years ago
@David: Yes.

After a restart it works.
Pascal, not clear at all what your comment #32 is referring to. If you have a clear and detailed set of steps for reproducing your problem, and it exists when running Firefox in its safe mode, then please file another bug with that information. 
Duplicate of this bug: 421919
You need to log in before you can comment on or make changes to this bug.