Firefox with he/ar UI displays print headers reversed for non-rtl pages

RESOLVED FIXED

Status

()

defect
P1
normal
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: tomer, Assigned: smontagu)

Tracking

(Blocks 1 bug, {rtl})

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(3 attachments)

Reporter

Description

11 years ago
When I try to print English page from Firefox with Hebrew layout, I gets the print headers reversed. I.e., "Page 1 of 2" displayed as "עמוד 1 מתוך 2" instead of "עמוד 1 מתוך 2". This issue affect both the Print Preview and the actual print. 

I can't reproduce it on http://www.wikipedia.org, but on http://www.mozilla.org it is visible (both do not specify dir=rtl, and are UTF-8 encoded). I'm attaching a screenshot.
Reporter

Updated

11 years ago
Summary: Firefox with he/ar UI show print headers reversed for non-rtl pages → Firefox with he/ar UI displays print headers reversed for non-rtl pages
Reporter

Comment 1

11 years ago
Posted image Print settings
Note that it is displayed correctly in the printer settings dialog.
Assignee

Comment 2

11 years ago
This is a regression since Firefox 2.
Component: Printing → Layout: BiDi Hebrew & Arabic
Flags: blocking1.9?
OS: Linux → All
Product: Toolkit → Core
QA Contact: printing → layout.bidi
Hardware: PC → All
Assignee

Comment 3

11 years ago
Posted patch PatchSplinter Review
This is happening because bidi is disabled when there are no RTL characters on the page apart from the headers and footers (which is why the bug doesn't appear on wikipedia).
Assignee: nobody → smontagu
Status: NEW → ASSIGNED
Attachment #308276 - Flags: superreview?(roc)
Attachment #308276 - Flags: review?(roc)
Attachment #308276 - Flags: superreview?(roc)
Attachment #308276 - Flags: superreview+
Attachment #308276 - Flags: review?(roc)
Attachment #308276 - Flags: review+
Assignee

Updated

11 years ago
Attachment #308276 - Flags: approval1.9?
Marking as blocking1.9+ w/P2.  Also, approving patch.
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
Attachment #308276 - Flags: approval1.9? → approval1.9+
Assignee

Comment 5

11 years ago
Checked in. Marking in-testsuite- since as far as I know we have no way to reftest print preview, but feel free to change that if I am wrong.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Flags: in-testsuite-
Resolution: --- → FIXED

Updated

11 years ago

Updated

11 years ago
Blocks: fx35-l10n-fa

Updated

11 years ago
No longer blocks: Persian-Fx3.5

Comment 6

11 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl

Updated

11 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: layout.bidi → layout.fonts-and-text

Updated

10 years ago
No longer blocks: fx35-l10n-fa

Updated

10 years ago
Blocks: Persian
You need to log in before you can comment on or make changes to this bug.