Context menu bustedness when right-clicking (ctrl+clicking works fine)

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Ty Williams, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

Firefox 3.0 betas are inconsistently handling right-clicks depending on how the right-click was entered. In OS X, right-clicks can be entered via a two-finger tap to the trackpad, holding down Ctrl while left clicking (either with a mouse, the trackpad button, or a single fingered tap to the trackpad), or as an actual right-click on a multi-button input device. All these should be handled identically. However, Ff is not handling them all the same. The outcome varies, but two-fingered-tap seems to work correctly very infrequently while ctrl-left-click seems to work very consistently. The easiest way to see the problem is to right-click in the middle of a page to try to get a contextual menu. The two-finger-tap will work correctly for a few times and then will suddenly start selecting and executing a random item from the contextual menu rather than displaying the contextual menu.

Note that this affects more than just the contextual menus, but the contextual menu is the easiest to trigger and the most annoying.

Reproducible: Always

Steps to Reproduce:
1. Open a browser window and navigate to a page
2. Tap on the trackpad with 2 fingers (must have this preference enabled in System Preferences) to emulate a right-click.
3. Repeat step 2 until a random item from the contextual menu is selected and executed 
Actual Results:  
The two-finger-tap method of right click will eventually result in a random item from the contextual menu being executed (such as Save Page As, Send Link, etc.)

Expected Results:  
Two finger tap method of right click should display the contextual menu.

Default theme, some extensions, no crashes.

Comment 1

10 years ago
Same or related as bug 404314 likely.

Updated

10 years ago
Depends on: 404314
Which version of Mac OS X are you using?

Apple's Keyboard & Mouse preference panel (on OS X 10.4.11) contains
this option (off by default) -- "Place two fingers on trackpad and
click button for secondary click".

I just turned this on and tried it in today's Minefield nightly
(2008-03-11-04-trunk), and had no problems.
(Reporter)

Comment 3

10 years ago
10.5.2 with all current patches.

The option you're speaking of is enabled on all my laptops. However, this behavior didn't occur under Ff2.* and started happening in the 3* betas when I began testing them. No other upgrades happened at that time. Going back to Ff 2.* results in everything functioning properly.

Just noticed another oddity. I have Check Spelling as You Type enabled in Ff. When a word is mis-spelled and gets a red-underline, you MUST use ctrl-left-click as right-click to get the spelling menu items to appear. If you two-finger-tap as right-click, the contextual menu WILL NOT CONTAIN the spelling items.

Comment 4

10 years ago
The spell-checking thing works fine for me using Firefox trunk on Tiger, using the MBP two-finger trick.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008031111 Minefield/3.0b5pre
Summary: Inconsistent Handling of Right-Click Based on Input Device → Context menu bustedness when right-clicking (ctrl+clicking works fine)
(Reporter)

Comment 5

10 years ago
OK, new build, new behavior. Using the 20080424 nightly, I'm no longer seeing this problem as described.

In 90% of all cases, the right-click, by whatever input method, works just fine. However, in the text entry boxes of some web forums, right-click by any method is very broken now. 1) the contextual menu appears anywhere on the screen it feels like and 2) it won't contain the correct menu options. Different forum software seems to produce different amounts of bad behavior. The bugzilla textbox I'm typing in here, for example, puts the context menu in the proper place, but it only contains generic items, not ones contextually correct. However, on dirtyimpreza.com (SFW, it's an offroad car site), right clicking in a text box gets you a contextual menu up at the very top of the screen, still without the correct items in it.

Comment 6

10 years ago
Hi,

I'm experiencing the same issues with right click not working for mac (10.5.3 Intel) on latest nightly.

I can sometimes get the right click working using the ctrl key, however most of the time it fails.  On Ffox 2.0.0.14 the right click menu does show up but disappears very quickly.

I'm using this on an Oralce/Hyperion application, please let me know if more info is needed.

Right click menu works as expected on solaris version of Firefox3.0 nightly.

I believe this may be related to an issue introduced in ffox 2.0.0.8 (I had similar right click issues on windows/mac versions, this was fixed in these OS versions (unsure exactly which point release).
The problem(s) reported here aren't clearly defined.  Nor have we been
able to reproduce them.  So it's probably best to open a new bug.

However, there's not much point in opening a new bug unless you can
provide a publicly accessible example of the problem you're reporting
-- a URL or testcase that demonstrates the problem.

Comment 8

10 years ago
Testcase, reproduced on both Tiger and Leopard:

<html>
<script>
function log(text) {
	document.getElementById("log").innerHTML += '...' + text + '<br>';
}
</script>

<body onmousedown="log('down'); event.preventDefault()" onmouseup="log('up')" oncontextmenu="log('right click')">
do right mouse click on FF3 Win and than on FF3 Mac, following events are fired:
<div id="log"></div>
</body>
</html>

Please note there is also different order of fired event, on Win the order is mouseUp-mouseDown-contextMenu, on Mac it is mouseDown-contextMenu-mouseUp
> Please note there is also different order of fired event, on Win the
> order is mouseUp-mouseDown-contextMenu, on Mac it is
> mouseDown-contextMenu-mouseUp

I suspect the even order isn't relevant to any of the problems
reported here -- the mouseDown-contextMenu-mouseUp order also happens
on Linux.

By the way, you need to get rid of the event.preventDefault() for your
testcase to work properly.

Comment 10

10 years ago
I know my testcase works properly if there is no event.preventDefault(), but it's just the reason why I reported this bug, I need to use event.preventDefault() in my case and it works properly in FF3Win, only Mac is affected, so I believe it's FF3Mac bug.

Comment 11

10 years ago
Any progress?
We haven't been able to reproduce any problems, so -> WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 13

10 years ago
This bug is definitely not squashed. It is alive and thriving on (at least) the Linux Firefox (v3.0.3).

There are at least four other bugs, listed below, relating to right-click "bustedness". Bug 455432 is probably best considered a duplicate of this bug. The other three (Bug 433829, Bug 432790, and Bug 403540) are special instances of the broken behavior.

*Bug 455432 - Right-click results in random action in some instances (as opposed to a context menu)
*Bug 433829 - page switches direction with single right click
*Bug 432790 - Right click problem  
*Bug 403540 - Right click a link - sometimes opens link in new window instead of showing context menu
You need to log in before you can comment on or make changes to this bug.