can't create new folder/subfolder anymore - error Error: NewFolder is not defined Source File: chrome://messenger/content/messenger.xul Line: 1

RESOLVED FIXED

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Magnus Melin, Assigned: Joey Minta)

Tracking

({dogfood, regression})

Trunk
dogfood, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Since at least a couple of days, create folder (or subfolder) for all types of servers fail. No dialog asking for name is put up, simply does nothing. 

Error: NewFolder is not defined
Source File: chrome://messenger/content/messenger.xul
Line: 1
(Assignee)

Comment 1

10 years ago
This is me.  Patch coming shortly.
Assignee: nobody → jminta
(Assignee)

Comment 2

10 years ago
Created attachment 309506 [details] [diff] [review]
patch

This is fallout from bug 421382, where my searches didn't pick up the way the NewFolder function was being used.  Since GetCompositeDatasource and DoRDFCommand are gone, this is a reworked version of the function that was removed there.
Attachment #309506 - Flags: review?(mkmelin+mozilla)
(Reporter)

Comment 3

10 years ago
Since "" is falsy, that could be simplified to |if (!uri || !name)|
Blocks: 421382
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 4

10 years ago
Comment on attachment 309506 [details] [diff] [review]
patch

r=mkmelin, with previous comment fixed
Attachment #309506 - Flags: review?(mkmelin+mozilla) → review+

Updated

10 years ago
Keywords: dogfood
Summary: can't create new folder/subfolder anymore → can't create new folder/subfolder anymore - error Error: NewFolder is not defined Source File: chrome://messenger/content/messenger.xul Line: 1
(Assignee)

Comment 5

10 years ago
Fixed comment #3 and landed.
Checking in mail/base/content/mailCommands.js;
/cvsroot/mozilla/mail/base/content/mailCommands.js,v  <--  mailCommands.js
new revision: 1.40; previous revision: 1.39
done
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.