favicon is lost when modifying a bookmark's URL (AKA there's no way to get a favicon for a redirecting URL or a bookmarklet)

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
RESOLVED WONTFIX
9 years ago
4 years ago

People

(Reporter: Simon Bünzli, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Steps to reproduce:
1. Goto http://www.mozilla.org/
2. Bookmark that page
3. Open the Bookmarks sidebar, navigate to that new bookmark and right-click -> Properties
4. Change the URL to http://www.mozilla.com/

Actual result:
The bookmark gets the default "blank page" favicon.

Expected result:
The favicon remains, otherwise there's no (easy) way to get the favicon back. This is especially annoying when bookmarking URLs which will redirect (such as the above mozilla.com which redirects based on language or SlashDot's auto-login URL).
(Reporter)

Updated

9 years ago
Flags: blocking-firefox3?
Summary: favicon is lost when modifying a bookmark's URL (AKA there's no way to get a favicon for a redirecting URL) → favicon is lost when modifying a bookmark's URL (AKA there's no way to get a favicon for a redirecting URL or a bookmarklet)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 253045
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
I'm asking for the _opposite_ behavior (favicon should _not_ be reset on changing a bookmark's URL). If I wanted the favicon to be reset, I'd just create a new bookmark...
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Bug 326896 ?
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
This is IMO a different regression, your favicons are lost when sites provide their own, mine are lost because sites don't.
This will not block the final release of Firefox 3. Any patch will need unit tests in order to be approved.
Flags: blocking-firefox3? → blocking-firefox3-
hmm, this WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080819034536 (new profile etc.), i.e. the favicon stays.

moreover i'm in favor of resetting the favicon on url change to get it updated to the one of the changed url than the opposite and have to recreate the bookmark (Bug 386940).

Updated

8 years ago
Status: REOPENED → NEW
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks

Comment 8

6 years ago
Whilst I understand what the OP was getting at, I think that the opposite problem is more concerning.  If URL A were bookmarked and later started to redirect to URL B, the original favicon is kept in the bookmark.  This means (a) if the favicon for URL B is different than from URL A then there's a mismatch between what's shown in the address bar and what's shown in the bookmark, and (b) if the favicons are lost from the bookmarks for whatever reason (as happens when bookmarks are exported from one installation and imported into another, for example) then a bookmark which previously had URL A's favicon is shown as having no favicon, again resulting in a mismatch (and a more confusing one, because it looks like a UA bug: URL B's favicon displays in the address bar yet the bookmark doesn't update).

Bear in mind that it's usually not at all obvious that a redirect is taking place.  Indeed, I arrived at this bug after searching for why Fx8 was failing to set a favicon for a familiar bookmark that I'd exported to a new machine.  Only after reading the bugs was I alerted to the fact that the reason was due to the bookmarked URL having started redirecting at some unknown point in the past.
favicons are per uri, an add-on could probably do something here to apply favicon to the new uri, but in general it's quite hard to guess if a changed uri should retain or not the original favicon, I may edit www.mozilla.org to www.grumpycat.org and the icon should really not persist.
Status: NEW → RESOLVED
Last Resolved: 9 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.