use Vista platform-compatible styling for notification bars

RESOLVED DUPLICATE of bug 423744

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 423744
10 years ago
3 years ago

People

(Reporter: madhava, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
The current notification bar colors don't fit with the Vista platform colors.

Suggestions for revised coloring to come.
Created attachment 310368 [details]
Vista unsigned code warning window

Just for reference of some of the colors used on vista, this is the red unsigned code warning window.
(Reporter)

Comment 2

10 years ago
Created attachment 310545 [details]
vista colour suggestions
(Reporter)

Comment 3

10 years ago
Created attachment 310583 [details]
alternative shade of red for the fail-level notification

Comment 4

10 years ago
I think the second one is the best colour.
Blocks: 420232, 425582
Depends on: 425598
Blocks: 405605
Here are the background images and default icons for each type of bar.  The
notification bars should have a default height of 30, but the background images
were created to be 60 pixels tall in case the has larger system fonts.

--background images--

http://mxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/global/icons/informationBar-60-aero.png

http://mxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/global/icons/questionBar-60-aero.png

http://mxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/global/icons/errorBar-60-aero.png

http://mxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/global/icons/warningBar-60-aero.png

--default icons--

http://mxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/global/icons/informationBarIcon-16-aero.png

http://mxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/global/icons/questionBarIcon-16-aero.png

http://mxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/global/icons/errorBarIcon-16-aero.png
Summary: use Vista platform-compatible colors for notification bars → use Vista platform-compatible styling for notification bars
New background images for the notification bars will land with bug bug 430759
Requesting blocking since we have all the files and this impacts the UI of the main window.  This bug should at least pick up a wanted+
Flags: blocking-firefox3?
Blocks: 428923

Updated

10 years ago
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
This will be fixed by bug 423744 with chrome overrides.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 423744

Updated

3 years ago
No longer depends on: 425598
You need to log in before you can comment on or make changes to this bug.