Closed Bug 426786 Opened 13 years ago Closed 4 years ago

Remove last remnants of no more used iconsize="large"

Categories

(Thunderbird :: Toolbars and Tabs, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 55.0

People

(Reporter: eagle3386, Assigned: Paenglab)

Details

(Whiteboard: [good first bug][lang=js][lang=xul])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008032904 Minefield/3.0pre
Build Identifier: version 2.0.0.12 (20080213)

I've customized both, my Firefox 3's and Thunderbird 2's UI by changing their throbber-image with a turning Tux-image.

Though, while the code I've added to Firefox' userChrome.css worked just fine, Thunderbird doesn't act that way.

Reproducible: Always

Steps to Reproduce:
1. Edit userChrome.css by adding the following lines above the namespace-line:

toolbar[mode="text"] #navigator-throbber { list-style-image: url("cc-throbber-16.png") !important; }
toolbar[mode="text"] #navigator-throbber[busy="true"] { list-style-image: url("cc-throbber-16.gif") !important; }

toolbar[iconsize="small"] #navigator-throbber { list-style-image: url("cc-throbber-24.png") !important; }
toolbar[iconsize="small"] #navigator-throbber[busy="true"] { list-style-image: url("cc-throbber-24.gif") !important; }

toolbar[iconsize="large"] #navigator-throbber { list-style-image: url("cc-throbber-32.png") !important; }
toolbar[iconsize="large"] #navigator-throbber[busy="true"] { list-style-image: url("cc-throbber-32.gif") !important; }

2. Launch Thunderbird
3. Right-click somewhere at the toolbar and choose "Customize..."
4. Make sure, "Use Small Icons" is unchecked
5. Select an option from the drop-down menu left of that checkbox as you prefer (except "Text", because with that option selected, the customized throbber-image is shown)
6. Look at the upper-right corner of the UI
Actual Results:  
No customized throbber-image shown in "large mode", but instead the default circle.
Though, if "Use Small Icons" is checked, the customized throbber-image is shown, no matter what option is selected from the drop-down menu.

Expected Results:  
Customized throbber-image should be shown in "large mode", too.

- Default theme is used.
- Extensions used: DictionarySwitcher 1.1.3, MinimizeToTray 0.0.1.2006102615+, Wortliste von http://tkltrans.sf.net (alte und neue deutsche Rechtschreibung) 20060716 (= German dictionary)
Not a valid bug.

There is no reason to suppose that exactly the same CSS code will work in Firefox  and Thunderbird.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
But why does the code then work when one checks that "Use Small Icons"?

Also, that's the typical code one finds if doing a search for it via Google - at least that happened to me..

So, to me this is definitely a bug, because AFAIK both application used the same base to start from and I can hardly image the TB's devs changed the throbber-code..
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
If your comparison is fx3, you should be testing tb3.
My comparison is not FF3 - I got another pc using FF2 and it works there, too..
The only difference is, we don't use the "large" attribute ;)
I guess it would be good for consistency with the ff nav-bar toolbar.

Bug 407899 introduced the defaulticons attribute, which also seems like something we should use - xref bug 417924.


Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
Hardware: PC → All
Summary: Customized throbber doesn't show up in "large mode", but in any other - same code works in FF2/3 perfectly → tb toolbars do not use "large", only "small" iconsizes
Ah, I had something similar in mind since small icon- / text-mode works great with that CSS-code.. ;)
Assignee: mkmelin+mozilla → nobody
Component: Mail Window Front End → Toolbars and Tabs
Keywords: good-first-bug
Whiteboard: [good first bug]
Hi, I want to know more information about this can any one help me. Since I was new to this.
Whiteboard: [good first bug] → [good first bug][lang=js][lang=xul]
Magnus, can you explain better what needs to be done here?
Flags: needinfo?(mkmelin+mozilla)
The original issue seems not to exist anymore. 

The only trace of size="large" is these, which looks to be obsolete.
 https://dxr.mozilla.org/comm-central/rev/d03f6d1f69374c85d4939d0c7cb92021614600f4/mail/themes/windows/mail/primaryToolbar.css#665 and https://dxr.mozilla.org/comm-central/source/mail/components/im/content/chat.css#107
Status: NEW → RESOLVED
Closed: 13 years ago4 years ago
Flags: needinfo?(mkmelin+mozilla)
Resolution: --- → WORKSFORME
Shouldn't we cleanup the css then?
Flags: needinfo?(richard.marti)
Attached patch Bug426786.patchSplinter Review
Yes, this patch removes them.
Assignee: nobody → richard.marti
Flags: needinfo?(richard.marti)
Attachment #8846736 - Flags: review?(acelists)
Comment on attachment 8846736 [details] [diff] [review]
Bug426786.patch

Review of attachment 8846736 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #8846736 - Flags: review?(acelists) → review+
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Thanks too.
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/64ba9ba1f50cb7aa00ef246d32aefdcd8a0f3890
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 55.0
Summary: tb toolbars do not use "large", only "small" iconsizes → Remove last remnants of no more used iconsize="large"
You need to log in before you can comment on or make changes to this bug.