Invalid handling of "news" link without a server name

VERIFIED DUPLICATE of bug 327885

Status

--
major
VERIFIED DUPLICATE of bug 327885
11 years ago
10 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008040301 SeaMonkey/2.0a1pre

Description: see below.

Reproducible: Always.

Steps to reproduce:
1. Make sure Browser and MailNews windows are open.
2. In the browser, click the following link: news:comp.editors

Actual results:
- The current browser tab is replaced by a XUL error page, "Address not found" for the address (I'm not kidding) "news://news:119/netscape.public.mozilla.mail-news" -- i.e. "news" is unknown on DNS.
- The mailnews window does not come to front
- A new account, for newsserver "news" port 119, is created, visible in the MailNews Account Settings, but it does not appear among the newsservers in the left pane of the 3-pane window

Expected results:
- Mailnews window should come to front
- The newsgroup in question should get subscribed, possibly after asking you on which server it is located.
- Browser window content shouldn't change.
Oops: the "wrong" address in the url bar for the XUL error page would be news://news:119/comp.editors (I changed that description at last minute to reflect a more "usual" Usenet newsgroup and forgor to change it here)

Comment 2

11 years ago
Yes, I can reproduce, with Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9pre) Gecko/2008040301 SeaMonkey/2.0a1pre, so this is probably All/All.

I noticed that the new account also shows up when closing and re-opening the MailNews window.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
This is exactly the problem as described in bug 327885, which should probably be itself duped to bug 64142
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 327885
(In reply to comment #3)
> This is exactly the problem as described in bug 327885, which should probably
> be itself duped to bug 64142
> 
> *** This bug has been marked as a duplicate of bug 327885 ***
> 

I agree. As reporter of this bug, I VERIFY the above resolution.
Status: RESOLVED → VERIFIED

Updated

11 years ago
No longer blocks: 176238

Updated

10 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: search
You need to log in before you can comment on or make changes to this bug.