Closed Bug 427610 Opened 12 years ago Closed 11 years ago

Hotmail.com - "Full Version" does not work properly. It loads the "classic version".

Categories

(Tech Evangelism Graveyard :: English US, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ChrisRivadeneira, Unassigned)

References

()

Details

(Keywords: regression, top100)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

When you log into hotmail, it doesn't allow you to use the full version for some reason.

Reproducible: Always

Steps to Reproduce:
1.Go to hotmail.com
2. Login 
3. Try to use the full version.  It does not work.
Actual Results:  
Same Problem

Expected Results:  
Able to use the full version of hotmail
Duplicate of this bug: 428014
Duplicate of this bug: 437530
Duplicate of this bug: 437720
it says an error occurred and cache and cookies need to be emptied, tried that twice and it doesn't work
Yeah I got the same as Mark :( Think Mozilla will fix it?
Duplicate of this bug: 439868
This is one of the most popular questions on sumo after Fx3.
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5)
> Gecko/2008032620 Firefox/3.0b5
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5)
> Gecko/2008032620 Firefox/3.0b5
> 
> When you log into hotmail, it doesn't allow you to use the full version for
> some reason.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.Go to hotmail.com
> 2. Login 
> 3. Try to use the full version.  It does not work.
> Actual Results:  
> Same Problem
> 
> Expected Results:  
> Able to use the full version of hotmail
> 

i have the Same Problem With FireFox 3 for Mac..
The new, full version 3 of FireFox continues to present the same issue. Can not load the Full Version of hotmail.

Thank you,
Still an issue in FF3 final.  Windows live mail message:

"You are temporarily on the classic version of Windows Live Hotmail due to an error encountered during login. Before trying again, please clear your cache and cookies. "

Live Hotmail worked fine in FF2 and IE7.

Recommend everyone also send feedback to Live Hotmail to about the issue since this is also a site issue.
Duplicate of this bug: 440611
Lots of dupes to here, and I feel like this is reported somewhere else, but I can't seem to find another bug like this right now.  Whatever; testing and confirming.  If someone else knows of a better bug please dupe this to that.

I'll also move this over to TE, as my guess is this the site's fault.  (just bad user agent sniffing?)  Hopefully someone who knows more about this can comment.
Assignee: nobody → english-us
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
Keywords: regression, top100
OS: Windows XP → All
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Hardware: PC → All
Duplicate of this bug: 431612
Duplicate of this bug: 433131
Hmm... this all may be a dupe of bug 396259.
However, it starts off as seeming unrelated to this and it's supposedly fixed.
In addition to not allowing the full version, it also will not allow the opening of a reading pane in the classic version.
I experience the same problem with FF3.  IE7 does not have the problem nor did FF2.  I suspect it may have something to do with new security features of FF3.  Please fix this.  Thanks
I experience the same thing. I think this is more likely a Microsoft issue than a Firefox one since they block out Opera as well. It probably be fixed by them in a few weeks since they be getting lots of complaints and Firefox 3 is out.
It is a conflict in programming FF3 AND Live.  This works with Maxthon and as said in comment 18 IE.  If Opera does not open up, then it is a programmin conflict with Opera and Live mail. And since the FF# just was released while nothin was changed on Live mail, ....  It is a glitch that FF needs to fix.   Or for those of us Mozilla blievers, we just have to suck it up if they don't.  I hope they do, but at least we can still read the mail.  
If this is a hotmail issue we'll address it ASAP - I'll forward this bug report to the appropriate folks.
FWIW, i am able to login to:

1. www.hotmail.com
2. use the full version

read, send, emails, the works.

i am using FF3 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
(In reply to comment #22)
> FWIW, i am able to login to:
> 
> 1. www.hotmail.com
> 2. use the full version
> 
> read, send, emails, the works.
> 
> i am using FF3 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9)
> Gecko/2008052906 Firefox/3.0
> 

are you using addons ? or have you done any customizations (like java script) ?
It doesn't work even if you change the user-agent with user agent switcher.

I changed it to IE7, and it got stuck at the loading screen.

I changed it to FF2, and it gave me the classic version, with the same error message as FF3.

Netscape 4.8 and Opera 9.25 user-agent strings give me an "unsupported browser" message.

For what it is worth, I received this reply from Windows Live Hotmail Technical Support:

"...Thank you for writing to Windows Live Hotmail Technical Support. Based on your e-mail, you encounter the message saying, "You are temporarily on the classic version of Windows Live Hotmail due to an error encountered during login", when you log in to your account. I understand how inconvenient this may be for you.

I have confirmed from our product team that Mozilla Firefox 3 is not currently a supported browser to switch to Full version of Windows Live Hotmail.

Our product team is already working on a resolution for this issue but we cannot provide you with an exact timeframe on when your browser will be supported. I assure you however that this is being dealt with utmost priority and that the product group is working diligently to have this problem fixed as soon as possible.

In the meantime, you may want to try the Classic version using Mozilla Firefox 3 or use the supported browsers for Full version:

- Internet Explorer 6 or later
- Mozilla Firefox 1.5 or 2.0

We appreciate your continued support as we strive to provide you with the highest quality service available. Thank you for using Windows Live Hotmail...."

(In reply to comment #23)
> (In reply to comment #22)
> > FWIW, i am able to login to:
> > 
> > 1. www.hotmail.com
> > 2. use the full version
> > 
> > read, send, emails, the works.
> > 
> > i am using FF3 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9)
> > Gecko/2008052906 Firefox/3.0
> > 
> 
> are you using addons ? or have you done any customizations (like java script) ?
> 

i don't have any addons that i think helped. what i have are:

abp, better gmail 2, downloadhelper, downthemall!, flagfox, foxmarks, greasemonkey (with consumerist and gmail add right click scripts), ie tab (i didn't use ie engine), siteadvisor, pdf download, quickrestart, shareaholic, update notifier.

and contrary to above reply from Windows Live Hotmail Technical Support, i can still logon and use full live hotmail.
rino, I'm a little confused - the title of this bug says full hotmail isn't available, but you say it is.  Are you just entering another data point?
rino, are you using Firefox's "Open last session windows and tabs" feature?
Doesn't work for me either, it says an error occurred during login.
(In reply to comment #27)
> rino, I'm a little confused - the title of this bug says full hotmail isn't
> available, but you say it is.  Are you just entering another data point?
> 

hi, i don't want to create confusion here so i again tried it out:

1. www.hotmail.com
2. entered my Windows Live ID
3. Windows Live Mail is loading

to make sure i'm in the "full" hotmail i clicked on Options, and it says:

You're using the full version of Windows Live Hotmail.

    * Not fast enough? Try the classic version.



if i have mis-read the title and this bug my apologies but as this is how i understood what "Hotmail Full Version" is.

i even get MSN as my default, instead of the inbox, when i logged in.
(In reply to comment #28)
> rino, are you using Firefox's "Open last session windows and tabs" feature?
> 

hi, no i open either a new tab or simply go directly to hotmail after FF3 loaded.
(In reply to comment #29)
> Doesn't work for me either, it says an error occurred during login.
> 

i would like to add, if this would make any difference, is that i have all the XP updates.
Hi folks, first time here.

I hadn't full version of Hotmail activated - never cared about -, and tried to enable it after reading this report. After the activation, I received the same error message as almost everybody here. However, there was the following message on the Options page:

You're using the full version of Windows Live Hotmail.

    * Not fast enough? Try the classic version.

Loged out/in some times; same old Hotmail, though. So, the point is: "rino.mardo", aren't you being confused by this tricky interface problem? Is full version REALLY working there?? Are the side panels appearing and working correctly?
(In reply to comment #33)
> Hi folks, first time here.
> 
> I hadn't full version of Hotmail activated - never cared about -, and tried to
> enable it after reading this report. After the activation, I received the same
> error message as almost everybody here. However, there was the following

i *never* received any error message switching from classic hotmail to full hotmail. this is what "confuses" me with this thread.


> message on the Options page:
> 
> You're using the full version of Windows Live Hotmail.
> 
>     * Not fast enough? Try the classic version.
> 
> Loged out/in some times; same old Hotmail, though. So, the point is:
> "rino.mardo", aren't you being confused by this tricky interface problem? Is
> full version REALLY working there?? Are the side panels appearing and working
> correctly?
> 

for side panels. clicked on calendar, selected different views, created a task. it's working. i clicked on contacts, created new ones, edited existing ones. they work.

went back to inbox by clicking inbox from the side panel. working.

BUT here's one thing that doesn't work (unless i'm expecting too much):

reading pane settings. no matter what i do i don't get no preview of my messages unless i click on the message.

expecting something like Outlook preview? btw, are you all using the secure connection of hotmail? i'm not.

The full version is almost exactly like Outlook for those confused. It has a reading pane as well as drag and drop of messages. The inbox should show al your messages as well as the currently selected message.

I don't think using the secure version or not makes a difference.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

I'm having the same problem.
Hi,After installing the FF3 add-on "IE tabs" and adding http://www.hotmail.com and http://bl108w.blu108.mail.live.com the problem with Full Hotmail Version was solved!! 

See here :
http://support.mozilla.com/tiki-view_forum_thread.php?comments_parentId=68350&forumId=1
"IE tabs" is a nifty Windows-only Firefox extension which allows you to render a page using IE inside a Firefox tab.  It ~is~ IE, so yeah, it'll obviously work there...  :p

People, please don't post here unless you actually have something new to add.
Ah Dave is right; This isn't really a way to get past the bug. Yeah it does work, but if your on MSN and you click the Hotmail icon, it'll still bring you into Firefox and the bug will still be in effect. You'd then have to use the "IE Tab" and then re-activate full version each time. So it's pretty pointless.

I'm still wondering if it's a firefox or hotmail issue. A lot of forums are saying it's Microsoft's problem and not firefox - but either way, I hope someone can either properly bypass this bug or just hope that Microsoft/firefox fix this soon. So for now I'm back on Firefox 2.0.0.14 once again...
but if your on MSN and you click the Hotmail icon, it'll still bring you
into Firefox and the bug will still be in effect. You'd then have to use the
"IE Tab" and then re-activate full version each time. So it's pretty pointless.

This is not correct. Adding the precise addresses in IE Tab options , clicking in Msn Hotmail Icon, FF3 opens DIRECTLY the full version of hotmail, using IE Tab.
I know that is not a real solution to this problem, but works well!
Bye.
Microsoft's site doesn't yet support the new version of their competitor's browser.  Go figure...  ;)

It may not be clear to some people, but IE tab is just a way of using IE without having to close Firefox.  That's why it's called "IE Tab"; you use "IE" in a "tab".

As Gianni is alluding to, there's settings in IE tab where you can set specific sites to always use IE rendering.  However, the problem isn't that this is annoying and doesn't work for non-Windows users.  The problem is that Hotmail does not support Firefox 3.  Not using Firefox 3 (i.e. using IE instead) is not a real solution to the problem of Hotmail not supporting Firefox 3.  It's the equivalent of "hey doc, it hurts when I do this" so the doctor replies "so, don't do that."

There are many things out there that use browser-dependent code and they'll all need to be updated to support the new browser.  That's why using browser-dependent code is often a bad idea.

For future reference, any bug report categorized under "Tech Evangelism" is one where the problem is with the site and not anything Mozilla related.  (the site is doing something wrong and we need to "enlighten" them ;)
Gianni, I'm glad it's working fine for you. But, you say your when you click on the hotmail icon on MSN, firefox opens hotmail automatically in the "IE-based" Firefox without clicking on the "Ie Tab" first? (can't think of a better way of writing it, sorry).
https://addons.mozilla.org/en-US/firefox/addon/1419
tools -> add-ons -> IE tab -> options -> sites filter
With this extension feature enabled, sites in this list automagically load up inside an IE browser embedded inside of Firefox.  For other questions about IE tab, please post in their support thread and not here.

However, again, none of this has to do with this bug report.  Bugzilla is not for tech support; it's for reporting and fixing bugs in Mozilla products.  Please avoid posting here again unless something changes.
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
Ah, thanks for that. I've done that but still doesn't load automatically in it. Probably due to the fact I have a program on MSN that open ups hotmail in Firefox rather than in the IE Browser. Never thought it would have been conflicting with it not opening it up in the IE-based Firefox, though it does make sense that it would conflict when I think about it.

Anyway, I didn't mean ask about IE Tab stuff; just with it possibly helping this issue I didn't think it would hurt.

Anyone think they have a theory of bypassing the bug(apart from switching back to 2.0/IE, etc) until Microsoft sort things out?
(In reply to comment #44)
> Anyone think they have a theory of bypassing the bug(apart from switching back
> to 2.0/IE, etc) until Microsoft sort things out?

Yeah, use classic Hotmail mode.
I meant about using the Full Version of Hotmail without switching back to that, etc.
(In reply to comment #46)
> I meant about using the Full Version of Hotmail without switching back to that

No, that's why there's 40-something replies + duplicates + support forum threads, not including old bug reports where they've done similar things before.

Pretending to be Firefox 2 via the User Agent Switcher extension still results in errors, and pretending to be IE breaks things entirely.  There is no quick fix here.  I'm sorry, I know this sucks if you're dependent on Hotmail, but that's the way it is until they choose otherwise.  Just use the classic version, which works fine, or setup Hotmail with a normal email client or hunt for a different email provider.
i tried to use IE Tabs addon

and added http://*.mail.live.com/* 

to Site Filter

and it worked :)
the Full Version worked.

did Microsoft intent to do this ?????
does Hotmail check for the browser name ???
(In reply to comment #37)
> Hi,After installing the FF3 add-on "IE tabs" and adding http://www.hotmail.com
> and http://bl108w.blu108.mail.live.com the problem with Full Hotmail Version
> was solved!! 
> 

heh, i uninstalled IE tabs, restarted my FF3, and i can still go and use Full Hotmail Live.

if Full Live Hotmail is working for my FF3 (no IE tabs) i guess this confirms that it's not a Firefox 3 issue but individual PC issue.


rino,

Not sure that I agree with you. Since I started this thread, I can now say that installing the IE Tabs in FireFox3 resolved the problem. So, no, it's not my PC. This problem started with FF3 Beta and has been resolved using the IE Tab add-on.

Thank you for suggesting adding the IE Tabs.
Read comment #25 and you'll learn that MS tech support as stated that the full version of Hotmail simply does not yet support Firefox 3.  Go bug them.  :p

Read comment #43 for a nice hacky work around for Windows.  It's been around for ages and has nothing to do with Mozilla; stop posting about it here.

Please, there is no need to continue to spam many peoples' inboxes.
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
Duplicate of this bug: 443129
(In reply to comment #51)
> Read comment #25 and you'll learn that MS tech support as stated that the full
> version of Hotmail simply does not yet support Firefox 3.  Go bug them.  :p

I simply don't agree on #51 even though it came from MS tech support. Reason? It works for me.

> Read comment #43 for a nice hacky work around for Windows.  It's been around
> for ages and has nothing to do with Mozilla; stop posting about it here.
> 

Agree. This bug nothing to do with Mozilla.

> Please, there is no need to continue to spam many peoples' inboxes.
> https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
> 

Noted. My last post. Thanks anyway.
Duplicate of this bug: 439876
Sorry to contribute to all the bugspam but if it's just bad user agent sniffing in the hotmail site, how come changing the user agent back to the FF2 value doesn't resolve it ?
I don't think its just user-agent sniffing.  There are some FF3-specific fix that should roll out with the next Hotmail fix release; I'm not sure when that is.  Since some people are reporting that FF3 is working OK for them on the Hotmail site, though, I'm not confident we understand all the issues that might be causing this problem.
It's not bad user agent sniffing. Go try it--find another browser that supports changing the user agent string and the full version of Hotmail (I used Camino) and set the string to that of Firefox 3. You will get the full (not classic) version of Hotmail.
Anyone from Mozilla care to comment ? There might be two issues - if MSN say they don't support Fx3 and are working on a fix then that's one but if other browsers mimicking Fx3 can work then there must also be firefox-specific problem with this site that's not going to go away when MSN fix whatever they're working on. Ditto the fact that Fx3 mimicking IE or Fx2 has problems when neither of those browsers do. 
Duncan:  They'll have to fix the Firefox-specific incompatibilities.  They're using browser-specific features that they need to update to work correctly; that's the point.
I think I see. Fx3 has changed/deimplemented features in Fx2 that Hotmail use. 

There must be a good reason why that was done but still, ouch. Hope there aren't too many other sites affected.

Still, if the problem can be worked around using IE tab and MSN are working towards Fx3 support that's good.
I contacted Microsoft, they will put Firefox 3 support in the new release this winter.
Duplicate of this bug: 445533
Duplicate of this bug: 445758
ok what got changed in 3.0.1 that made my 3.0 not work with Full Live Hotmail?

my posts before said the Full Live Hotmail works with my Firefox 3.0 but after the upgrade to 3.0.1 it stopped working. i can't help but think out loud "if it ain't broke..".

sorry for the bugspam i know i said in comment 53 it's my last post but this last update ticked me off.
(In reply to comment #64)
> ok what got changed in 3.0.1 that made my 3.0 not work with Full Live Hotmail?
> 
> my posts before said the Full Live Hotmail works with my Firefox 3.0 but after
> the upgrade to 3.0.1 it stopped working. i can't help but think out loud "if it
> ain't broke..".
> 
> sorry for the bugspam i know i said in comment 53 it's my last post but this
> last update ticked me off.
> 

Rino,

Don't forget to re-set that tab to the IE setting.

Rino, the changes are available here:

http://www.mozilla.com/en-US/firefox/3.0.1/releasenotes/

Before you upgraded to 3.0.1, you should have tested each extension individually to see if any one was giving you access to Hotmail Full. If disabling all extensions still allowed you to access the full version of Hotmail, then we would be able to help you. Now we can't, because we can't say for sure if it was an extension or not.

Russ, all we know about Rino's setup is that it magically worked for no immediately apparent reason. If you look at his posts, he claims Hotmail Full worked perfectly fine without IE Tab. Now it doesn't. His luck ran out, and there's really nothing we can do.

Seriously though, we should limit further comments on this bug to reports of responses from Microsoft or reports of success WITHOUT IE TAB, as there's nothing else we can do here.

One thing that definitely should NOT be here is people suggesting IE Tab as a fix. That is not a fix. That is a workaround that will only work for Windows users. The popularity of Firefox is due in part to the fact that it is cross-platform, and I don't think we users of non-Windows OSes deserve to be marginalized like that. If you want to extol IE Tab, do it somewhere else; everybody here already knows it works.
(In reply to comment #67)
> One thing that definitely should NOT be here is people suggesting IE Tab as a
> fix. That is not a fix. That is a workaround that will only work for Windows
> users.

It's a stretch to even call it a workaround.  The word "workaround" implies that you're avoiding the problem by doing something different within the program.  The solution given via IE Tab is to not use Firefox at all.  Microsoft simply does not yet fully support their competitor's new browser version, period.  Go bug them about it.
Ok with 3.1 now I can't even get to see hotmail page, it says bad header or just page window.
Full version of Hotmail started working for me today in FF 3.0.1
Bug Fixed. :D (works in 3.0 and above )

Please close this thread.
Also seemed fixed for me now as well, getting nice fancy AJAX running very fast on Firefox 3.0.1. 
Tested on Linux with Firefox 3.0.1. Yep, seems to be fixed.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Summary: Hotmail's "Full Version" does not work properly. It loads the "classic version" → Hotmail.com - "Full Version" does not work properly. It loads the "classic version".
(In reply to comment #71)
> Bug Fixed. :D (works in 3.0 and above )
> 
> Please close this thread.
> 

Still not working for me.
Live Hotmail now works for me also using FF 3.0.1 Vista 64.  Seems this bug is fixed.  

Thanks to all those who worked on the bug, and to Microsoft for finally updating their site.
I'm using Vista 32bit and Firefox 3.01 and its still not working for me.
(In reply to comment #76)
> I'm using Vista 32bit and Firefox 3.01 and its still not working for me.
> 

It's unlikely that the team that runs hotmail would distribute new code to every single user all at once. Such big projects often distribute such code in phases as a matter of caution. 
The bug at hand here was an incompatibility with the full version of Hotmail with Firefox 3.  It does work now, so anyone who continues to have problems is likely to be experiencing another issue.  If there turns out to be another problem here for certain users (i.e. not all, as with this bug) then another bug report would be needed for that, but there's no evidence of that yet.

Please use the support.mozilla.com forums for further help before posting again on Bugzilla.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.