[FEATURE] JavaScript Alert dialogs

VERIFIED FIXED in M9

Status

()

P3
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: gerardok, Assigned: davidm)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: is this fixed now?)

(Reporter)

Description

20 years ago
Version: Seamonkey
Program: Viewer.exe
BuildID: mar_180610
Platform: WinNT

The JavaScript alert command is not opening any dialog box.

I've noticed it sends output to console. This failure possibly happens on other
platforms.

Steps to reproduce:

1. Create an HTML file with the following content:

<html>
<head>
<title>MyPage</title>
</head>
<body>
<script>
alert("Alert dialog opened");
</script>
</body>
</html>

2. Load that file in the browser

Actual Results: No dialog box is opened.
Expected Results: A dialog containing the "Alert dialog opened" string.
(Reporter)

Updated

20 years ago
QA Contact: 4616 → 4015

Updated

20 years ago
Status: NEW → ASSIGNED
Summary: JavaScript Alert dialogs not displayed
(Reporter)

Updated

20 years ago
Hardware: PC → All
(Reporter)

Comment 1

20 years ago
The same is happening on Linux and Mac, with the caviat that there is no
console to sent the output to on Mac. Platform changed to All.

Updated

20 years ago
Target Milestone: M6

Updated

20 years ago
Target Milestone: M6 → M7

Comment 2

20 years ago
*** Bug 6974 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

20 years ago
Severity: normal → major
OS: Windows NT → All
(Reporter)

Comment 3

20 years ago
The described failure applies to Apprunner also. Apprunner doesn't display any
output to the console. Severity changed to Major.

Updated

20 years ago
Assignee: vidur → don
Status: ASSIGNED → NEW
Target Milestone: M7

Comment 4

20 years ago
I just commited changes so that prompt() and confirm() are also defined (alert()
has been for a while). All of these calls get sent up to the implementor of
nsINetSupport. This is currently in browser land. The plumbing on the JS side
exists. It's up to one of Don's people to hook up the UI.

Updated

20 years ago
Assignee: don → davidm
Priority: P3 → P1
Summary: JavaScript Alert dialogs not displayed → [FEATURE] JavaScript Alert dialogs
Target Milestone: M8

Comment 5

20 years ago
David, what are we dependant upon before this can be completed?
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

20 years ago
The problem is that if I make the webshell window impliment the NetSuport
interface ( which I did in the past ), the dialogs don't load. I don't know why
but until necko lands I really don't want to look into it.
(Assignee)

Updated

19 years ago
Target Milestone: M8 → M9
(Assignee)

Comment 7

19 years ago
Move to m9 since Necko didn't land

Comment 8

19 years ago
*** Bug 9346 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Blocks: 8310

Comment 9

19 years ago
This is a stopper for people writing JavaScript and using alert() for debugging.
I suspect they can use dump() in the interim, but it would be great to at least
have alert() write out to the console as it does in Viewer.

Updated

19 years ago
Blocks: 10575
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

19 years ago
I checked in the code to hook up the UI. There are still problems in that you are
unable to bring up the dialog from certain points in the code but I believe I
have bugs on most of them
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Updated

19 years ago
Status: REOPENED → NEW
(Reporter)

Comment 11

19 years ago
Re-tested on 07/28 build. A dialog box opens now but the alert msg is not being
displayed. A dialog box containing the "Alert dialog opened" string is expected.
Bug reopened.
(Reporter)

Updated

19 years ago
Resolution: FIXED → ---
(Reporter)

Comment 12

19 years ago
Re-tested on 07/28 build. A dialog box opens now but the alert msg is not being
displayed. A dialog box containing the "Alert dialog opened" string is expected.
Bug reopened.
(Assignee)

Comment 13

19 years ago
*** Bug 5127 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Depends on: 11611
(Assignee)

Comment 14

19 years ago
The dialogs should come up. However they will not be modal until after danm
fixes 11611 so Confirm and Prompt will not return correct values.

Updated

19 years ago
Whiteboard: is this fixed now?
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

19 years ago
fix checked in.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 16

19 years ago
Verified fix on 8/20 build on Win NT and MacOS, and 8/24 on Linux.

Updated

19 years ago
No longer blocks: 10575

Comment 17

19 years ago
This bug is still marked as a JavaScript issue at:
http://www.mozilla.org/projects/seamonkey/release-notes/m12-detail.html#general_browser

Re-opening to get this oversight covered.
Severity: major → normal
Status: VERIFIED → REOPENED
Priority: P1 → P3
Resolution: FIXED → ---

Comment 18

19 years ago
NOTE: Also downgraded to reduce radar detection.
(Assignee)

Comment 19

19 years ago
closing. Open a bug against the release note people.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 20

19 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.