Closed Bug 5127 Opened 21 years ago Closed 21 years ago

Error with JS: window.confirm() method not defined

Categories

(Core :: DOM: Core & HTML, defect, P2)

x86
Windows 95
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: fussel, Assigned: davidm)

References

Details

(Whiteboard: fixed now?)

When I click on the "FTP-Server" - Link on the Mozilla-Page, normaly should
appear a message-box "Are you sure ...". Both Apprunner and Viewer don't want
to show me this message-box
Assignee: norris → gagan
Component: JavaScript → Networking Library
QA Contact: 4590 → 4015
Component: Networking Library → DOM Level 0
Priority: P3 → P2
QA Contact: 4015 → 4616
Summary: Error with JS → Error with JS: window.confirm() method not defined
I think this refers to the 'FTP Server' link displayed at
http://www.mozilla.org/binaries.html, where the window.confirm() method is used
as follows:

<A HREF="ftp://ftp.mozilla.org/pub/mozilla/nightly/"
   onClick="return confirm('Are you sure you want to do this crazy thing?');">
<B>FTP server</B></A>

The confirm() method is reporting the JavaScript error: confirm is not defined.
Component changed to DOM level-0 and Updated Summary.
Deffered till Necko lands...
Deferring till Necko lands...
Per DP's suggestion marking these till M8. Though Necko lands with M7, we will
be able to verify it for M8.
I'm moving this to target M9, Necko will be enabled somewhere during late M8 or
early M9.  We will need to get on this and it cannot be postponed past the M9
milestone.
Assignee: gagan → vidur
Status: ASSIGNED → NEW
Hmm... wrong owner, assigning back to DOM people(?)
Assignee: vidur → davidm
The backend of this is hooked up. Passing along to davidm to implement the front
end or to close if it has been implemented.
Status: NEW → ASSIGNED
This was working until necko landed
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 4279 ***
Status: RESOLVED → REOPENED
Right now I'm reopening this bug just for one reason that whether we want to
keep seperate bugs open for different dialog boxes or we want to keep only only
one bug for all dialog boxes.
Bug# 4279 deals with alert() method and only talk about alert dialog box.
This bug deals with confirm dialog box.
Its up to you, which way you prefer. If you want to keep only one bug for all
dialog boxes, then we need to change summary and testcase for bug# 4279.
Otherwise, we need to keep this bug open, coz both these bugs talk about
different methods and different dialog boxes.
Resolution: DUPLICATE → ---
Depends on: 11611
The dialogs should come up. However they will not be modal until after danm
fixes 11611 so Confirm and Prompt will not return correct values.
Whiteboard: fixed now?
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
fix checked in
Status: RESOLVED → VERIFIED
Working fine now. Marking Verified.
You need to log in before you can comment on or make changes to this bug.