Closed Bug 427995 Opened 12 years ago Closed 12 years ago

Cmd-c, cmd-v and other key combinations don't work with non-Roman-script keyboards that don't use IME

Categories

(Core :: Widget: Cocoa, defect, P2, major)

PowerPC
macOS
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: wav_surfer, Assigned: masayuki)

References

Details

(Keywords: inputmethod, regression)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008040904 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008040904 Minefield/3.0pre

On April 7 build, when I switch keyboard layout to Thai Kedmanee. I can use Cmd+จ = Cmd+0 to normal page size. I can use Cmd+ส = Cmd+L to open location. I can use Cmd+ะ = Cmd+t to open new tab. Since April 8 build, I cannot do that. I've read bug 398514 and conclude that fixing that bug causes new bug to international keyboard layout.

Reproducible: Always

Steps to Reproduce:
1. Switch keyboard layout to Thai Kedmanee.
2. Try some Cmd key (like an example).
Actual Results:  
Functions are broken.

Expected Results:  
Functions should work like Cmd+English characters.

I start the bug 422972 and extend it to Cmd+other keys than `. With suggestion from Steven Michaud, I open this bug.
Depends on: 398514
Assignee: nobody → joshmoz
Component: Keyboard Navigation → Widget: Cocoa
Product: Firefox → Core
QA Contact: keyboard.navigation → cocoa
Version: unspecified → Trunk
I've confirmed this.  See bug 422972 comment #10.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Another bug that will be fixed by bug 359638.
Depends on: 359638
No longer depends on: 398514
Summary: Keyboard input not the same as native for international keyboard layout → Cmd-c, cmd-v and other key combinations don't work with Thai keyboard
> Another bug that will be fixed by bug 359638.

See bug 427797.
+'ing this per conversation in mac gecko meeting.  Should block.
Flags: blocking1.9+
Priority: -- → P2
taking
Assignee: joshmoz → masayuki
Keywords: regression
Status: NEW → ASSIGNED
You see exactly the same problem with the Arabic keyboard.

Both the Thai and Arabic keyboards alter characters that you've already "typed" as their context changes (as you "type" more characters).  Neither uses IME.
Blocks: 398514
Bug 428367 is probably a dupe of this one.
Actually, I've now found that cmd-c and cmd-v don't work in the Russian, Ukrainian or Greek keyboards.  But they do work in the US Extended keyboard (which is Unicode).

So the pattern seems to be that they don't work in keyboards (Unicode or otherwise) that output a non-Roman script and don't use IME.
Summary: Cmd-c, cmd-v and other key combinations don't work with Thai keyboard → Cmd-c, cmd-v and other key combinations don't work with non-Roman-script keyboards that don't use IME
Duplicate of this bug: 428367
Cmd-c and cmd-v also work in French and German keyboards.
The patch of bug 359638 was landed.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Only Cmd+` (on Thai keyboard layout) not working again since May 9, 2009 build.
(In reply to comment #12)
> Only Cmd+` (on Thai keyboard layout) not working again since May 9, 2009 build.

please file a new bug.
oh, I found bug 407793... The old behavior might be bug.
(In reply to comment #14)
> The old behavior might be bug.

Nakano-san, sorry for off-topic here,
but I can reproduce Cmd+` problem on Thai layout.

Please see Bug 407793 Comment 6.

And note the difference between Japanese environment and other.
Open [System Preferences] -> [Keyboard & Mouse] -> [Keyboard Shortcuts]
and see [Move focus to next window in active application].
# This is OS X 10.5. I don't know whether it's same on 10.4.
This shortcut is Cmd+F1 by default on Japanese environment,
but it's Cmd+` by default on the other many environment.
Thus Cmd+` shoud switch window, and this works for other applications.
You need to log in before you can comment on or make changes to this bug.