Closed Bug 428258 Opened 12 years ago Closed 11 years ago

Firefox crashes when it loads this web page. [XError: 'BadAlloc (insufficient resources for operation)']

Categories

(Core :: Graphics, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 424333

People

(Reporter: q.quark, Unassigned)

References

()

Details

(Keywords: crash, platform-parity)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008040514 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008040514 Firefox/3.0b5

After I search on google "anunturi imobiliare" ( http://www.google.com/search?hl=en&q=anunturi+imobiliare&btnG=Search) I middle click the 3-rd result (http://www.imobiliarepro.com/) to open it in a new tab. Firefox tries to load that page, but at approximately 3/4 of progress, Firefox crashes instantly.
I run firefox from the terminal and got this:
mihai@mihai-laptop:~$ firefox
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
The program 'firefox' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 37693 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
firefox crashes.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008040922 Minefield/3.0pre

Doesn't crash for me on Mac.
Keywords: crash
I can reproduce the problem.  A local build with the fix in bug 424333
avoids the "crash" -- it doesn't paint the window properly, but that's
better than just exiting the application IMO (which could cause dataloss).
Status: UNCONFIRMED → NEW
Component: General → GFX: Thebes
Depends on: 424333
Ever confirmed: true
Keywords: pp
Product: Firefox → Core
QA Contact: general → thebes
Summary: Firefox crashes when it loads this web page. → Firefox crashes when it loads this web page. [XError: 'BadAlloc (insufficient resources for operation)']
Caused by the background image:
http://www.imobiliarepro.com/images/gradient.png
which is a 10x50000 pixel png

Same bug as bug 424333, bug 476768, bug 474220, etc. All caused by the weird giant background images. Might as well close this as a dupe rather than leaving it open as a dependent.
Status: NEW → RESOLVED
Closed: 11 years ago
No longer depends on: 424333
Resolution: --- → DUPLICATE
Duplicate of bug: 424333
You need to log in before you can comment on or make changes to this bug.