Compact Gmail IMAP folder doesn't reduce folder size displayed in folder pane (except for in All Mail, Trash and Spam)

RESOLVED INCOMPLETE

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Peter Fischer, Unassigned)

Tracking

(Blocks: 1 bug)

x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; InfoPath.1)
Build Identifier: http://mozilla.isc.org/pub/mozilla.org/thunderbird/releases/2.0.0.12/win32/de/Thunderbird%20Setup%202.0.0.12.exe

DELeted eMails (iMap/Gmail) are NOT DELeted while COMPACTing Folder (OFFline-readable) ;-(

Displayed Mbox-Size in Left windows seems to be correct!

Reproducible: Always

Steps to Reproduce:
1. DELete eMail(s) in Gmail via Browser...
2. TRY to COMPACT OFFline-readable Folder... while u are ONline!
3. watch Mbox-Size in Left windows ;-)
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0

Comment 1

10 years ago
It works for me.  
When Gmail IMAP, "IMAP mail folder == label at Gmail Web" and "delete/move of a mail" means "immediate remove of label of Gmail Web". Then, from IMAP client view, click of mail folder after mail delete is currently identical to next on usual IMAP server.
 1. Client-1 : Delete a mail from a folder (==request to flag as \Deleted)
 2. Client-2 : Expunge to the mail folder
 3. Client-1 : Click the folder (re-sync)
    At this step, mails flagged as \Deleted are not passed to client.
    Then, size at this step becomes same one after Expunge.
 4. Client-1 : Compact folder
               When offline-use=On, copy of already deleted mails
               are removed from local file for offline copy.

Because Gmail IMAP returns OK to undelete request just after delete(==request to flag as -\Deleted), I think bug of Gmail IMAP is involved(See Bug 417167 and Bug 427007). But above is current implementation of Gmail IMAP.

Read documents/bugs pointed in meta Bug 402793, please. 
 
Blocks: 402793

Comment 3

10 years ago
AFAIK gimap doesn't support compacting/expunging... It's not exactly a conventional imap server.

->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 4

10 years ago
Gmail does support expunge, but it is only meaningful in All Mail, Trash and Spam.

Comment 5

10 years ago
It does?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 6

10 years ago
Yes.  If you mark a message deleted in a user-label folder, Gmail simply removes the label, and reports it as expunged as soon as possible.  Issuing an EXPUNGE command simply returns OK.

In All Mail, Trash and Spam, messages marked deleted actually pick up the \Deleted flag.  An EXPUNGE command will then delete them.  (They are, in effect, the only "real" folders.)


Comment 7

10 years ago
I see. Updating summary... 
However, I'm pretty sure I saw this earlier, can't reproduce anymore though (with a trunk build) so I assume something changed. 

Can someone confirm the problem is gone?
Summary: COMPACT iMap-Folder (Gmail) does NOT really DELete DELeted eMails! → Compact Gmail IMAP folder doesn't remove deleted mail except for in All Mail, Trash and Spam

Comment 8

10 years ago
Just a quick update.  Gmail no longer stores the \Deleted flag on messages in "All Mail", although it indicates success.  Because of that, EXPUNGE is now meaningless in that folder. 

Trash and Spam still behave normally.

I still cannot recreate the original reported problem.  Whether I delete messages or remove their labels through the browser, Thunderbird picks up on it.
Bug summary is incorrect(since initial), I believe.
> Compact Gmail IMAP folder doesn't remove deleted mail except for in All Mail, Trash and Spam

(A) Other than [Gmail]/All Mail, [Gmail]/Trash, [Gmail]/Spam

Upon "uid store UID_of_mail +FLAGS (\Deleted \Seen)" request by Tb, Gmail/Gmail IMAP behaves as if Expunge is requested from client at same time. So mail folder size displayed in Tb's folder pane is already file size after Expunge. Therefore, folder size in folder pane won't reduce upon "Compact Gmail IMAP folder".

(B) [Gmail]/All Mail

Gmail IMAP's behaviour is already changed. So same as (A) with "[Gmail]All Mail".

(C) [Gmail]/Trash & [Gmail]/Spam

\Deleted flag is supported by Gmail IMAP as usual IMAP does, so "mail folder size in folder pane of Tb" reduces when "Compact Gmail IMAP folder" by Tb.
To Peter Fischer(bug opener):

Current bug summary is apparently INVALID, because problem described by the bug summary never exists.
Your comment #0 sounds for me to be report of "folder size in folder pane is not reduced upon compact folder". And if it's right, this bug can be confirmed(although this bug should be closed as INVALID later because Gmail IMAP's spec). So I change bug summary to one which reflects your comment #0, for ease of tracking, for ease of search.
Please change to appropriate one, if my change is wrong or not so good.
Summary: Compact Gmail IMAP folder doesn't remove deleted mail except for in All Mail, Trash and Spam → Compact Gmail IMAP folder doesn't reduce folder size (except for in All Mail, Trash and Spam)
Oh, bug summary I saw was Magnus Melin's crisp translation of initial bug summary by bug opener.
Magnus, do you agree with my bug summary change?
Peter can you answer wada's questions ?

Comment 13

9 years ago
Peter appears to be gone
=> incomplete
if new information comes to light, please update the bug

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → INCOMPLETE
Summary: Compact Gmail IMAP folder doesn't reduce folder size (except for in All Mail, Trash and Spam) → Compact Gmail IMAP folder doesn't reduce folder size displayed in folder pane (except for in All Mail, Trash and Spam)
You need to log in before you can comment on or make changes to this bug.