Closed Bug 428975 Opened 12 years ago Closed 12 years ago

Print selection prints blank pages on reddit.com due to "overflow: hidden"

Categories

(Core :: Printing: Output, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: dholbert, Assigned: dholbert)

References

(Blocks 1 open bug, )

Details

(Keywords: regression, testcase)

Attachments

(10 files)

869 bytes, text/html
Details
113 bytes, text/html
Details
114 bytes, text/html
Details
88 bytes, text/html
Details
436 bytes, text/html
Details
12.58 KB, application/pdf
Details
12.59 KB, application/pdf
Details
289 bytes, text/html
Details
290 bytes, text/html
Details
242 bytes, text/html
Details
I'm filing this bug as a follow-up for remaining "print selection prints blank pages" issue that some people are seeing, even after the patch for bug 402264 landed. (e.g. bug 402264 comment 64)

Handy testcases to use:
  attachment 314216 [details]
  attachment 314434 [details]
Flags: blocking1.9?
(In reply to bug 402264 comment #61)
> I tested according to your advice.
> Nothing was still output.

(In reply to bug 402264 comment #63)
> Firefox 3 last nightly doesn't print yet.

Hideo and Mrtb -- just to be clear, are you guys seeing *blank* pages printed, or *no* pages printed?
I'll leave this on the nom list until we have more info. 
(In reply to comment #1)
> (In reply to bug 402264 comment #61)
> > I tested according to your advice.
> > Nothing was still output.
> 
> (In reply to bug 402264 comment #63)
> > Firefox 3 last nightly doesn't print yet.
> 
> Hideo and Mrtb -- just to be clear, are you guys seeing *blank* pages printed,
> or *no* pages printed?

No pages are printed for both testcases with recent trunk/Linux.
dholbert can't reproduce this issue.  If we get a consistent test case, please re-nom.  -'ing.
Flags: blocking1.9? → blocking1.9-
(In reply to comment #4)
> dholbert can't reproduce this issue.  

Yup, this is WORKSFORME in both Linux (Ubuntu 8.04 beta) and Windows Vista, using latest-trunk.

> (In reply to comment #3)
> No pages are printed for both testcases with recent trunk/Linux.

@Hideo:  Ok, that sounds like something different then -- can you file a new bug for the "no pages printed" issue that you're seeing?  (I'm getting a debian unstable Virtual Machine set up to see if I can reproduce that)

@mdew: This bug is open for the blank-pages issue that you reported still happening in bug 402264 comment 64 -- can you retest using latest-trunk and say if you still see it?  Also, what Windows version are you using?

Also: can anyone else reproduce the "print-selection prints blank pages" issue, or is it just mdew?
(In reply to comment #5)
> @Hideo:  Ok, that sounds like something different then
> (I'm getting a debian
> unstable Virtual Machine set up to see if I can reproduce that)

FWIW: I've finished setting up a fully-updated Debian Unstable VM, with the "cupsys" and "gtk2-engines" matching the versions that Hideo mentioned in bug 402264 comment 61.  On that VM, print-selection WFM using latest-trunk.

So, I don't know why Hideo would be seeing these issues.  Hideo, please file a bug if you're still seeing no pages being output.
Daniel, try doing this.

1. Open www.reddit.com
2. select and article and text (any number)
3. Print, selection.
4. blank page (header is fine)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041519 Firefox/2.0b2  (under windows XP)
Tried to minimise a testcase for this

1. Select the text in the grey feild
2. File, Print, Selection, Print.
3. Nothing prints (except the header)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041519 Firefox/2.0b2
mdew: Thanks very much for the additional information and testcase!

I can confirm this bug, both on reddit.com (selecting part of an article title on the front page) and using the testcase you posted.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008041504 Minefield/3.0pre
Ubuntu Linux 8.04 beta
Assignee: nobody → dholbert
Summary: Print selection still prints blank pages on some systems → Print selection prints blank pages on reddit.com
(In reply to comment #6)
> (In reply to comment #5)
> So, I don't know why Hideo would be seeing these issues.  Hideo, please file a
> bug if you're still seeing no pages being output.
 
I filed bug 429312.
This looks like the same bug as this one.
(source: bug 428339 comment 4)
 - Load http://www.stpauls.it/domenica/0829do/0829dohp.htm#PAR
 - Select from "LITURGIA DEL GIORNO" to the end of the page
 - Print-selection
Result (for me):  prints blank page.  (although In bug 428339 comment 4, mrtb says part of the paragraph prints for him.)
"Mine" bug doesn't work from 20070207 build.
But the changelogs are empty. See here: http://forums.mozillazine.org/viewtopic.php?t=517765 http://forums.mozillazine.org/viewtopic.php?t=517433

I think that the patch the caused it is this http://bonsai.mozilla.org/cvslog.cgi?file=/mozilla/layout/printing/nsPrintEngine.cpp&rev=1.137 of bug show_bug.cgi?id=177805
The bug number is 177805
(In reply to comment #13)
> "Mine" bug doesn't work from 20070207 build.

Thanks Mrtb -- I can confirm that regression window for this bug.  (tested builds by selecting article titles on reddit.com & printing selection)

 20070206: works
 20070207: text is shifted up & cut off

Bonsai Link: http://tinyurl.com/5wrpdq

(In reply to comment #14)
> The bug number is 177805

Yup, that's definitely a good candidate.
(By the way, Mrtb -- if you put the word "bug" before the number, then bugzilla will auto-link it, like this: bug 177805)

Also -- the posted testcase (attachment 315911 [details]) seems to be broken in Firefox 2, so that one's a different, non-regression bug.
Attachment #315911 - Attachment description: Testcase → Testcase [ Different issue -- broken in FF2 as well ]
(In reply to comment #16)
> Yup, that's definitely a good candidate.
> ...bug 177805

Yup -- that's the only checkin that touched the layout directory for that nightly.

Marking dependency.
Blocks: pixels
(In reply to comment #16)
>  20070206: works
>  20070207: text is shifted up & cut off

Actually, looking a little further in the future, it looks like the major regression here was from bug 374050.

Testing reddit article title selection printing, I see:
20070320: Get some printed output (though it's not everything I selected)
20070321: Get no printed output
Blocks: 374050
Note:
 - difference between testcases 2a and 2b is a space before the div
 - difference between testcase 2a and reference 2 is "overflow: hidden" on div

Here are two experiments, with my results for each testcase across various builds.

======

EXPERIMENT 1:
 - Open a testcase
 - Select-All with Ctrl-A, or via edit menu.
 - Print selection

RESULTS:
               testcase 2a    testcase 2b    reference 2
               -----------    -----------    -----------
  20070320       full 'a'       full 'a'       full 'a'
  20070320        blank          blank          blank
  20080415        blank     top half of 'a'    full 'a'

=====

EXPERIMENT 2:
 - Same as experiment 1, but select the 'a' *using cursor* (NOT select-all)

RESULTS:
               testcase 2a    testcase 2b    reference 2
               -----------    -----------    -----------
  20070320       full 'a'       full 'a'       full 'a'
  20070320        blank          blank          blank
  20080415        blank          blank         full 'a'


(Note that the difference between the results is on 20080415 for testcase 2b, whether you get top half of 'a' vs. blank output.)
Re-nominating for blocking1.9, as we now have a consistent testcase that shows the regression.
Flags: blocking1.9- → blocking1.9?
Keywords: regression, testcase
Summary: Print selection prints blank pages on reddit.com → Print selection prints blank pages on reddit.com due to "overflow: hidden"
BTW, I get the same buggy behavior on tesctcase 2a/2b if I use overflow:auto or overflow:scroll instead of overflow:hidden.
Overall, I think we're at a point where printing is in decent shape to ship.  While this bug should be fixed, I don't see us holding back the release for this.  Daniel, please request approval once reviews are completed.
Flags: blocking1.9? → blocking1.9-
Now this bug seems to be fixed after the last nighlty (2008042207)

Testcase 2a, 2b and reference 2 seem to work properly.
Attached file testcase 3
(In reply to comment #27)
> Testcase 2a, 2b and reference 2 seem to work properly.

Yup, those now work for me, too.

However, reddit.com itself still seems to be broken -- when I select a chunk of any article title below the first one on the front page, I get blank print-selection output.

I've minimized that to this testcase, which shows overlapping text when I select-all and print.  (The overflow:hidden divs all seem to be shifted upwards about half-a-line.)
(In reply to comment #28)
> The overflow:hidden divs all seem to be shifted upwards
> about half-a-line.)

I just compared print-selection to print-normal, and it's in fact the reverse of this.

The overflow:hidden divs are in the correct place, and the *NON*-overflow:hidden content is shifted DOWN about half-a-line
Attachment #317628 - Attachment description: testcase 3 output (select-all, print-selection --> broken) → testcase 3 broken output (select-all, print-selection)
Attached file testcase 4
To get broken output: (with "first line" incorrectly shifted downwards)
 - Load testcase
 - Select all with Ctrl-A
 - Print selection

Interestingly, if I use the *mouse* to try and select-all via text-highlighting, I get *correct* output.  So the breakage has something to do with the invisible initial whitespace being selected. (which I can only do with select-all.)
Attached file reference 4a
(In reply to comment #32)
> So the breakage has something to do
> with the invisible initial whitespace being selected.

Here's a reference case with that initial whitespace removed.  It gives expected output.
Attached file reference 4b
This reference case avoids the bug by not using overflow:hidden.
(In reply to comment #34)
> Created an attachment (id=317638) [details]
> reference 4b
> 
> This reference case avoids the bug by not using overflow:hidden.

Actually, reference 4b avoids the *overlap* -- however, it still shows the text-shifted-down bug.  The difference is that *both* lines are shifted down, whereas the testcase only shifts down the first line.
Filed bug 430748 for the text-shifted-down issue -- I think that covers testcase 4.

Gonna work on that bug, and we'll see if that fixes these remaining issues on reddit.com described in comment #28.
Patch v1 on bu(In reply to comment #36)
> Filed bug 430748 for the text-shifted-down issue -- I think that covers
> testcase 4.

Cool -- patch v1 on bug 430878 fixes testcase 4 here, as well as the remaining issue on reddit.com described in comment 28.
Per comment 37, the remaining were fixed by the checkin for bug 430878.
 --> Fixed.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
does this fix the orginal testcase I posted?
Tests should go in reftest (eventually if we're missing harness-work for it), methinks.
Flags: in-testsuite?
(In reply to comment #40)
> Tests should go in reftest (eventually if we're missing harness-work for it),
> methinks.

Agreed, though we are indeed currently missing harness-work for it.  See bug 428037, 'Need ability to reftest "print-selection" feature'.
(In reply to comment #39)
> does this fix the orginal testcase I posted?

No, it doesn't fix that testcase in my build.  However, as I indicated in comment 16, that's due to a different bug which is also present in Firefox 2.

mdew, if you file a follow-up bug with that testcase, and CC me, I'll see what I can do.  (though I can't promise anything, as I'm focusing more on regressions between Firefox 2 and Firefox 3)
Blocks: 431308
Flags: wanted1.9.0.x?
You need to log in before you can comment on or make changes to this bug.