[10.5] Can't switch tabs with CTRL + Tab

VERIFIED FIXED in mozilla1.9

Status

()

Core
Widget: Cocoa
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: bsterne, Assigned: masayuki)

Tracking

({regression})

Trunk
mozilla1.9
All
Mac OS X
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [key hell])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
 
(Reporter)

Comment 1

10 years ago
In the latest nightly build I'm unable to switch tabs using CTRL + Tab (or CTRL + Shift + Tab).  Using Option + Command + Arrow does work.
Summary: Can't switch tabs with CTRL + Tab (ro → Can't switch tabs with CTRL + Tab

Updated

10 years ago
Flags: blocking1.9?
This needs to be in Widget:Cocoa.
Assignee: nobody → joshmoz
Component: Tabbed Browser → Widget: Cocoa
Keywords: regression
QA Contact: tabbed-browser → cocoa
I wonder if this is related to bug 429510 ?

+'ing this until we know.  Dammit.
Flags: blocking1.9? → blocking1.9+
(In reply to comment #3)
> I wonder if this is related to bug 429510 ?

I don't think so.

Brandon, do you know in which nightly this last worked?

Comment 5

10 years ago
20080422_2022 works
20080422_2051 fails
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1208920920&maxdate=1208922659
regression from Bug 423814.

I can't understand Cocoa key handling...
(In reply to comment #5)
> regression from Bug 423814.

It's strange. keyDown is not called??
(Reporter)

Comment 7

10 years ago
CTRL + Tab (and CTRL + Shift + Tab) work in the 2008042204 nightly but don't work in the 2008042304 nightly.
I cannot reproduce this bug on 10.4 (like bug 423814!).

It seems that when we return NO in pKE at *some* key combination, that doesn't fire keyDown.
Josh:

Do you have idea for this bug?

Comment 10

10 years ago
(In reply to comment #8)
> I cannot reproduce this bug on 10.4 (like bug 423814!).
> 
> It seems that when we return NO in pKE at *some* key combination, that doesn't
> fire keyDown.

I can reproduce on 10.5.2.
When I press Ctrl+(normal key), keyDown is called.
But when I press Ctrl+Tab or Ctrl+Esc, keyDown is not called.

Updated

10 years ago
Summary: Can't switch tabs with CTRL + Tab → [10.5] Can't switch tabs with CTRL + Tab
Created attachment 318412 [details] [diff] [review]
Patch v1.0

Maybe, this fixes this bug (and bug 431080)....
Attachment #318412 - Flags: review?(joshmoz)
(Assignee)

Updated

10 years ago
Blocks: 431080
Whiteboard: [key hell][needs review]

Comment 12

10 years ago
we need to add a keyboard navigation litmus suite for these kind of tests
Flags: in-litmus?

Comment 13

10 years ago
Masayuki: we have 10.5 here in the lab.  Can you provide us a tryserver build with your patch?  We can test it then.

Comment 14

10 years ago
Tomcat has built the fix on his tryserver build.   Will be testing today, and report back here when completed.
(In reply to comment #14)
> Tomcat has built the fix on his tryserver build.   Will be testing today, and
> report back here when completed.
> 
The tryserver build can be found here: https://build.mozilla.org/tryserver-builds/2008-04-29_16:07-cbook@mozilla.com-1209510375/
Masayuki, i tested your patch with the Tryserver Build 

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008043000 Firefox/3.0pre -> normal debug build fail without the patch, as reported in comment #1 from Brandon.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008042916 Minefield/3.0pre the tryserver build with your patch works fine and Tab Switching via CTRL + Tab / CTRL + Shift + Tab is working as expected :) 

For Bug 431080 we maybe should ask the reporter to try out the tryserver build, if this patch fix his reporter bug.



Created attachment 318548 [details] [diff] [review]
Patch v1.1

oops, sorry. the previous patch has wrong condition.
Assignee: joshmoz → masayuki
Attachment #318412 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #318548 - Flags: review?(joshmoz)
Attachment #318412 - Flags: review?(joshmoz)

Comment 18

10 years ago
Comment on attachment 318548 [details] [diff] [review]
Patch v1.1

I think we should take this patch, it is the best we can do in a reasonable time frame. I'm going to continue looking into this key behavior though.
Attachment #318548 - Flags: superreview?(roc)
Attachment #318548 - Flags: review?(joshmoz)
Attachment #318548 - Flags: review+

Updated

10 years ago
Attachment #318548 - Flags: superreview?(roc) → superreview?(vladimir)
Attachment #318548 - Flags: superreview?(vladimir) → superreview+

Updated

10 years ago
Attachment #318548 - Flags: approval1.9?
Comment on attachment 318548 [details] [diff] [review]
Patch v1.1

a1.9+=damons
Attachment #318548 - Flags: approval1.9? → approval1.9+
checked-in.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Whiteboard: [key hell][needs review] → [key hell]
Verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008050209 Minefield/3.0pre
Status: RESOLVED → VERIFIED
Hardware: PC → All
Target Milestone: --- → mozilla1.9
in-litmus+:

Covered by https://litmus.mozilla.org/show_test.cgi?id=4219
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.