scrolling a page (using mouse wheel or scroll bars) chunky, jittery

RESOLVED DUPLICATE of bug 372039

Status

Core Graveyard
GFX: Win32
RESOLVED DUPLICATE of bug 372039
10 years ago
9 years ago

People

(Reporter: David Poole, Unassigned)

Tracking

Bug Flags:
wanted-next +
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050206 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050206 Minefield/3.0pre

With my modest computer (XP 2400+) scrolling my clan's page, the page scrolls down very slowly, with Firefox 2.0.x it works fine.

Using my other PC with a 3800+ chip in, it seems fine. Checked using latest trunk exactly the same.

Reproducible: Always

Steps to Reproduce:
1. Load Page
2. Scroll
3. Watch it jittery
Actual Results:  
Jitters

Expected Results:  
Smooth Scrolling
Confirmed, the site does act very jittery in FF3, (tried it on a slower pc in FF2 and it worked perfectly, while on my power pc it jittered on FF3)

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008050206 Minefield/3.0pre

I put together a testcase and found that just the background image alone when set to fixed (in the style) produces this problem (perhaps because of the size of it?)

maybe a blocker?
Flags: blocking-firefox3?

Comment 2

10 years ago
I've seen similar bugs before about Fx2 vs. Fx3 performance, especially with jittery scrolling, just can't remember the bug number atm.
Whiteboard: DUPEME
--> Core::GFX

This isn't blocking, but I'm cc'ing Vlad and Stuart as most of the scrolling problems we've seen to date have been with OSX (see bug 424308, bug 399248, bug 398137, and bug 418351) whereas this one seems to be Windows-only; OSX seems to scroll pretty OK on the sample URL.

Possibly related bugs are: bug 421601, bug 422330, bug 405740.
Component: General → GFX: Win32
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: general → win32
Summary: Scrolling is slow and jittery compared to Firefox 2.0.x → scrolling a page (using mouse wheel or scroll bars) chunky, jittery
Whiteboard: DUPEME
Status: UNCONFIRMED → NEW
Ever confirmed: true
Oh, and in other places Vlad has said Compositor might help here, though Roc wasn't so sure. cc'ing Roc for good measure, too.
Flags: wanted-next+
Flags: blocking1.9-
I think I found a dupe for this, bug #90198, apparently this is an ongoing problem (the bug has been open since 2001). :)
(Reporter)

Comment 6

10 years ago
Well since it works fine in Firefox 2.0.x, I don't think so :)
It started then, but changed over time, they definitely have to do with each other as the whole problem here is the background fixed style, probably not a dupe but a patch there might help here (or make this worse!)

;)
(Reporter)

Comment 8

10 years ago
Ok, found more.

Opera reacts the same. :)

So disabled Background image as suggested in Opera, this sorted it.

Therefore, disabled Background Image in FF 3 Beta 5 with Ad Block Plus, this sorted it.

So the background image is definitely causing it.

Comment 9

10 years ago
this works the same on linux and probably osx.

change os to all.

Comment 10

10 years ago
I'm changing OS to all based on comments and changing version to Trunk, because it's not like it's going to get fixed on the 1.9.0.x branch at this point.

But this bug either needs duplicating or finding out a simple test case for it, it's far too vague to be seriously tackled by a developer at the moment.
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
but where user can get useful for developer info from?

Comment 12

10 years ago
(In reply to comment #6)
> Well since it works fine in Firefox 2.0.x, I don't think so :)
> 

I'd agree :)


Anyhow, the same behaviour is shown on those sites upon scrolling

http://sga.gatech.edu
http://www.gameswelt.de
http://www.cssmagazine.it
http://arvidaxelsson.se/blog

Strangely http://www.csseleven.com works fine until the sidebar is opened, after which it lags as well

Comment 13

10 years ago
Someone has pointed out on the mozillazine forums that at least on some sites the very slow scrolling is caused by the background image being rescaled.  By resizing the window horizontally (try 1px), the scrolling may get fast again.

The rescaling (slight blurring) is noticeable in the top right corner (look at the text) on this site: http://www.contra.gr/pressroom.html

Of the sites reported in comment #12, all behave like this (i.e. scrolling speed may change by a 1px change in window width), except http://sga.gatech.edu/, which always scrolls slowly, no matter how wide the window is.

Another thing I noticed is that on several sites (e.g. http://arvidaxelsson.se/blog or http://www.cssmagazine.it/), the scrolling is always slow at the very bottom of the page (even if the background image is not rescaled).

Now one question (that I don't have the expertise to answer) is: is the window-width-dependent rescaling a bug in the browser or is it a consequence of the coding of these sites?  If this is a problem with the browser, is there any chance that is would get fixed in one of the 3.0.x releases?

Comment 14

10 years ago
Reading my previous comment, it is not formulated very clearly ...  Here's a clarification:

To see this phenomenon (and reproduce the very slow scrolling), 

1. Go to the following site: http://www.contra.gr/pressroom.html
2. Scroll vertically, and note the speed
3. Reduce the window size by exactly one pixel, and go back to step 2.

While repeating steps 2. and 3., notice that scrolling speed alternates between smooth and very slow.  Also the background image alternates between scaled and not scaled.

Here's the forum thread where this was mentioned:

http://forums.mozillazine.org/viewtopic.php?t=653791&postdays=0&postorder=asc&postsperpage=15&start=169

(Sorry for the bugspam ... I just wanted to make this very clear.)
The blurring is fixed by bug 433640.

Bug 433640 comment 45:
> -> fixed for 1.9.1
> 
> It's too late for Firefox 3 at this point; we'll try to get it in for 3.0.1.
Depends on: 433640

Comment 16

10 years ago
Duplicate of bug 361754?
(In reply to comment #16)
> Duplicate of bug 361754?

Probably not this bug is about pages using background:fixed images.

Updated

10 years ago
Duplicate of this bug: 440107

Comment 19

10 years ago
(In reply to comment #15)
> The blurring is fixed by bug 433640.

I can't say whether actually the blurring was the reason for this bug, however once one zooms the page (along with the new image zooming, text-only not) the bug is suddenly back again.
(In reply to comment #17)
> (In reply to comment #16)
> > Duplicate of bug 361754?
> 
> Probably not this bug is about pages using background:fixed images.
> 

Well, the reporter linked a site without fixed backgrounds. So this is a duplicate of Bug 361754. 
On the contrary other examples attached to this bug refer to Bug 372039.
(In reply to comment #20)
> Well, the reporter linked a site without fixed backgrounds. So this is a
> duplicate of Bug 361754. 
> On the contrary other examples attached to this bug refer to Bug 372039.

Well originally the linked site had a background:fixed image and that's when it was performing poorly, the site has changed since and does not have this problem anymore, however the other sites linked in comments here do have background:fixed and are problematic.

Ok, so this is a duplicate of Bug 372039. Sorry for the misunderstanding. I remove the site link, since it's no more related.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 372039
(Assignee)

Updated

9 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.