Improve search plugins landing page

RESOLVED DUPLICATE of bug 426239

Status

addons.mozilla.org Graveyard
Search Plugins
RESOLVED DUPLICATE of bug 426239
10 years ago
2 years ago

People

(Reporter: morgamic, Assigned: madhava)

Tracking

Details

(Reporter)

Description

10 years ago
The current search plugins landing page confuses people, we need a better design for this page that:

* lets new users understand what a search plugin is
* has a condensed browser for people to search by URL/site or category
* has a more prominent reference to mycroft and other projects
* has relevant links to documents saying how to make a search plugin

Comment 1

10 years ago
I'd really like to see a fix - even of the quick and dirty kind - to this prior to Firefox 3 release. I accept the charge of bias on this issue but do feel I speak for Firefox users looking for a search plugin as well - while bug 426234 has increased the number of visitors to Mycroft slightly, these are still well down compared to pre-25/03

Is there any chance of a note on https://addons.mozilla.org/en-US/firefox/browse/type:4/cat:all?sort=name advising of other choices if the selection are not what the user wants or something similar to prevent the current dead end that is faced?
Duplicate of this bug: 440826

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 426239
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.