Make search plugins easy to find and install

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Search Plugins
RESOLVED FIXED
10 years ago
2 years ago

People

(Reporter: morgamic, Unassigned)

Tracking

Dependency tree / graph

Details

(URL)

(Reporter)

Description

10 years ago
The current site doesn't let users find search plugins easily.  We just have to do more/try harder/change this.  This is a meta-bug to track this set of features.  Below are some thoughts I've written about this previously in emails:

<quote>
It's our responsibility to encourage and educate users about search engines, which is something we fail to do when we group "search tools" in a long list of categories.  We are fitting everything nicely into categories so it looks nice but it's not helping users looking for a search plugin.  I'm not clear on why we are burying these search plugins and making them less obvious with no marker saying "hey add me to your search bar".  In my opinion this is wrong.  It's not about perfect, it's about not making users think more for no reason.

This is an important cool feature in Firefox and I don't think we're helping users find and understand it at all.  Because it has no established familiarity it's even more important to segregate it and highlight it somehow.  Where we are now, we're not making things more efficient for users to find this stuff.
</quote>

For starters, we should think of ways to build off of mycroft and use these use-cases as examples:
http://mycroft.mozdev.org/

Updated

10 years ago
Depends on: 426234

Updated

10 years ago
Depends on: 433739

Comment 1

10 years ago
From bug 426234 comment 16

With bug 426085, a user has to click back up to the Search Tools category page
to find this which is a click path I doubt many users will find:

Click dropdown
'Manage Search Engines...'
'Get more search engines...'
(a.m.o/en-US/firefox/browse/type:4/cat:all?sort=name)
Can't find what I want here...
?Click Search Tools

I recommend links to further search plugins should be on the page that users land at through the links in browsers.
That would be bug 433433, I think, Charles. This bug is more about making it easier to find the search plugins from the main AMO page. I agree, though, that people are probably more likely to get to search plugins from the in-browser UI.

Comment 3

9 years ago
Is there already a bug for Firefox not being able to create (opensearch)search plugins? Like Opensearchfox plugin or Opera is doing; in the context menu of a text field: "Create Search...". 

That way, users wouldn't need to search for plugins, just make them themselves.
Or am I missing something?

Comment 4

9 years ago
One very simple thing to do is to add the Mycroft search plugin to the default installation.

It is always the very first thing i do when i install Firefox. (The second thing i do is adding the Firefox add-ons search plugin, but that's a separate issue.)

It should be given a different name, though, because for most users the name "Mycroft" has nothing to do with search engines. "Add search plugins" would be a good name.

Updated

9 years ago
Duplicate of this bug: 433433
Depends on: 525594
https://addons.mozilla.org/en-US/firefox/browse/type:4
Status: NEW → RESOLVED
Last Resolved: 8 years ago
No longer depends on: 525594
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.