Closed Bug 434157 Opened 12 years ago Closed 12 years ago

Font scaling of Vista doesn't work as good with RC1 than it did with Betas

Categories

(Core :: Graphics, defect)

x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9

People

(Reporter: tobine, Assigned: roc)

References

Details

(Whiteboard: [RC2+])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9) Gecko/2008051206 Firefox/3.0

I'm using MS Vista on a LCD-TV (1080p). I've set the font scaling to 144 dpi, so I can read the application menus as well as the websites.
With Firefox 3 Beta (including Beta 5), it worked perfectly. The navigation bar as well as the websites were scaled.
Now, with RC1, the icons in the navigation bar stay pretty small (I didn't set "small icons"!) and I've to scale up every website I visit manually (STRG+). At least, Firefox remembers that setting per site, but anyway.

Reproducible: Always

Steps to Reproduce:
1. Set font scaling to higher dpi
2. Start Firefox and open website
Actual Results:  
Website scaling in Firefox ist not affected by Windows setting.
Navigation bar icons aren't affected, either.

Expected Results:  
All scaling should be done as it is set in Windows settings.

I switched early from Firefox 2 because of the better scaling in Firefox Betas! That's a major regression for me!
Duplicate of this bug: 434257
Could you get a regression range?
Sorry, I was sick.

Scaling worked including version
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008033105 Minefield/3.0pre

It is broken since
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008040106 Minefield/3.0pre

I hope that helps!
Flags: blocking-firefox3?
Probably the result of bug 394103
Status: UNCONFIRMED → NEW
Depends on: 424822
Ever confirmed: true
Version: unspecified → Trunk
--> Core::GFX/Thebes, I don't think this is a Firefox 3 blocker, but we'll want to fix it in one of the dot-dot updates, probably.

I'm a little worried that this is going to come down to a choice between addressing the concerns of those who filed bug 394103 or this one, though in that case, I think since those running into bug 394103 were hitting it due to kookiness in their Linux configs, this bug is gonna win.
Component: OS Integration → GFX: Thebes
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: os.integration → thebes
Flags: wanted1.9.0.x+
Flags: blocking1.9?
Flags: blocking1.9.0.1?
I had marked bug 424822 as a dependency, as that would allow users to override the behavior added in bug 394103.  Alternatively, the new behavior in bug 394103 could be reverted, and bug 424822 could be used to allow Linux users to hack around their problem.  Either way, we'll need bug 424822.
I think at this point I'm more about reverting bug 394103, but again, I can wait until after we ship, I think.
Whiteboard: [RC2?]
Vlad believes that we should #ifdef MOZ_WIDGET_GTK2 the change from bug 394103, since the misrepresentation of DPI appears to be limited to Linux, and that's the conservative play.  I have no reason to doubt him.
Whiteboard: [RC2?]
I guess whiteboard isn't one of the fields that bugzilla lies about in the mid-air message. ;(
Whiteboard: [RC2?]
Roc: can you implement the fix from comment 8 and put it up for review ASAP? Thanks!
Flags: blocking1.9? → blocking1.9+
Whiteboard: [RC2?] → [RC2+]
Assignee: nobody → roc
Attached patch fixSplinter Review
Attachment #322574 - Flags: review?(vladimir)
Comment on attachment 322574 [details] [diff] [review]
fix

Sure, add a comment at least referencing this bug number?  (Or explaining what's going on, if you understand what the underlying issue is)
Attachment #322574 - Flags: review?(vladimir) → review+
You mean something like
   // be more conservative about activating scaling on GTK2, since the dpi
   // information is more likely to be wrong
?
Comment on attachment 322574 [details] [diff] [review]
fix

a=beltzner, please land on cvsroot asap
Attachment #322574 - Flags: approval1.9+
mozilla/gfx/src/thebes/nsThebesDeviceContext.cpp 	1.78 
Status: NEW → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9
...and the comment:
mozilla/gfx/src/thebes/nsThebesDeviceContext.cpp 	1.79
Flags: wanted1.9.0.x+
Flags: blocking1.9.0.1?
this is still an issue on windows xp with 144 dpi. firefox 3.5 worked just great. i upgraded to 3.6.b3 and suddenly the gui collapsed. screenshots with 3.5 and 3.6b3:

http://clip2net.com/page/m0/2714596 (3.6b3) TOO SMALL
http://clip2net.com/page/m0/2714709 (3.5) SLIGHTLY TOO LARGE, BUT IT'S MUCH MORE CONFORTABLE TO THE EYE, working 8 hours a day at 37' from 2 meters distance
You need to log in before you can comment on or make changes to this bug.