Mac OS X: Active tab is broken in RTL when window is unfocused

VERIFIED FIXED in Firefox 3

Status

()

defect
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: yehudab, Assigned: yehudab)

Tracking

(Blocks 1 bug, {rtl})

Trunk
Firefox 3
All
macOS
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [RC2+])

Attachments

(3 attachments)

(Assignee)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; he; rv:1.9) Gecko/2008051202 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; he; rv:1.9) Gecko/2008051202 Firefox/3.0

Looks like fix for bug 406730 breaks some of the fixes for bug 364536: 
When the window is unfocused, the active tab looks "broken". 



Reproducible: Always

Steps to Reproduce:
1. Open at least 2 tabs on Mac OS X with RTL chrome (e.g. Hebrew version)
2. Switch the current application, so that Firefox is in the background
3. Look at the right and left borders of the selected tab
Actual Results:  
The right and left borders of the selected tab look "broken"

Expected Results:  
The right and left borders of the selected tab should match the middle part of the part

See attached screenshot
(Assignee)

Comment 2

11 years ago
Posted patch css patch Splinter Review
(Assignee)

Updated

11 years ago
Flags: blocking-firefox3?

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

11 years ago
Assignee: nobody → yehudab
Version: unspecified → 3.0 Branch
(Assignee)

Updated

11 years ago
Attachment #321510 - Flags: review?
Version: 3.0 Branch → unspecified
Keven and Steven, it seems that there was something forgotten. Could one of you have a look at the patch?
Hardware: Macintosh → All
Version: unspecified → Trunk
Yehuda, was this really raised by bug 406730? I can't really imagine because it looks like a really different issue.
Attachment #321510 - Flags: review? → review?(gavin.sharp)
(Assignee)

Comment 5

11 years ago
(In reply to comment #4)
> Yehuda, was this really raised by bug 406730? I can't really imagine because it
> looks like a really different issue.
> 

Yes, as far as I can tell. You can see that my patch is over the lines that were added to browser.css in https://bugzilla.mozilla.org/attachment.cgi?id=318989

Updated

11 years ago
Blocks: fx3-l10n-he
Keywords: rtl
(Assignee)

Comment 6

11 years ago
Henry, just to clarify on comment #5: It is not an issue of two unsynched
checkins. Rather that the fix for bug 406730 introduced a new situation that
requires RTL treatment

Updated

11 years ago
Blocks: fx35-l10n-fa
Yeah, I can see now. Looks like that Gavin is the right one to review your patch.
Status: NEW → ASSIGNED
Comment on attachment 321510 [details] [diff] [review]
css patch 

We should take this for RC2, it's a safe RTL-only theme fix.
Attachment #321510 - Flags: review?(gavin.sharp) → review+
Whiteboard: [RC2?]
(Assignee)

Updated

11 years ago
Attachment #321510 - Flags: approval1.9?
Not going to block here, RTL on Mac wasn't even a blocker, and this is relatively minor.  We'll get it for 3.0.1 for sure, or RC2 if we need to do that.
Flags: blocking1.9.0.1+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
Comment on attachment 321510 [details] [diff] [review]
css patch 

a=beltzner, please land asap on cvsroot
Attachment #321510 - Flags: approval1.9? → approval1.9+
Whiteboard: [RC2?] → [RC2+]
mozilla/browser/themes/pinstripe/browser/browser.css 	1.156
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3
(Assignee)

Comment 12

11 years ago
Mike and Gavin,
Thanks for approving and landing this for RC2.

Comment 13

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; he; rv:1.9) Gecko/2008052903 Firefox/3.0

Confirmed fix for RC2. I'll attach a pic.

Comment 14

11 years ago
Posted image Bug Fixed
This is in 10.5 using RC2.

Updated

11 years ago
Status: RESOLVED → VERIFIED

Comment 15

11 years ago
(In reply to comment #14)
> Created an attachment (id=323622) [details]
> Bug Fixed
> 
> This is in 10.5 using RC2.
> 

the image is corrupt.

Updated

11 years ago
Attachment #323622 - Attachment mime type: image/png → image/tiff
(In reply to comment #15)
> the image is corrupt.
Fixed.

Comment 17

11 years ago
Thanks Tomer. :)
Flags: blocking1.9.0.1+

Updated

10 years ago
No longer blocks: fx35-l10n-fa

Updated

10 years ago
Blocks: Persian
You need to log in before you can comment on or make changes to this bug.