"Re:" added even when already present when replying to a message opened from a MIME digest

VERIFIED DUPLICATE of bug 387061

Status

Thunderbird
Message Compose Window
--
minor
VERIFIED DUPLICATE of bug 387061
10 years ago
10 years ago

People

(Reporter: David Woolley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: 2.0.0.14 (20080421)

If you use File|Attachments|Open on a message within a MIME digest (e.g. those generated by Pipermail at mailman.qth.net).  Thunderbird adds Re: at the beginning of the subject even if there was already one there.  It doesn't do this when replying directly to a message.

Reproducible: Always

Steps to Reproduce:
1.Open a MIME multipart/digest message (I do this with double click for its own window, but this is not necessary)
2.Select File|Attachments|Open on a message in the digest that already has Re: at the start of the subject.
3.Select Reply All on that message, but Reply also produces the same result.
Actual Results:  
Subject has bogus Re:

e.g.

Re: Re: [Elecraft] RFTB Sunday Night

when the original subject was

Re: [Elecraft] RFTB Sunday Night

Expected Results:  
Re: [Elecraft] RFTB Sunday Night

The erroneous Re: is the first one, as some mailers use RE: and this appears second.

The specific digest used in this example was:

Elecraft Digest, Vol 49, Issue 40
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0

Comment 1

10 years ago
Confirming on trunk.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Blocks: 269826
(Reporter)

Comment 2

10 years ago
It looks like this one duplicates #387061, although that one says Re: is duplicated when it is actually added.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 387061

Comment 3

10 years ago
Indeed.
Status: RESOLVED → VERIFIED
No longer blocks: 269826
You need to log in before you can comment on or make changes to this bug.