Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Form widgets do not display Japanese correctly

VERIFIED FIXED in M10

Status

()

Core
Internationalization
P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: cpratt, Assigned: rods (gone))

Tracking

Trunk
x86
Windows NT
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Visit http://www.asahi-net.or.jp. Look at the drop-down list; instead of Japanese characters, you get mojibake. This happpens even when everything
else on the page is displayed in Japanese (using the MS Gothic font under NT 4 SP 4 and after editing the prefs.js file to use this font to display
the page).

The HTML in question appears to be:

<!--------form start------>
<table><tr><td valign=top align=left>
</td>
<td valign=top align=left><nobr>
<FORM ACTION="http://cgi.asahi-net.or.jp/cgi-bin/select.cgi" METHOD="GET">
<SELECT NAME="url">
<OPTION VALUE="http://www.asahi-net.or.jp">$B"'A*Br%a%K%e!<(B
<OPTION value="http://www.asahi-net.or.jp/join.html">$B;qNA!&F~2qAk8}(B
<OPTION value="http://www.asahi-net.or.jp/news.html">$B2q0w$X$N$*CN$i$;(B
<OPTION value="http://www.asahi-net.or.jp/service/service_index.html">$B%5!<%S%90FFb(B
<OPTION value="http://www.asahi-net.or.jp/members/members_index.html">$B;vL3<jB3$-(B
<OPTION value="http://www.asahi-net.or.jp/diagram/diagram.html">$BL\E*JLMxMQ0FFb(B
<OPTION VALUE="">--------------
<OPTION value="http://www.asahi-net.or.jp/service/guide/inet_index.html">$B@\B3!&@_Dj(BQ&A

<OPTION value="http://www.asahi-net.or.jp/ap-d-no-j.html">$B9qFb(BAP$B0lMw(B
<OPTION value="http://www.asahi-net.or.jp/info/oversea/oversea-index.html">$B3$30(BAP$B0lMw(B
<OPTION value="http://bbb.asahi-net.or.jp">BBB$B%5!<%S%9(B
<OPTION VALUE="">--------------
<OPTION value="http://www.asahi-net.or.jp/member.html">$B2q0w%[!<%`%Z!<%8(B
<OPTION VALUE="">--------------
<OPTION value="http://www.asahi-net.or.jp/service/soho/soho.html">SOHO$B%5!<%S%9(B
<OPTION value="http://www.mmjp.or.jp/">MMJP$B%[!<%`%Z!<%8(B
</SELECT>
<INPUT TYPE="submit" value="Go!">
</FORM></nobr>
</td></tr>

</table>
<!--------form end------>

Updated

19 years ago
Target Milestone: M4

Comment 1

19 years ago
TFV M4

Updated

19 years ago
Assignee: ftang → trudelle
Summary: Mojibake displayed in forms → Form widgets does not display Japanese correctly

Comment 2

19 years ago
Change the summary from "Mojibake displayed in forms" to "Form widgets does not
display Japanese correctly"

Reassign this to Peter Trudelle. In theory, if peter's engineers call the right
GFX text drawing/measuring routines in the GFX based widget, this should be
solved once peter's engineer switch the HTML form widget to the GFX based
widget from the native OS based widget.

Updated

19 years ago
Assignee: trudelle → karnaze

Comment 3

19 years ago
This and most other forms widgets are karnaze's, reassigning.

Updated

19 years ago
Assignee: karnaze → kmcclusk
Target Milestone: M4 → M5

Comment 4

19 years ago
Reassigning to Kevin, since it will involve gfx based option/select.

Updated

19 years ago
Target Milestone: M5 → M7

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Target Milestone: M7 → M10

Updated

18 years ago
Blocks: 7228

Comment 5

18 years ago
Same as bug #4681?
(Reporter)

Updated

18 years ago
Summary: Form widgets does not display Japanese correctly → Form widgets do not display Japanese correctly

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Should be fixed by Ender-based text widget.  See bug #6262.

*** This bug has been marked as a duplicate of 6262 ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
Depends on: 6262
(Reporter)

Updated

18 years ago
Resolution: DUPLICATE → ---
(Reporter)

Updated

18 years ago
Target Milestone: M10 → M8
(Reporter)

Comment 7

18 years ago
Bug 6262 sez "The following functionality needs to be implemented for editor
Enable Ender as plain text field
Enable Ender as plain text area
Enable Ender as rich text area"

Um, if this bug will be fixed by doing that, great, but that doesn't make this
bug a duplicate of 6262, does it? Reopening bug, changing dependencies to refer
to bug 6262.

Updated

18 years ago
Target Milestone: M8 → M9
Moving to M9

Updated

18 years ago
Target Milestone: M9 → M10
Moving to M10

Updated

18 years ago
Assignee: kmcclusk → rods
Status: REOPENED → NEW
Rod, here is a something to check against the gfx-select
(Assignee)

Comment 11

18 years ago
Could some veryify this on a Japanese platform? Verify using viewer with GFX
widgets turned on.

Comment 12

18 years ago
Someone (Teruko?) will verify this, but you don't need a Japanese system
for displaying Japanese.  Japanese display should work fine on a US system
if you install Japanese fonts.  One such font is the Bitstream Cyberbit
font 2.0 from:
  ftp://ftp.netscape.com/pub/communicator/extras/fonts/windows/

There are 3 versions:
  (1) Cyberbase.ZIP: "complete" Unicode glyph set
  (2) CyberCJK.ZIP: the Chinese, Japanese and Korean glyph subset
  (3) Cyberbit.ZIP: the non-CJK glyph subset

Installing either (1) or (2) will allow you to render Japanese.

Comment 13

18 years ago
Rod,
Did you want viewer or apprunner to be verified?
(Assignee)

Comment 14

18 years ago
For now it just needs to be verified using the viewer with GFX turned on. I will
install the fonts on my work machine on monday, I'm low on disk space here at
home.

Comment 15

18 years ago
I tested this in 8-06-09 Win32, Mac, and Linux build.  When I changed the pref to turn on GFX in Win and Linux,
Apprunner displays form widget correctly.  Mac is not testable.
(Assignee)

Comment 16

18 years ago
What is up with the mac? Can I mark it fixed yet?

Comment 17

18 years ago
I need to correct my previous comment.  Apprunner displays non text form widget correctly.
In Mac, when I turn on the GFX in pref, the page http://www.asahi-net.or.jp/ is displayed as garbage.

Comment 18

18 years ago
The GFX text widgets are being tracked in bug 6262.

On the Mac, bugzilla's display was mangled with the GFX widgets enabled.
Rectangles were being drawn strangely with a Picasso look to it.
(Assignee)

Comment 19

18 years ago
This needs to be assigned to a Mac person. Is safe to describe this bug as "Mac
does not display Japanese characters correctly."

Comment 20

18 years ago
The bugzilla page had no Japanese.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 21

18 years ago
This bug is fixed. A Mac specific bug needs to be opened. Or this can be
re-opened and reassigned.
(Reporter)

Comment 22

18 years ago
To the best of everyone's knowledge, has a bug been opened against the Mac?
(Assignee)

Comment 23

18 years ago
My guess is that it hasn't been opened yet against the mac

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 24

18 years ago
Mac bugs are filed in 12824. OK, the original bug is fixed.  Tested 8-30 Win32 build.
You need to log in before you can comment on or make changes to this bug.