If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Order of accounts in Mail folder pane and Account Settings

VERIFIED FIXED in M18

Status

SeaMonkey
MailNews: Account Configuration
P1
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: jglick, Assigned: Alec Flett)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows 98
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][UE1] Fix in hand [usability])

(Reporter)

Description

18 years ago
"Local Folders" should always be the last account level item in the folder pane.

All Mail accounts should come before all News accounts.

Order:
Mail Accounts (in order added, default is generally first, unless later changed)
News Accounts (in order added)
Local Folders
(Reporter)

Comment 1

18 years ago
nominate as nsbeta3
Keywords: nsbeta3
Target Milestone: --- → M18

Updated

18 years ago
QA Contact: lchiang → nbaca

Comment 2

18 years ago
Ninoschka - don't we have another bug against alecf on ordering of accounts in 
the folder pane?

Comment 3

18 years ago
Marking bug# 28633 a duplicate of this one.

Bug# 28633 states that the accounts are in arbitrary order and explains that the 
order in Account Settings and the Folder pane do not match. 

This bug gives more directions on what order the accounts should be. We should 
also make sure that the order of accounts displayed in Account Settings matches 
the order displayed in the Folder pane. 

Summary: Order of accounts in Mail folder pane → Order of accounts in Mail folder pane and Account Settings

Comment 4

18 years ago
*** Bug 28633 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

18 years ago
this is an account manager bug, reassigning to me.
Assignee: putterman → alecf
Component: Mail Window Front End → Account Manager
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 6

18 years ago
Set to Priority 1 based on UE review meetings.
Priority: P3 → P1
(Reporter)

Comment 7

17 years ago
Opps, my error. After meeting with Mail team, order should be:

All Mail Accounts (default account at top, then in order added), 
Local Folders, 
All News Accounts (in order added).

Updated

17 years ago
Keywords: mail2

Comment 8

17 years ago
+ per mail triage
If Jennifer's solution is hard to implement, is there a way to have the default 
mail server always be at the top of the folder pane?
Whiteboard: [nsbeta3+]
(Assignee)

Comment 9

17 years ago
jennifer's solution is easy, I'll do that.
(Assignee)

Updated

17 years ago
Whiteboard: [nsbeta3+] → [nsbeta3+]Fix in hand
(Reporter)

Updated

17 years ago
Whiteboard: [nsbeta3+]Fix in hand → [nsbeta3+][UE1] Fix in hand
(Assignee)

Comment 10

17 years ago
the one thing about the fix I'm about to checkin is that it doesn't update the
order when someone clicks on the "set as default" button, but that should go in
another bug, and probably doesn't need to be nsbeta3'd
(Assignee)

Comment 11

17 years ago
fix is in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Updated

17 years ago
Whiteboard: [nsbeta3+][UE1] Fix in hand → [nsbeta3+][UE1] Fix in hand [usability]
(Assignee)

Comment 12

17 years ago
jennifer, you saw this was already fixed, right? :)
(Reporter)

Comment 13

17 years ago
Yah, I saw it was fixed!  :-)

I thought if folks wanted to do a search for the usability bugs and see their 
status (how many fixed, how many still open, etc.), it would be good to include 
the fixed ones also.  That way, people can see how good the mail folks are at 
getting stuff fixed!  :-)

Comment 14

17 years ago
Adding ue1 because i felt like it? akin to dveditz@netscape.com's 
nsbeta2/nsbeta3 keyword mass spams.
Keywords: UE1

Comment 15

17 years ago
Build 2000-08-25-08M18: NT4, Linux 6.0, Mac 9.04

It's working much better!

1. Mail folders appear first, followed by Local Folders and then News accounts.
2. Changing the default mail account
- When changing the default mail account (i.e. to qatest33) the change is not
reflected immediately in Account Settings, close the dialog.
- It is not reflected in the Mail folder pane
- Open Account Settings and now the new default account (qatest33) is at the top
of the list, close the dialog.
- The mail folder still does not reflect the change
- The change appears after:
   - Mail is closed and opened again via Navigator, then switch back to Mail.
   - Exiting and restarting Mail.

Question: Can we make the change sooner or should I log another bug to address
item 2 for the next release.
(Assignee)

Comment 16

17 years ago
yeah, let's deal with it in a later release... new bug!

Comment 17

17 years ago
Verified Fixed.

Issue #2: For the new default mail account to appear first and immediatley is
logged in bug# 50841.

Status: RESOLVED → VERIFIED

Updated

17 years ago
Blocks: 61078

Updated

16 years ago
Keywords: UE1

Comment 18

15 years ago
Fixing this bug broke bug 10215

Updated

15 years ago
Blocks: 155951
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.