Account wizard cannot make IMAP-based Gmail accounts

RESOLVED DUPLICATE of bug 400931

Status

Thunderbird
Preferences
--
major
RESOLVED DUPLICATE of bug 400931
10 years ago
10 years ago

People

(Reporter: lars noodén, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5
Build Identifier: Thunderbird 2.0.0.14 (20080505)

The account wizard in Thunderbird 2.0.0.14 makes only POP-based Gmail accounts.  It should also, or instead, allow the creation of IMAP-based Gmail accounts.

Further, it appears the account cannot be switched to IMAP after creation. The account settings -> server settings have 'hard coded' POP Mail Server as server type.  This can be found on Kubuntu as installed from kubuntu-kde4-8.04-alternate-amd64.iso plus updates

$ lsb_release -rc
Release: 8.04
Codename: hardy


Gmail has instructions, which bypass the Gmail option in the wizard, but those that choose Gmail in the wizard choose POP. This is insecure *and* means data is downloaded to the client and erased from the server. Beginners can lose serious data that way.

Gmail's IMAP instructions:
http://mail.google.com/support/bin/answer.py?answer=77662


Reproducible: Always

Steps to Reproduce:
1. File -> New -> Account -> Gmail
2. 
3.
Actual Results:  
A POP-based account is created.

Expected Results:  
1) The choice of POP or IMAP (IMAP == default) or IMAP-only during account creation.

2) The choice of switching from POP to IMAP after the account is made. (That's probably harder to implement.)

https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/235445
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 400931
You need to log in before you can comment on or make changes to this bug.