Enable predefined IMAP settings for Gmail

RESOLVED FIXED in Thunderbird 3.0b1

Status

P1
enhancement
RESOLVED FIXED
11 years ago
a year ago

People

(Reporter: omarb.public, Assigned: mkmelin)

Tracking

(Depends on: 1 bug)

unspecified
Thunderbird 3.0b1
Dependency tree / graph
Bug Flags:
wanted-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
IMAP is now enabled for Gmail. Actually when you add a new account it's possible to select Gmail but all predefined settings are for POP access. If I want to add IMAP access I need to go through 'Email account'

Steps to reproduce:
1 Enable IMAP in your Gmail account.
2 Open Thunderbird, and select Tools > Account Settings.
3 Click Add Account.
4 Select the Email account radio button and click Next. The Identity screen appears.
5 Enter your full name in the Your Name field. Enter your full Gmail email address (username@gmail.com) in the Email Address field, and click Next.
6 Select IMAP as the type of incoming server you are using. Enter imap.gmail.com in the Incoming Server field.
etc.

Expected result:
Just select Tools > Account Settings > Add Account > Gmail and then select IMAP or POP access
(Reporter)

Updated

11 years ago
OS: Windows XP → All
Hardware: PC → All
Duplicate of this bug: 400978
I would even go further and suggest that IMAP be promoted as a better default than POP.

Comment 3

11 years ago
Furthermore, this should also set the locations for special folders (Drafts, Deleted, Sent).

In the case of sent mail, I believe IMAP should only be used to store a copy if the user is NOT using Google's SMTP server (which does it for you).  For example, I have to use my home ISP's SMTP server, so I do need to record sent mail by recording a copy with IMAP.
not to forget the Trash folder as well. See:

http://lifehacker.com/software/geek-to-live/turn-thunderbird-into-the-ultimate-gmail-imap-client-314574.php

However, in my opinion the amateur end-users won't know what SMTP servers are, much less set them to something else. So since the wizard is meant to be as user-friendly as possible, maybe the default Gmail settings should still be set.


And there should be a list of notes somewhere on Google which says what IMAP features Gmail doesn't support.

Found it:
http://mail.google.com/support/bin/answer.py?answer=78761&topic=12762
Trash folder bug entry would be:

Bug 182274
(Assignee)

Comment 6

11 years ago
Adding the Gmail IMAP issues meta bug as dependency. Before we enable Gmail imap we should probably wait a bit until at least the most serious of them are fixed. (It's mostly server bugs in the end I think.)
Depends on: 402793
(Assignee)

Comment 7

11 years ago
Created attachment 288165 [details] [diff] [review]
proposed fix (WIP)

This adds the Gamil IMAP option to the list.
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Comment on attachment 288165 [details] [diff] [review]
proposed fix (WIP)

>+                <NC:trashFolderName>[Gmail]/Trash</NC:trashFolderName>

I'm still on the fence about it, but according to (around the middle of) http://lifehacker.com/software/geek-to-live/turn-thunderbird-into-the-ultimate-gmail-imap-client-314574.php Gmail's opinion is that using [Gmail]/Trash as the trash folder isn't a good idea.
(Assignee)

Comment 9

11 years ago
Yeah, still some stuff to figure out here. Ideally, and given the model they use, I would have expected mails that get marked as deleted to show up in Trash when they are "deleted" from the last "folder". Then just using the "Remove them immediately" option would have worked quite nicely.

International folder names could also cause some small trouble, but as I understand it only (part of) those with english gmail UI have IMAP access at this point.
(In reply to comment #9)
> International folder names could also cause some small trouble, but as I
> understand it only (part of) those with english gmail UI have IMAP access at
> this point.

You only need the english UI to enable IMAP. After that one can switch back to german or whatever. But then the Folder names are [Google Mail]/Papierkorb depending on the locale.
The settings wizard should also handle the difference between gmail.com and googlemail.com, because both the server and the IMAP Folder names need to be changed.

Comment 11

11 years ago
I believe we should default the Gimap delete setting to 'Remove immediately'.  

It is probably best to default the Drafts folder to the 'Local Folders' account, because of bug #402132, at least until Google provides either UIDPLUS or search by Message-ID.

Comment 12

11 years ago
Isn't this related to bug #182274?

Comment 13

11 years ago
yes Imap tends to be a bit nicer than pop by default pop marks all msgs read if you have leave on server most newbs wont set this also imap tends to be handier in roaming and or dual boot I/E Linux / Windoze and or multiple machines. 

with pop owning multiple machines and having to run slow sync software can be a royal pain , and if you use the web ui for while your at a work pc no biggy all your read or unread stay synced and folders on desktop laptop and web stay nice nice , and linux dosent thunderbird and windows thunderbird dosent become a blackhole like pop mail can 

anyhow it'd be a royal plus to explit the hell out of imap since it always has ben better then pop but in the past a bit slow due to the bandwith but with hi speed so pervasive thease days the few extra secouds is priceless for all the system bouncing a IT security admin like myself dose .  in the end imap saves me countless hours.
(In reply to comment #11)
> It is probably best to default the Drafts folder to the 'Local Folders' account,
> because of bug #402132, at least until Google provides either UIDPLUS or search by Message-ID.

FYI.
"search by Message-ID" problem seems to have been fixed by Gmail IMAP.
See Bug 402132 Comment #16 on 2007-12-08.

Comment 15

11 years ago
Another recommendation I'd like to make is to default the [Gmail]/Spam folder, [Gmail]/Sent Mail folder and [Gmail]/Drafts folder to be the defaults for Thunderbird's Junk, Sent and Drafts folders, respectively.

Comment 16

11 years ago
I would not favor defaulting IMAP Gmail folders to T-bird folders. That sounds as if you are defeating the purpose of choosing IMAP over POP. IMAP allows for keeping multiple devices (desktop pc, portable pc, handhelds like smart phones, iphones, etc.) sync whereas POP doesn't.

(In reply to comment #15)
> Another recommendation I'd like to make is to default the [Gmail]/Spam folder,
> [Gmail]/Sent Mail folder and [Gmail]/Drafts folder to be the defaults for
> Thunderbird's Junk, Sent and Drafts folders, respectively.
> 

Comment 17

11 years ago
I was not talking about making that the default for the global folders. What I meant was that, when setting up a GMail IMAP account, the account-specific options for Junk, Sent and Drafts should use [Gmail]/Spam, [Gmail]/Sent Mail and [Gmail]/Drafts so that these things would be automatically synced to any other client that was using Gmail IMAP. (Having access to all Sent Mail and Drafts on all machines is a godsend). I know that it is possible to configure this by hand, but I think that it should be the default in order to make configuration simpler for the average end-user.

Comment 18

11 years ago
OK, I understand you now.

(In reply to comment #17)
> I was not talking about making that the default for the global folders. What I
> meant was that, when setting up a GMail IMAP account, the account-specific
> options for Junk, Sent and Drafts should use [Gmail]/Spam, [Gmail]/Sent Mail
> and [Gmail]/Drafts so that these things would be automatically synced to any
> other client that was using Gmail IMAP. (Having access to all Sent Mail and
> Drafts on all machines is a godsend). I know that it is possible to configure
> this by hand, but I think that it should be the default in order to make
> configuration simpler for the average end-user.
> 

Flags: wanted-thunderbird3?

Comment 19

11 years ago
Let me post here my thoughts.
Realistically, the IMAP interface for GMail is very different from a normal one.
It seems to me that ideal client behavior would be the following:

The spam filter be disable for just the Gmail account. For many people Google's own spam features are enough, and TB's on top of it just adds complication. Obviously it should be possible to use it if desired. Either which way, the "Junk" button in the interface should move the message to [Gmail]/Spam.
Ideally, when in the [Gmail]/Spam folder, the Not junk UI feature would be availible, which would IMAP "move" the message to the Inbox folder.

Sent mail should be copied to [Gmail]/Sent Mail only if the Gmail Smtp is not being used.

Draft messages should be saved to [Gmail]/Drafts, and messages in that folder should be recognised as drafts, allowing them to be open for continued editing.


All Special delete handling such as the keeping a local copy of deleted messages should be disabled. Those features really mess with GMail's IMAP features.
The button that sends the IMAP delete button should actually have several personas. When in the Inbox folder, it should be labeled "Archive", when in a tag folder, it should be labeled "Remove Tag", and when in the in the [gmail]/Trash or [gmail]/Spam folder it should be labled "Purge".

A new Interface button should be added labeled "Delete" that simply Does an IMAP move of the selected messages to [Gmail]/Trash. This button should be disabled in the [Gmail]/Trash folder and the [Gmail]/Spam folder.

Finally, a new interface button labled "Tag" should be added. When clicked it would display a list of the IMAP folders, possibly excluding the "[Gmail]/*" folders. Selecting a folder would result in an IMAP "move" of the selected message(s)  to the chosen folder.


If all the above were done, the interface would be highly sensible and work well. (Except for errors on my part due to misunderstanding the gmail IMAP equivalency chart).  as it stands right now, configuring Tb to do all those things is almost impossible. Some are easy enough to do, but others basically need extensions currently.

Comment 20

11 years ago
(In reply to comment #19)
> Finally, a new interface button labled "Tag" should be added. When clicked it
> would display a list of the IMAP folders, possibly excluding the "[Gmail]/*"
> folders. Selecting a folder would result in an IMAP "move" of the selected
> message(s)  to the chosen folder.
That is a bad idea.  Tags and folders are very different in Thunderbird.  The intended use is, apparently, to provide an interface to move messages between user-label folders, but that already exists.  Even if it is labelled "Label" to avoid confusion with tags, it does not provide any new function.

Thunderbird stores tags as IMAP flags on the message. 

> All Special delete handling such as the keeping a local copy of deleted
> messages should be disabled. Those features really mess with GMail's IMAP
> features.
In other words, the default delete model should be "Remove immediately".

> The button that sends the IMAP delete button should actually have several
> personas. When in the Inbox folder, it should be labeled "Archive", when in a
> tag folder, it should be labeled "Remove Tag", and when in the in the
> [gmail]/Trash or [gmail]/Spam folder it should be labled "Purge".
I think all of this can be summarised by changing the Delete button label to "Remove", if the delete model is not "Move to Trash".  

> A new Interface button should be added labeled "Delete" that simply Does an
> IMAP move of the selected messages to [Gmail]/Trash. This button should be
> disabled in the [Gmail]/Trash folder and the [Gmail]/Spam folder.
> 
An interesting idea, but I think it would be better to allow an accelerator key to modify the delete model.  E.g., holding down the 'Ctrl' key could force the "Move to Trash" action.

Comment 21

11 years ago
(In reply to comment #20)

>That is a bad idea.  Tags and folders are very different in Thunderbird.
>The intended use is, apparently, to provide an interface to move messages
>between user-label folders, but that already exists.  Even if it is
>labelled "Label" to avoid confusion with tags, it does not provide
>any new function.

Yes, but it makes one of the fundamental actions in the Gmail e-mail paradigm easier, and more noticeable. Despite the terminology conflict, any Gmail user will recognize the folders as being Gmail tags, and would be looking for a way to add tags or remove tags. At the very least, having some way to easily add what Gmail calls tags to a message would be quite desirable.

>In other words, the default delete model should be "Remove immediately".
Exactly. 

>I think all of this can be summarised by changing the Delete button label
>to "Remove", if the delete model is not "Move to Trash".  
That would work. I have a slight preference for the context sensitive labels, but that is just me.

>> A new Interface button should be added labeled "Delete" that simply Does an
>> IMAP move of the selected messages to [Gmail]/Trash. This button should be
>> disabled in the [Gmail]/Trash folder and the [Gmail]/Spam folder.
>> 
>An interesting idea, but I think it would be better to allow an accelerator key
>to modify the delete model.  E.g., holding down the 'Ctrl' key could force the
>"Move to Trash" action.
Reasonable enough. It may be nice if the label on the button changed while holding down 'ctrl' so people could have a chance to discover this feature without just hearing about it.

Did you have an comments on making the exisitng spam filter optional for Gmail. (Gmail's spam filters are so good, they are all most people would ever need, so the local one would probably just get in the way). Or about having the (un)mark as spam feature integrate with the Imap spam folder. (So there is a button that a user can push to easily let Gmail know a message is (not) spam).

What about my assessment of the sent items folder and drafts folder?


(In reply to comment #21)
To unknown_kev_cat@hotmail.com:
Please don't confuse terms, and please don't misuse terms. 
 (a) Gmail's term of "Label"(==Mail folder name/structure in Gmail IMAP)
 (b) Tb's term of "tag", which Gmail never uses, which is called "flag"
     or "keyword" in protcol definition of IMAP
 (c) Tb's term of "label" used before Thunderbird 2.0, which is called "tag"
     by Th 2.0 or after.
Duplicate of this bug: 436233

Comment 24

11 years ago
How about combining GMAIL folders with Thunderbird tags in this way:
* Import GMAIL folders as Thunderbird tags
* When setting a tag in Thunderbird also do a IMAP move to corresponding folder in GMAIL (which would set the GMAIL tag on the message)
* If a message appear in a GMAIL folder also automatically apply the corresponding Thunderbird tag
(Assignee)

Updated

11 years ago
Priority: -- → P1
Depends on: 450227
(Assignee)

Comment 25

10 years ago
Created attachment 340788 [details] [diff] [review]
proposed fix, v2

In wait of the new account setup, here is an updated version. This patch
 - adds the Gmail IMAP option to the list of account types
 - makes it possible for ISPs to have several account types in a file - bug 65715

It 
 - sets up drafts to be in [Gmail]/Drafts
 - uses IMAP delete model: "remove it (from view) immediately", but sets the predefined folder to [Gmail]/Trash for convenience if someone wants to change it
 - don't store a copy in Sent (since gmail takes care of that for you), but sets the sent mail folder to [Gmail]/Sent in case someone wants to change it

---

I don't know what's up with having to use <NC:FccFolder> and not <NC:fccFolder>... but this way it works.
Attachment #340788 - Flags: superreview?(bienvenu)
Attachment #340788 - Flags: review?(bienvenu)

Updated

10 years ago
Attachment #340788 - Flags: superreview?(bienvenu)
Attachment #340788 - Flags: superreview+
Attachment #340788 - Flags: review?(bienvenu)
Attachment #340788 - Flags: review+

Comment 26

10 years ago
Comment on attachment 340788 [details] [diff] [review]
proposed fix, v2

this looks OK, thx, Magnus.
(Assignee)

Comment 27

10 years ago
changeset:   530:def009b7345c
http://hg.mozilla.org/comm-central/rev/def009b7345c

->FIXED

I don't have access to a google mail account, so I hope someone who does can verify that it works. (It's the same settings as gmail, only replacing gmail with googlemail.)
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Flags: wanted-thunderbird3? → wanted-thunderbird3+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b1

Updated

10 years ago
Blocks: 458770
(Assignee)

Updated

10 years ago
Depends on: 505589

Updated

9 years ago

Comment 28

a year ago
(In reply to Magnus Melin from comment #25)
>  - sets up drafts to be in [Gmail]/Drafts
>  - uses IMAP delete model: "remove it (from view) immediately", but sets the
> predefined folder to [Gmail]/Trash for convenience if someone wants to
> change it
>  - don't store a copy in Sent (since gmail takes care of that for you), but
> sets the sent mail folder to [Gmail]/Sent in case someone wants to change it

Magnus, are you able to look at bug 1322068? We can test as we have a Gmail account.
You need to log in before you can comment on or make changes to this bug.