Formulation of the EULA makes the product unusable.

RESOLVED FIXED

Status

mozilla.org
Licensing
--
critical
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: jpinon, Assigned: harvey anderson)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.14) Gecko/20080404 Iceweasel/2.0.0.14 (Debian-2.0.0.14-2)
Build Identifier: Unable to display, product unusable.

New paragraph 4 of EULA is unacceptable by me (and lot of others) as it require I accept terms that may change in the future. I cannot accept to be bound to a policy that may change without my consent.

Reproducible: Always

Steps to Reproduce:
Install firefox 3.0, read the EULA.
Actual Results:  
Did not continue the installation.

Expected Results:  
No part of the EULA should depend of accepting a policy that may change without user consent. The previous EULA (version 1.1 : http://www.mozilla.com/en-US/legal/eula/firefox-en.html) did not contain such a clause.
Assignee: nobody → hecker
Component: Installer → Licensing
Product: Firefox → mozilla.org
QA Contact: installer → gerv
Version: unspecified → other
(Assignee)

Comment 1

10 years ago
The intent is that the we may change the EULA in the future for future versions of the code. We can't unilaterally change the EULA that a User acccepted. We can update the language. We should also limit it to material changes. We make minor fixes all the time. The question is, if there's a new point release and a new EULA, should we force the User to accept the EULA again, as a way of presenting the changes. I'm thinking of the update process which doesn't display a EULA.
hja
Harvey: I think jpinon is referring specifically to paragraph 4, which relates to the privacy policy rather than the EULA itself. It reads:
(http://www.mozilla.com/en-US/legal/eula/firefox3-en.html)

"4. PRIVACY POLICY. You agree to the Mozilla Firefox Privacy Policy, made available online at http://www.mozilla.com/legal/privacy/, as that policy may be changed from time to time. When Mozilla changes the policy in a material way a notice will be posted on the website at www.mozilla.com and when any change is made in the privacy policy, the updated policy will be posted at the above link. It is your responsibility to ensure that you understand the terms of the privacy policy, so you should periodically check the current version of the policy for changes."

I think it's that last sentence he objects to.

Gerv

(Assignee)

Comment 3

10 years ago
Understood. Proposed change:
1. Take out "You agree to the policy". We don't need them to actually agree to the privacy policy, as it is our policy. And take out the last sentence. 

2. The ironic part of this, is that on privacy, when we do make material changes, there is a substantial and real discussion in advance of any such change, unlike any organization I've seen elsewhere. 
So, then:

"4. PRIVACY POLICY. The Mozilla Firefox Privacy Policy is made
available online at http://www.mozilla.com/legal/privacy/, and may
be changed from time to time. When Mozilla changes the policy in a material way
a notice will be posted on the website at www.mozilla.com, and when any change
is made in the privacy policy, the updated policy will be posted at the above
link."

jpinon: How does that look to you?

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

10 years ago
This looks quite acceptable, thanks.
Great. Harvey: do you need anything else from us here?

Gerv
Assigning to Harvey, as he's the person who can fix this.

Gerv
Assignee: hecker → handerson
(Assignee)

Comment 8

10 years ago
Created attachment 328653 [details]
Updated EULA July 8 2008

Attached is revised EULA. Cbrady, will you double check the attached against the existing final. 

Adding Mike B to make sure this gets into the next builds.
(Assignee)

Updated

10 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

10 years ago
Status: ASSIGNED → NEW

Comment 9

10 years ago
Harvey & Mike,

Please do no institute this change to the EULA yet.  We still have another open bug on the EULA with a draft I submitted a few weeks ago and am still awaiting comments from Mike, etc.  We should incorporate all changes at the same time.

Comment 10

10 years ago
Created attachment 331181 [details]
Updated Firefox 3.x EULA (July 2008)

Updated EULA. If no other comments should be good to include in next release.
Duplicate of this bug: 439604
Bug 462254, which removes the EULA, has landed for Firefox 3.0.5 and Firefox 3.1. I think we can call this fixed now.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Depends on: 462254
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.