Closed Bug 440552 Opened 12 years ago Closed 12 years ago

Auto-detect online status based on network interface status

Categories

(Thunderbird :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: davida, Assigned: Bienvenu)

References

Details

Attachments

(1 file, 1 obsolete file)

If my net connection drops, thunderbird should automatically and gracefully go into offline mode (and not ask to download, as that would be pointless).

We need nsINetworkLinkService for OS X before we can do this, though.
Flags: blocking-thunderbird3+
Attached patch trivial pref change for mac (obsolete) — Splinter Review
Update:

 - OS X now can support this, and I'll submit a patch to enable the Windows behavior on Mac.

 - Linux can't support this until NetworkManager can be trusted, which is hard according to 424626

 - If the Linux user can trust NetworkManager,  the pref "toolkit.networkmanager.disable" should be set to false, as well as the offline.autoDetect pref set to true.
Attachment #341992 - Flags: review?
Attachment #341992 - Flags: review? → review?(bienvenu)
Comment on attachment 341992 [details] [diff] [review]
trivial pref change for mac

or I think we we could now just do #ifdef XP_UNIX
pref("offline.atoDetect", false);
#else
#endif
Comment on attachment 341992 [details] [diff] [review]
trivial pref change for mac

I'll attach a tweaked patch
Assignee: nobody → bienvenu
Attachment #341992 - Attachment is obsolete: true
Attachment #343309 - Flags: review?(bugzilla)
Attachment #341992 - Flags: review?(bienvenu)
Attachment #343309 - Flags: review?(bugzilla) → review+
I'm going to create a separate bug for creating an exception behavior for Linux users.  This patch seems fine as is, however I think we can turn on Linux auto-detect with an added speed bump.
landed
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Bryan, if you could reference the linux bug here, that might help.
bug 460363 has the exception for linux users
Duplicate of this bug: 381187
You need to log in before you can comment on or make changes to this bug.