Display an internal error message upon encountering a blank (0-length) HTTP error page

RESOLVED DUPLICATE of bug 482874

Status

()

Core
Networking: HTTP
RESOLVED DUPLICATE of bug 482874
10 years ago
2 years ago

People

(Reporter: Daniel Zupo, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; pt-BR; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; pt-BR; rv:1.9) Gecko/2008052906 Firefox/3.0

many pages not display the message of page not found when receive a 404 error.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
The server sends zero content for the 404-
Shouldn't we display an internal error page if the server responds with an empty response for a 404 ?

HTTP Status Code: HTTP/1.1 404 Not Found
Connection:	close	
Date:	Fri, 27 Jun 2008 16:42:57 GMT	
Server:	Microsoft-IIS/6.0	
IISExport:	This web site was exported using IIS Export v4.1	
X-Powered-By:	ASP.NET	
Content-Length:	0	
Content-Type:	text/html	
Expires:	Fri, 27 Jun 2008 16:41:57 GMT	
Set-Cookie:	ASPSESSIONIDQSBDBQQD=LMLNDEICAKLAFGEMNJACLKND; path=/	
Cache-control:	private
Status: UNCONFIRMED → NEW
Component: General → Networking: HTTP
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → networking.http
Version: unspecified → Trunk

Updated

10 years ago
Severity: normal → enhancement
Summary: Many pages not display the message of page not found when receive a 404 error → Display an internal error message upon encountering a blank (0-length) 404 page
Duplicate of this bug: 452222
Duplicate of this bug: 454006
Severity: enhancement → normal
Duplicate of this bug: 466791
Summary: Display an internal error message upon encountering a blank (0-length) 404 page → Display an internal error message upon encountering a blank (0-length) HTTP error page
Blocks: 484787

Updated

8 years ago

Comment 5

8 years ago
Created attachment 480930 [details] [diff] [review]
Patch to show internal error pages for HTTP error in the 400/500 range

Based on Curtis' patch in bug 482874 I created a similar patch to show error pages for all types of HTTP errors.

I left in the possibility to configure the maximum amount of server-side message length to trigger the override, though the default is 0.

I removed all references to 404.

The texts could surely stand some improvement, I basically copied the first sentences from RFC 2616.

When the patch for bug 482874 is landed, this one could be updated to use the same code then.

Comment 6

8 years ago
Comment on attachment 480930 [details] [diff] [review]
Patch to show internal error pages for HTTP error in the 400/500 range

Asking ehsan for review, as he also looked into the original patch at bug 482874.
Attachment #480930 - Flags: review?(ehsan)
Comment on attachment 480930 [details] [diff] [review]
Patch to show internal error pages for HTTP error in the 400/500 range

Sorry, I only reviewed that patch for RTL concerns, and I'm not the best person to review this one.  I'll forward your request to Boris and Axel tentatively.
Attachment #480930 - Flags: review?(ehsan)
Attachment #480930 - Flags: review?(community)
Attachment #480930 - Flags: review?(bzbarsky)
Why don't we just land the patch from bug 482874 instead of duplicating parts of it?
Comment on attachment 480930 [details] [diff] [review]
Patch to show internal error pages for HTTP error in the 400/500 range

Per comment 8....
Attachment #480930 - Flags: review?(bzbarsky) → review-
Attachment #480930 - Flags: review?(community)

Updated

7 years ago
OS: Windows 2000 → All
Duplicate of this bug: 876682

Comment 11

5 years ago
There is a patch from 2011, so it wasn't applied to release versions?

As far as I know Firefox is the only browser that simply displays a blank page instead of relaying HTTP error messages to the user.
It wasn't applied, correct.  It failed to pass the code review process...

If you're interested in this, I suggest driving bug 482874 in.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 482874
You need to log in before you can comment on or make changes to this bug.