Google Gears not yet supported for Mozilla Prism

RESOLVED WONTFIX

Status

--
major
RESOLVED WONTFIX
10 years ago
8 years ago

People

(Reporter: feranick, Assigned: matthew.gertner)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0
Build Identifier: 0.9

Google Gears already supports Firefox 3.0, but not Prism. Given the stand-alone character of Prism, having the ability of using it for offline document editing is a big plus, but currently unavailable on Prism, and thus making it less appealing than, say, the full featured Firefox 3.0.

Reproducible: Always

Steps to Reproduce:
1. Setup a Google Docs (or Google Reader) with Prism
2. Select the offline option
3. A screen will pop-up asking to install Google Gears
4. Go ahead with the installation
Actual Results:  
The Google gears page pops up, saying the browser (Prism) isn't supported by Google Gears.

Expected Results:  
Google Gears should install, and offline caching should then work.

Tested both with vanilla version 0.9 from mozilla labs on Ubuntu 8.04.1 and version 0.8-svn20071115r8030-ubuntu3 from the Ubuntu standard repositories, with identical results.
(Assignee)

Updated

10 years ago
Duplicate of this bug: 435794
(Assignee)

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
(Assignee)

Comment 2

10 years ago
See http://otaqui.com/blog/382/enable-google-gears-and-offline-gmail-for-mozilla-prism/. Looks like it's just a question of modifying install.rdf. I'll confirm and see if there's some way I can file this as a Gears bug.
Assignee: nobody → matthew.gertner
Status: NEW → ASSIGNED
(Assignee)

Comment 3

10 years ago
Ok I filed a Gears bug: http://code.google.com/p/gears/issues/detail?id=811

Comment 4

10 years ago
Looks like that you patch for Gears has been accepted (http://code.google.com/p/gears/issues/detail?id=704)

Do you have any idea if and when it'll be integrated in the official Gears distribution?
(Assignee)

Comment 5

10 years ago
No idea. That depends on Google, not us.

Comment 6

10 years ago
I know it depends on Google, I was just wondering whether you had any feedback from them or they just accepted the patch and didn't say anything.
(Assignee)

Comment 7

10 years ago
The latter. I didn't get any bugmail or anything.
(Assignee)

Updated

9 years ago
Duplicate of this bug: 493419

Comment 9

9 years ago
Shouldn't this be marked as WONTFIX?
(Assignee)

Comment 10

9 years ago
Ok I closed this. I'm not sure what the status is with the latest version of Gears, but it really is a Gears issue, not a Prism issue (unless we were to decide to impersonate Firefox).
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX

Updated

8 years ago
You need to log in before you can comment on or make changes to this bug.