Closed Bug 444703 Opened 12 years ago Closed 11 years ago

Monitor category for specific language

Categories

(support.mozilla.org :: Knowledge Base Software, task, major)

task
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: cilias, Assigned: ecooper)

References

Details

(Whiteboard: tiki_feature, tiki_upstreamed, tiki_test)

Attachments

(2 files, 2 obsolete files)

Maybe I'm the only that would use this but...
Instead of monitoring each page individually, it would be great if I had one watch that monitored all English pages in the KB.
an rss feed would be great
Note: There is already monitoring for an entire category in tiki-browse_categories.php. (i.e. <http://support.mozilla.com/tiki-browse_categories.php?locale=en-US&parentId=11>) The display of browse_categories.php was changed to only display one locale (bug 422834). Making the watch do the same should fix this.
Blocks: 463059
Eric, do you think this can be squeezed into 0.7.3? This is a key reason why many approvers are not reviewing other people's edits.
-->0.7.3 for triage
Target Milestone: --- → 0.7.3
Target Milestone: 0.7.3 → 0.9
For anyone cc'ed to this bug: this had to be moved to 0.9 because of lack of resources to get this fixed for the upcoming 0.7.3 release. Eric, obviously if you find any spare time and don't have any other 0.8 bugs left to fix, feel free to take this one and we might be able to move it up to e.g. 0.8.1. :)
Assignee: nobody → smirkingsisyphus
Moving this to 0.8.1 mostly to indicate that this is a priority. I don't yet know when this milestone is planned.

This bug is definitely wanted asap as many localizers are requesting it.
Target Milestone: 0.9 → 0.8.1
Would this just be for wiki pages being edited, then? If so, we could set something similar up to the "Watch language wiki page creations" found in tiki-user_watches.php.
Hello, the main priority for me (but I think this is a common need) is to check the English knowledge base to apply the last changes to the other languages.

Very often, when reading a page translated in Italian by me or by one of my peer localizers, I found the warning that the page content may not be up to date. And currently there is no way to keep notified about these changes.

So, this is something concerning the users' perception of the QUALITY of the KB: the changes may be of very slight entity (e.g. "website" instead of "web site", as it happened in the last few days), but the user, from the other side, may think that the translation of the page is not well mantained - which is not true, in many cases.

Thanks for your attention.

Simon
Adding a language restraint to the category monitor could get messy and requires a few major changes to the watch functionality. A simpler, more direct approach is to set up a new watch that monitors page edits in a specific, user-defined language similar to how you can currently monitor page creations in a particular language. 

So, as an example, you can monitor all page edits made to pages in English even if your preferred locale is something like jp. The drawback to this would be that it would be all en pages you have access to instead of a particular category. Make sense?  

In any case, this should be moved to the next release (0.8.2?), just because any edits to the watch functionality edits the core tikilib and should be tested vigorously because of it (it's a library called every page load).
Target Milestone: 0.8.1 → 0.8.2
If I understand correctly, it would be set up like the watch for new translations, but for edits. If so, that's fine. (probably better, because locale leaders would have the same intructions for both watches)
I've been testing a patch locally for the last few days. 

Changes to staging articles are currently included in this watch. Is this ideal? Or should they be skipped?
Attachment #356352 - Flags: review?(nelson)
I think this is ideal because this watch is for locale leaders and they should be notified if staging articles are being worked on.  Although it could get spammy.  Do you know if the watch e-mails can be consolidated into a daily report?
(In reply to comment #11)
> Changes to staging articles are currently included in this watch. Is this
> ideal? Or should they be skipped?

The staging area is a category. If anyone wants to watch the staging area, they should create a watch for that.
(In reply to comment #12)
> I think this is ideal because this watch is for locale leaders and they should
> be notified if staging articles are being worked on.  Although it could get
> spammy.  Do you know if the watch e-mails can be consolidated into a daily
> report?

AFIK, tiki doesn't have a feature like that. Nelson?

(In reply to comment #13)
> The staging area is a category. If anyone wants to watch the staging area, they
> should create a watch for that.

Just to be clear, it would only be staging edits (and all other wiki edits) for a specific language with this new watch.
(In reply to comment #12)
> I think this is ideal because this watch is for locale leaders and they should
> be notified if staging articles are being worked on.  Although it could get
> spammy.  Do you know if the watch e-mails can be consolidated into a daily
> report?

A while ago we had decided against having a "ready for review" button as well as the save button so that editors could distinguish between revisions that were works in progress and edits that they actually wanted reviewed. Reconsidering this could eliminate spam more effectively and would make the alerts more useful as they'd be real time, not a daily digest (which might still have spam if an article isn't ready for review but has been revised).
(In reply to comment #14)
> Just to be clear, it would only be staging edits (and all other wiki edits) for
> a specific language with this new watch.

No, it is changing the current ability of watching a category, to be language specific. So remove the "(and all other wiki edits)" from the above.
Hmm...I was under the impression we were now going for something in comment 9 (as confirmed in comment 10), which is a language-specific watch for edits across all categories.

If I misunderstood, I'll toss the current patch and see if we can get something going ASAP. As I mentioned previously, adding a language restraint to category watches could get messy just in how tiki handles category watches.
I'm not against using the current patch if it already works and then patching a more refined way later also.  No need to toss hard work.
Attached patch Adds a language category watch (obsolete) — Splinter Review
This patch fulfills the original request of being able to watch a category in a specific language. So, contributors can now watch all edits to the Knowledge Base category in English...or Japanese or French or whatever. I tested this locally for a couple days, and it behaved as it should. This makes edits to the core tiki library, so it should be tested pretty heavily.

The UI for it was added to the watch page for the sake of simplicity; so all language related watches can be set from the same page. I'll post a screenshot shortly.
Attachment #356352 - Attachment is obsolete: true
Attachment #358635 - Flags: review?(nelson)
Attachment #356352 - Flags: review?(nelson)
Very, very open to change. Didn't spend any time on it because I'm under the impression we'll be revamping the UI in coming releases.
Attached patch v2Splinter Review
v2. Also takes care of bug 474641 (forcing https links in watch emails).

Nelson could you take a look at it make sure it's kosher?
Attachment #358635 - Attachment is obsolete: true
Attachment #360427 - Flags: review?(nelson)
Attachment #358635 - Flags: review?(nelson)
Blocks: 474641
Waiting on Nelson for patch review, pushing to 0.9.  Eric, you can reallocate this review to me if you want.
Target Milestone: 0.8.2 → 0.9
Comment on attachment 360427 [details] [diff] [review]
v2

Tossing review to Laura.
Attachment #360427 - Flags: review?(nelson) → review?(laura)
Comment on attachment 360427 [details] [diff] [review]
v2

Stephen, this needs lots of QA.  If we commit this do you have time for it before Thursday?
Attachment #360427 - Flags: review?(laura) → review+
(In reply to comment #24)
> (From update of attachment 360427 [details] [diff] [review])
> Stephen, this needs lots of QA.  If we commit this do you have time for it
> before Thursday?

Yup!
Bug 474641 can be tested in conjunction with this.

I had to make a small addendum to the patch to make sure notifications were sent when pages were created. It was a one line fix. Patch is in r22581/r22582.

Stephen this watch is based on category and language. The UI for it is under "My Watches". So someone watching the KB for English should only get email notifications when a KB page in en is changed (approving a staging version) or when a new KB article in en is added. We need to make sure this watch works and plays nicely with everything else.

Oh, and for wiki edits, you need to make sure the watcher is a different account than the editor or the email won't be sent (obviously).
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
When I make changes via https://support-stage.mozilla.org/tiki-user_watches.php?locale=en-US, they don't seem to stick; that is, they don't appear as an Event with its associated Object, as I would expect (I have prior watches set up successfully, and bug 474641 is verified thanks to those).

I think this might be something with the cookie-storing code, but I'm really stabbing in the dark; what makes me think so is that we're getting 304s for the cookies:

Cookie: __utma=150903082.1627896336.1235513845.1235513908.1235518723.3; __utmz=150903082.1235513845.1.1.utmccn=(direct)|utmcsr=(direct)|utmcmd=(none); dloadday=63.245.220.246.1235510703206756; s_cc=true; s_sq=%5B%5BB%5D%5D; SUMOv1=pedknamh8g1ro506jj6khjt2u7


(s_sq = Albanian, which is the language I had chosen to watch in the dropdown).

HTTP/1.x 304 Not Modified

Date: Wed, 25 Feb 2009 08:39:57 GMT

Server: Apache/2.2.3 (Red Hat)

Connection: Keep-Alive

Keep-Alive: timeout=5, max=998

Etag: "400b"

Expires: Wed, 25 Feb 2009 08:39:57 GMT

Cache-Control: max-age=0


I really, really don't have a clue (obviously), but this, coupled with bug 478685 and bug 479854 comment #9 is making me a very sad panda [1]

1. http://en.wikipedia.org/wiki/Sexual_Harassment_Panda
Hello and thanks alot for having fixed this bug. 

Could someone please create a new page and change another one in the en-us KB? Just to make a test "on the field".

Thank you again.
(In reply to comment #27)
> I really, really don't have a clue (obviously), but this, coupled with bug
> 478685 and bug 479854 comment #9 is making me a very sad panda [1]
> 
> 1. http://en.wikipedia.org/wiki/Sexual_Harassment_Panda

Being unable to save new watches is a symptom of bug 479854.
I can't save new watches either. (adding dependency)
Depends on: 479854
Excuse me, is it really fixed?

I did not received any notification for changed en-US KB articles...
Simone, did you test on support-stage.mozilla.org or support.mozilla.com?

Under my contributor account, I set up a watch for "waiting for review" in Finnish. Then using my admin account, I made an edit to <https://support-stage.mozilla.org/kb/*Firefoxin+asentaminen+Macille?bl=n>, and I got an email notification.
I was testing support.mozilla.com

Sorry, I did not understand the patch was not passed in the production environment.

Thanks.
(In reply to comment #33)
> I was testing support.mozilla.com
> 
> Sorry, I did not understand the patch was not passed in the production
> environment.
> 
> Thanks.

Simone: mind testing on support-stage?  We could use the help; thanks!
Stephen, I enabled the option for en-us language and I've just been notified about one test article.

It seems to be allright. 

Thank you very much and excuse me for my misunderstanding - bad day...
Depends on: 480415
I now can't create any other kinds of watches.
Status: RESOLVED → REOPENED
Keywords: regression
Resolution: FIXED → ---
I just created wiki_edit watches watches on local, staging, and prod, so I'm confused.
Depends on: 480631
I don't understand what is not working, aside from bug 480631.
Here's a screencast. <http://ilias.ca/flashback/addwatch.swf>
(In reply to comment #38)
> I don't understand what is not working, aside from bug 480631.
> Here's a screencast. <http://ilias.ca/flashback/addwatch.swf>

My bug(s) seem(s) to be that while I can create any number of watches, I most often don't get notifications for them (and yes, I'm making changes with a different user account).
Using a test contributor account, I created a watch for English articles in the sandbox category (I even gave the account a different email address). Using my admin account, I edited <https://support.mozilla.com/kb/sandbox+article?bl=n>, and I got a notification.
(In reply to comment #39)
> (In reply to comment #38)
> > I don't understand what is not working, aside from bug 480631.
> > Here's a screencast. <http://ilias.ca/flashback/addwatch.swf>
> 
> My bug(s) seem(s) to be that while I can create any number of watches, I most
> often don't get notifications for them (and yes, I'm making changes with a
> different user account).

Stephen, do you want to set aside a day this week where you and I can go at this in a concerted effort? Hopefully, we can narrow the scope of the issue and figure out if it's something related to the patch or just tiki in general...or staging.

I refrained from making Captain Planet references.
(In reply to comment #41)

<snip>

> Stephen, do you want to set aside a day this week where you and I can go at
> this in a concerted effort? Hopefully, we can narrow the scope of the issue and
> figure out if it's something related to the patch or just tiki in general...or
> staging.
> 
> I refrained from making Captain Planet references.

Yeah, let's do that.  Just catch me online and we'll go through it together.  It's driving me nuts that I'm not seeing what others are seeing (and I'm sure I'm driving everybody else nuts along with me, too).

I totally watched Captain Planet when I was younger; hopefully I'd get the reference!
Target Milestone: 0.9 → 1.0
Resolving to fix'd as per Stephen in IRC. Reopen if it acts up again, please.

A spin-off bug has been filed at bug 481316.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
No longer depends on: 480415, 480631
Resolution: --- → FIXED
I'm reopening again, sadly; Eric and I looked at this earlier and it didn't work for me (but did for him).  He's going to add some debug logging to tiki-editpage.php to ensure that my test nickname is included in the list of email addresses to which to send.

Note that we're also struggling with bug 480415, which might be a part of this problem?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Resolving again.

A new bug should be filed for missing watch emails if it can be verified after the timeouts are taken care of.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Verified.
Status: RESOLVED → VERIFIED
Sorry, but is this fix supposed notify even the "rollback" actions? 

On 03/28 I saw Chris made a rollback to a previous version of this article:

https://support.mozilla.com/it/kb/Unable+to+install+add-ons?bl=n

and I don't seem to have received any notification about it.

Thanks in advance.
Keywords: regression
Whiteboard: tiki_feature
Whiteboard: tiki_feature → tiki_feature, tiki_upstreamed
Has this really been upstreamed?

Definitely a desired feature of Tiki5
Whiteboard: tiki_feature, tiki_upstreamed → tiki_feature, tiki_upstreamed, tiki_test
Severity: normal → major
You need to log in before you can comment on or make changes to this bug.