Closed Bug 445185 Opened 12 years ago Closed 12 years ago

Switch unit test boxes to comm-central builds

Categories

(SeaMonkey :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kairo, Assigned: kairo)

References

(Depends on 1 open bug)

Details

The SeaMonkey unit test boxes should be switched to run on comm-central once it goes live, the config for them will move over to hg.mozilla.org/build/buildbot-configs subdir seamonkey.unittest. This needs an upgrade of buildbot to trunk on all those boxes, so I can't set up the new config in parallel, will need to work on that once comm-central is live.
http://hg.mozilla.org/build/buildbot-configs/index.cgi/file/tip/seamonkey-unittest/ has preliminary configs for those builds, modeled largely after the build machines configs and using buildbotcustom. That config is completely untested though, as I only can do that in production once the new comm-central is live.
The config has been updated to a state that runs, but all the boxes are orange now.

Linux crashes in mochichrome tests.
Mac fails (at least) 1 TUnit test and aborts, fails 1 reftest, and crashes in mochichrome tests.
Windows fails (at least) 6 TUnit tests and aborts, and fails 1 mochichrome test.
Update:

Linux and Windows are passing all tests (look at the numbers) and are orange only for leaks, bonus points for fixing those!

Mac is orange for two failures:
1) TUnit failure on the test from bug 378991 - FF is running 10.5 and succeeding, we are running 10.4 and failing, is this a Leopard vs. Tiger problem?
2) a reftest fails due to a tiny color glitch, see bug 378217 comment #95 for detailed analysis.
Depends on: 448126
(In reply to comment #3)
> Update:
> 
> Linux and Windows are passing all tests (look at the numbers) and are orange
> only for leaks, bonus points for fixing those!

I filed bug 448125.

> Mac is orange for two failures:
> 1) TUnit failure on the test from bug 378991 - FF is running 10.5 and
> succeeding, we are running 10.4 and failing, is this a Leopard vs. Tiger
> problem?

Mark filed bug 447999.

> 2) a reftest fails due to a tiny color glitch, see bug 378217 comment #95 for
> detailed analysis.

I filed bug 448121.

***

I filed bug 448126 too, on a MacOSX (profile related !?) focus issue.
Depends on: 447999, 448121
Depends on: 448137
Depends on: 448537
Depends on: 449533
Depends on: 450114
Setting the bug itself to FIXED, as the machines have been successfully switched to comm-central, we have dependent open bugs on the test failures, which are not about wrong setup of the machines, but actual tests failing.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
No longer depends on: 450114
Depends on: 451482
No longer depends on: 448537
BTW: There is one (new?) reftest failure on the Mac unit test box, it's
REFTEST TEST-UNEXPECTED-FAIL | file:///builds/slave/comm-central-macosx/build/mozilla/layout/reftests/forms/input-text-size-1.html
(In reply to comment #6)
> BTW: There is one (new?) reftest failure on the Mac unit test box, it's

(Not new:) See bug 449533 and its dependence.

NB: Don't add reports to this bug, file (blocking) bugs.
No need to tell me how to use Bugzilla.
Depends on: 454513
Depends on: 454587, 454582
No longer depends on: 454513
No longer depends on: 454582
No longer depends on: 449533
No longer depends on: 454587
No longer depends on: 447999
No longer depends on: 448121
No longer depends on: 448137
Depends on: 451090
You need to log in before you can comment on or make changes to this bug.