In <test_opener.html>, _intermittent_ "TEST-UNEXPECTED-FAIL / Should be able to navigate popup by targeted hyperlink.", on Linux

VERIFIED DUPLICATE of bug 451090

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 451090
10 years ago
7 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Notice
{{
Error loading URL http://test1.example.org/tests/docshell/test/navigation/blank.html : 804b0002 (NS_BINDING_ABORTED)

NEXT ERROR *** 19463 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_opener.html | Should be able to navigate popup by targeted hyperlink. - got Error: Permission denied for <http://localhost:8888> to get property Window.document from <http://test1.example.org>., expected "This frame was navigated."
}}

in
<http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1217419570.1217423305.11386.gz>
{{
Linux comm-central dep unit test on 2008/07/30 05:06:10

*** 19459 INFO Running /tests/docshell/test/navigation/test_opener.html...
Document http://test1.example.org/tests/docshell/test/navigation/blank.html loaded successfully
Document http://test1.example.org/tests/docshell/test/navigation/blank.html loaded successfully
Error loading URL http://test1.example.org/tests/docshell/test/navigation/blank.html : 804b0002 (NS_BINDING_ABORTED)
Document data:text/html,<html><body>This%20frame%20was%20navigated.</body></html> loaded successfully
Document data:text/html,<html><body>This%20frame%20was%20navigated.</body></html> loaded successfully
Document data:text/html,<html><body>This%20frame%20was%20navigated.</body></html> loaded successfully
Document data:text/html,<html><body>This%20frame%20was%20navigated.</body></html> loaded successfully
Document http://test1.example.org/tests/docshell/test/navigation/blank.html loaded successfully
*** 19460 INFO TEST-PASS | /tests/docshell/test/navigation/test_opener.html | Should be able to navigate popup by setting location.
*** 19461 INFO TEST-PASS | /tests/docshell/test/navigation/test_opener.html | Should be able to navigate popup by calling window.open.
*** 19462 INFO TEST-PASS | /tests/docshell/test/navigation/test_opener.html | Should be able to navigate popup by submitting form.
NEXT ERROR *** 19463 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_opener.html | Should be able to navigate popup by targeted hyperlink. - got Error: Permission denied for <http://localhost:8888> to get property Window.document from <http://test1.example.org>., expected "This frame was navigated."
}}

NB: I had noticed it previously, but not reported it as I was not sure about transient or intermittent.

*****

Fwiw, in the same (but may be all) build, we are not seeing bug 446197 (which runs just before):
{{
*** 19454 INFO Running /tests/docshell/test/navigation/test_not-opener.html...
[...]
*** 19455 INFO TEST-PASS | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open.
*** 19456 INFO TEST-PASS | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form.
*** 19457 INFO TEST-PASS | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink.
}}
(Reporter)

Updated

10 years ago
Summary: In <test_opener.html>, _intermittent_ "TEST-UNEXPECTED-FAIL / Should be able to navigate popup by targeted hyperlink." → In <test_opener.html>, _intermittent_ "TEST-UNEXPECTED-FAIL / Should be able to navigate popup by targeted hyperlink.", on Linux

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 451090
No longer blocks: 438871, 445185
(Reporter)

Comment 2

7 years ago
V.Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.