Accepting an event via iTIP/iMIP email doesn't work

VERIFIED FIXED in 0.9

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Andreas Treumann, Assigned: dbo)

Tracking

unspecified
Bug Flags:
blocking-calendar0.9 +

Details

(Reporter)

Description

10 years ago
STEPS TO REPRODUCE:
===================

- open a iTIP/iMIP mail and push the 'Accept' button 

RESULT:
=======

- 'Accept', 'decline' and 'tentative' buttons stays visible
- the event is not added to the calendar

EXPECTED RESULT:
================

- the event should added in the calendar

REPRODUCIBLE:
=============

- always


Last build without this bug 20080707, first with this issue 20080708.

Possible caused by bug 442651 or bug 443157.
Flags: wanted-calendar0.9?
(Assignee)

Updated

10 years ago
Flags: wanted-calendar0.9? → blocking-calendar0.9+

Comment 1

10 years ago
Do you see any error messages in the Error Console?
(Reporter)

Comment 2

10 years ago
No, the Error Console is empty :-(
(Assignee)

Updated

10 years ago
Depends on: 431522
(Assignee)

Updated

10 years ago
Assignee: nobody → daniel.boelzle
(Assignee)

Comment 3

10 years ago
fixed with bug 431522

Cause has been that we've corrected getItem's behaviour the way that empty queries (i.e. the item is not in the calendar) are not an error any longer, but return with NS_OK (without any onGetResult call, like documented/defined in calICalendar.idl). The itip code that checks for an existing item has been wrong.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: regression
Resolution: --- → FIXED
Target Milestone: --- → 0.9
(Reporter)

Comment 4

10 years ago
Checked in build 2008071619 -> VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.